aboutsummaryrefslogtreecommitdiff
path: root/games/frogatto
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /games/frogatto
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile4
-rw-r--r--games/frogatto/files/patch-Makefile2
2 files changed, 2 insertions, 4 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 74e07ef1b729..93d2a058896d 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -27,9 +27,7 @@ USE_SDL= sdl image mixer ttf
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|-Werror||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,%lu,%u,' ${WRKSRC}/src/server.cpp
@${REINPLACE_CMD} -e 's,__linux__,__${OPSYS}__,' \
${WRKSRC}/src/clipboard.cpp
diff --git a/games/frogatto/files/patch-Makefile b/games/frogatto/files/patch-Makefile
index 72fc79ea8a2b..3f08bcd7243d 100644
--- a/games/frogatto/files/patch-Makefile
+++ b/games/frogatto/files/patch-Makefile
@@ -23,7 +23,7 @@
# Linker library options.
LIBS := $(shell pkg-config --libs x11 ) -lSDLmain \
- $(shell pkg-config --libs sdl glu glew SDL_image libpng zlib) -lSDL_ttf -lSDL_mixer
-+ $(shell pkg-config --libs sdl glu glew SDL_image libpng) -lSDL_ttf -lSDL_mixer
++ $(shell pkg-config --libs sdl glu glew SDL_image libpng) -lz -lSDL_ttf -lSDL_mixer
include Makefile.common