aboutsummaryrefslogtreecommitdiff
path: root/games/frogatto
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-16 16:09:15 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-16 16:09:15 +0000
commit5671b14afb3f8c18421ddd41f0f7a32817c44e3d (patch)
tree8fe5d5845648a4177013c69d8cad26b8d907eadd /games/frogatto
parent46861b31d94656e17a5cfee0728aeec20edbf945 (diff)
downloadports-5671b14afb3f8c18421ddd41f0f7a32817c44e3d.tar.gz
ports-5671b14afb3f8c18421ddd41f0f7a32817c44e3d.zip
Add patches to fix build with boost-1.48.0
PR: ports/156253 Submitted by: Alexander Churanov Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=296785
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile2
-rw-r--r--games/frogatto/files/patch-src-server.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 986f30eb6a74..08998014aab5 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -7,7 +7,7 @@
PORTNAME= frogatto
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.frogatto.com/files/
diff --git a/games/frogatto/files/patch-src-server.cpp b/games/frogatto/files/patch-src-server.cpp
new file mode 100644
index 000000000000..5304afd98839
--- /dev/null
+++ b/games/frogatto/files/patch-src-server.cpp
@@ -0,0 +1,11 @@
+--- src/server.cpp.orig 2012-03-12 10:21:03.000000000 +0300
++++ src/server.cpp 2012-03-12 10:21:15.000000000 +0300
+@@ -37,7 +37,7 @@
+ private:
+ void start_accept()
+ {
+- socket_ptr socket(new tcp::socket(acceptor_.io_service()));
++ socket_ptr socket(new tcp::socket(acceptor_.get_io_service()));
+ acceptor_.async_accept(*socket, boost::bind(&server::handle_accept, this, socket, boost::asio::placeholders::error));
+ }
+