aboutsummaryrefslogtreecommitdiff
path: root/games/fs2open
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-05-12 22:52:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-05-12 22:52:43 +0000
commit2f8c589c819928570c31af5c12b8a855e46a7d2b (patch)
treea029c77a622bfa92ac3db69172d0480c7abb8fce /games/fs2open
parent524ba73d43662ea9da0f4207a7a9e96d33483045 (diff)
downloadports-2f8c589c819928570c31af5c12b8a855e46a7d2b.tar.gz
ports-2f8c589c819928570c31af5c12b8a855e46a7d2b.zip
Notes
Diffstat (limited to 'games/fs2open')
-rw-r--r--games/fs2open/Makefile2
-rw-r--r--games/fs2open/files/patch-code_model_modelread.cpp19
2 files changed, 18 insertions, 3 deletions
diff --git a/games/fs2open/Makefile b/games/fs2open/Makefile
index 85b40287eb8d..9ea3fe17330a 100644
--- a/games/fs2open/Makefile
+++ b/games/fs2open/Makefile
@@ -16,7 +16,7 @@ LICENSE_PERMS= dist-mirror auto-accept
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libpng.so:graphics/png
-USES= cmake compiler:c++11-lang lua:51 jpeg openal pkgconfig sdl
+USES= cmake compiler:gcc-c++11-lib lua:51 jpeg openal pkgconfig sdl
USE_GITHUB= yes
GH_ACCOUNT= scp-fs2open
GH_PROJECT= fs2open.github.com
diff --git a/games/fs2open/files/patch-code_model_modelread.cpp b/games/fs2open/files/patch-code_model_modelread.cpp
index 2e17dcff88a8..aedb66f28f0d 100644
--- a/games/fs2open/files/patch-code_model_modelread.cpp
+++ b/games/fs2open/files/patch-code_model_modelread.cpp
@@ -1,4 +1,4 @@
---- code/model/modelread.cpp.orig 2020-02-10 13:38:06 UTC
+--- code/model/modelread.cpp.orig 2020-01-25 16:45:09 UTC
+++ code/model/modelread.cpp
@@ -5341,7 +5341,7 @@ void swap_bsp_sortnorms( polymodel * pm, ubyte * p )
}
@@ -9,7 +9,13 @@
{
#if BYTE_ORDER == BIG_ENDIAN
ubyte *p = (ubyte *)model_ptr;
-@@ -5397,7 +5397,7 @@ void swap_bsp_data( polymodel * /*pm*/, void * /*mode
+@@ -5394,10 +5394,13 @@ void swap_bsp_data( polymodel * /*pm*/, void * /*mode
+ }
+
+ return;
++#else
++(void)pm;
++(void)model_ptr;
#endif
}
@@ -18,3 +24,12 @@
{
#if BYTE_ORDER == BIG_ENDIAN
char *type_p = (char *)(buffer);
+@@ -5439,6 +5442,8 @@ void swap_sldc_data(ubyte * /*buffer*/)
+ shld_polys[i] = INTEL_INT(shld_polys[i]);
+ }
+ }
++#else
++(void)buffer;
+ #endif
+ }
+