aboutsummaryrefslogtreecommitdiff
path: root/games/garden-of-coloured-lights
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-19 11:24:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-19 11:24:49 +0000
commit86786105656375517fe3f809978100bf129c1656 (patch)
tree01df446ea55fa37c9f313f6eb570a18646c854cf /games/garden-of-coloured-lights
parent052f912ec027f2d714dfdb6c9f1a0d16ccd80e76 (diff)
downloadports-86786105656375517fe3f809978100bf129c1656.tar.gz
ports-86786105656375517fe3f809978100bf129c1656.zip
Garden of coloured lights is an old school 2D vertical shoot-em-up
with some innovative elements. Innovative graphics, soundtrack and game concept. The game itself is very challenging and as you progress, you will understand that you are dealing with a true piece of art... WWW: http://garden.sourceforge.net/
Notes
Notes: svn path=/head/; revision=422426
Diffstat (limited to 'games/garden-of-coloured-lights')
-rw-r--r--games/garden-of-coloured-lights/Makefile35
-rw-r--r--games/garden-of-coloured-lights/distinfo3
-rw-r--r--games/garden-of-coloured-lights/files/patch-src_stuff.c26
-rw-r--r--games/garden-of-coloured-lights/files/patch-src_stuff.h13
-rw-r--r--games/garden-of-coloured-lights/pkg-descr6
-rw-r--r--games/garden-of-coloured-lights/pkg-plist4
6 files changed, 87 insertions, 0 deletions
diff --git a/games/garden-of-coloured-lights/Makefile b/games/garden-of-coloured-lights/Makefile
new file mode 100644
index 000000000000..cd97acfae11d
--- /dev/null
+++ b/games/garden-of-coloured-lights/Makefile
@@ -0,0 +1,35 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= garden-of-coloured-lights
+PORTVERSION= 1.0.9
+CATEGORIES= games
+MASTER_SITES= SF/garden/garden/${PORTVERSION}/
+DISTNAME= garden-${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Old school 2D vertical shoot-em-up with some innovative elements
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= liballeg.so:devel/allegro
+
+GNU_CONFIGURE= yes
+USES= desktop-file-utils localbase
+INSTALLS_ICONS= yes
+
+DATADIR= ${PREFIX}/share/garden
+
+PORTDOCS= AUTHORS ChangeLog NEWS README
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/garden-of-coloured-lights/distinfo b/games/garden-of-coloured-lights/distinfo
new file mode 100644
index 000000000000..6788ada0d90c
--- /dev/null
+++ b/games/garden-of-coloured-lights/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474068270
+SHA256 (garden-1.0.9.tar.gz) = daf8732c229a4cc04f460514bff1ba05171faada9e19575c72a50a914f2352e3
+SIZE (garden-1.0.9.tar.gz) = 2714783
diff --git a/games/garden-of-coloured-lights/files/patch-src_stuff.c b/games/garden-of-coloured-lights/files/patch-src_stuff.c
new file mode 100644
index 000000000000..06cc90f62d71
--- /dev/null
+++ b/games/garden-of-coloured-lights/files/patch-src_stuff.c
@@ -0,0 +1,26 @@
+--- src/stuff.c.orig 2015-01-19 21:17:42 UTC
++++ src/stuff.c
+@@ -52,7 +52,7 @@ float decoy_table[ANGLE_1]; // not used
+ float cos_table[ANGLE_1];
+ float sin_table[ANGLE_1];
+
+-inline int xpart (int angle, int length);
++int xpart (int angle, int length);
+
+ void init_trig (void)
+ {
+@@ -67,12 +67,12 @@ void init_trig (void)
+
+ }
+
+-inline int xpart (int angle, int length)
++int xpart (int angle, int length)
+ {
+ return (cos_table[angle & 1023] * length);
+ }
+
+-inline int ypart (int angle, int length)
++int ypart (int angle, int length)
+ {
+ return (sin_table[angle & 1023] * length);
+ }
diff --git a/games/garden-of-coloured-lights/files/patch-src_stuff.h b/games/garden-of-coloured-lights/files/patch-src_stuff.h
new file mode 100644
index 000000000000..e1542d0d35dd
--- /dev/null
+++ b/games/garden-of-coloured-lights/files/patch-src_stuff.h
@@ -0,0 +1,13 @@
+--- src/stuff.h.orig 2015-01-19 20:19:08 UTC
++++ src/stuff.h
+@@ -24,8 +24,8 @@ int grand (int number);
+ int crandom (int number);
+ int turn_towards_angle (int angle, int tangle, int turning);
+ int turn_towards_xy (int x1, int y1, int x2, int y2, int angle, int turning);
+-inline int xpart (int angle, int length);
+-inline int ypart (int angle, int length);
++int xpart (int angle, int length);
++int ypart (int angle, int length);
+ int pulsate (int speed, int amount, int county);
+ int angle_difference (int a1, int a2);
+
diff --git a/games/garden-of-coloured-lights/pkg-descr b/games/garden-of-coloured-lights/pkg-descr
new file mode 100644
index 000000000000..fd56ce70699f
--- /dev/null
+++ b/games/garden-of-coloured-lights/pkg-descr
@@ -0,0 +1,6 @@
+Garden of coloured lights is an old school 2D vertical shoot-em-up
+with some innovative elements. Innovative graphics, soundtrack and
+game concept. The game itself is very challenging and as you progress,
+you will understand that you are dealing with a true piece of art...
+
+WWW: http://garden.sourceforge.net/
diff --git a/games/garden-of-coloured-lights/pkg-plist b/games/garden-of-coloured-lights/pkg-plist
new file mode 100644
index 000000000000..6d64c5d068a0
--- /dev/null
+++ b/games/garden-of-coloured-lights/pkg-plist
@@ -0,0 +1,4 @@
+bin/garden
+share/appdata/garden.appdata.xml
+share/applications/garden.desktop
+share/icons/hicolor/scalable/apps/garden.svg