aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris-qt/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-29 17:42:48 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-29 17:42:48 +0000
commit3b58c2d7da44724e171ba2e40eaf564d3f7504d8 (patch)
treeecac8578699643d830f8c0b726882a33e07b1e0a /games/gcompris-qt/Makefile
parent3d246f040cb2f45726541f6e98d30f6a02288744 (diff)
downloadports-3b58c2d7da44724e171ba2e40eaf564d3f7504d8.tar.gz
ports-3b58c2d7da44724e171ba2e40eaf564d3f7504d8.zip
Notes
Diffstat (limited to 'games/gcompris-qt/Makefile')
-rw-r--r--games/gcompris-qt/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/games/gcompris-qt/Makefile b/games/gcompris-qt/Makefile
new file mode 100644
index 000000000000..b2717cd7c9fc
--- /dev/null
+++ b/games/gcompris-qt/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= gcompris-qt
+DISTVERSION= 0.81
+CATEGORIES= games kde
+MASTER_SITES= http://gcompris.net/download/qt/src/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Educational games and activities for kids ages 2 to 10
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libBox2D.so:x11-toolkits/qml-box2d
+
+USES= cmake:outsource kde:5 tar:xz
+USE_KDE= doctools
+USE_QT5= core gui multimedia network qml quick sensors svg widgets \
+ xml xmlpatterns \
+ buildtools_build linguisttools_build qmake_build
+
+CMAKE_ARGS= -DQML_BOX2D_LIBRARY=${QT_QMLDIR}/Box2D.2.0
+
+.include <bsd.port.mk>