aboutsummaryrefslogtreecommitdiff
path: root/games/gemdropx
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-10 19:52:36 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-10 19:52:36 +0000
commitf7538634e7fe929a01ba0f2f59ba9c2713f119c4 (patch)
tree64f2d2ad8d8abe6f49ebc1ea4719674b69aef18f /games/gemdropx
parentefcfdfc44c00ba1aad2840cdded7563fc5eae118 (diff)
downloadports-f7538634e7fe929a01ba0f2f59ba9c2713f119c4.tar.gz
ports-f7538634e7fe929a01ba0f2f59ba9c2713f119c4.zip
- Add second MASTER_SITES entry
- Avoid pkg-plist due to short plist - Convert to OptionsNG - Give maintainership to submitter PR: ports/171270 Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=304062
Diffstat (limited to 'games/gemdropx')
-rw-r--r--games/gemdropx/Makefile57
-rw-r--r--games/gemdropx/files/patch-aa28
-rw-r--r--games/gemdropx/pkg-descr28
-rw-r--r--games/gemdropx/pkg-plist70
4 files changed, 56 insertions, 127 deletions
diff --git a/games/gemdropx/Makefile b/games/gemdropx/Makefile
index 2ef4a367db70..86b5c2840bac 100644
--- a/games/gemdropx/Makefile
+++ b/games/gemdropx/Makefile
@@ -7,26 +7,55 @@
PORTNAME= gemdropx
PORTVERSION= 0.9
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
-MASTER_SITES= ftp://ftp.billsgames.com/unix/x/gemdropx/src/
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/gemdropx/src/ \
+ ftp://ftp.billsgames.com/unix/x/gemdropx/src/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An interesting one-player puzzle game for X
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Interesting one-player puzzle game for X (SDL)
+
+LICENSE= GPLv2
+
+ALL_TARGET= ${PORTNAME}
+USE_SDL= image mixer sdl
-USE_SDL= mixer
USE_GMAKE= yes
-MAKE_ENV= JOY=NO
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.xmp
+
+PORTDATA= *
+PORTDOCS= AUTHORS.txt CHANGES.txt ICON.txt README.txt TODO.txt
+
+.include <bsd.port.options.mk>
+
+post-patch:
+# Fix SDL, CFLAGS
+ @${REINPLACE_CMD} \
+ -e 's|sdl-config|$(SDL_CONFIG)|' \
+ -e 's|CC=gcc|CC?=g++|' \
+ -e 's|CXX=gcc|CXX?=g++|' \
+ -e 's|CFLAGS=-Wall $(SDL_CFLAGS)|CFLAGS+=$(SDL_CFLAGS)|' \
+ ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gemdropx ${PREFIX}/bin
- @${MKDIR} ${DATADIR}/images
- ${INSTALL_DATA} ${WRKSRC}/data/images/* ${DATADIR}/images
- @${MKDIR} ${DATADIR}/sounds
- ${INSTALL_DATA} ${WRKSRC}/data/sounds/* ${DATADIR}/sounds
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} "images sounds" ${DATADIR})
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/data/images/gemdropx-icon.xpm ${PREFIX}/share/pixmaps/${PORTNAME}.xmp
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.mk>
diff --git a/games/gemdropx/files/patch-aa b/games/gemdropx/files/patch-aa
deleted file mode 100644
index e529411858f9..000000000000
--- a/games/gemdropx/files/patch-aa
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig Sat May 18 17:53:29 2002
-+++ Makefile Sat Jun 22 09:56:19 2002
-@@ -14,11 +14,11 @@
- # Added 'install' target (finally!): May 18, 2002
-
-
--DATA_PREFIX=/usr/local/share/gemdropx
--SDL_CFLAGS := $(shell sdl-config --cflags)
--SDL_LDFLAGS := $(shell sdl-config --libs)
--CC=gcc
--CXX=gcc
-+DATA_PREFIX=$(PREFIX)/share/gemdropx
-+SDL_CFLAGS := $(shell $(SDL_CONFIG) --cflags)
-+SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
-+CC?=gcc
-+CXX?=gcc
-
-
- MIXER=-lSDL_mixer
-@@ -27,7 +27,7 @@
- EMBEDDEDFLAG=NOT_EMBEDDED
-
-
--CFLAGS=-Wall $(SDL_CFLAGS) \
-+CFLAGS+=$(SDL_CFLAGS) \
- -DDATA_PREFIX=\"$(DATA_PREFIX)\" -D$(NOSOUNDFLAG) -D$(JOYFLAG) \
- -D$(EMBEDDEDFLAG) $(XTRA_FLAGS)
- SDL_LIB=$(MIXER) $(SDL_LDFLAGS)
diff --git a/games/gemdropx/pkg-descr b/games/gemdropx/pkg-descr
index b44545d28a24..13042835a7a5 100644
--- a/games/gemdropx/pkg-descr
+++ b/games/gemdropx/pkg-descr
@@ -1,20 +1,18 @@
- Gem Drop X is an interesting one-player puzzle game for X-Window.
+"Gem Drop X" is an interesting one-player puzzle game using the
+Simple DirectMedia Layer (SDL) libraries.
- Gem Drop X is a direct port of Gem Drop, an Atari 8-bit game
-written in Action! (a very fast C and Pascal-like compiled language
-for the Atari). The concept of the game Gem Drop is based directly
-on an arcade game for the NeoGeo system called "Magical Drop III"
-by SNK.
+It is a direct port of "Gem Drop," an Atari 8-bit game written in Action!
+(a very fast C- and Pascal-like compiled language for the Atari).
- If you're familiar with games like Jewels, Klax, Bust-A-Move or
-Tetris, this game is similar to them all. I consider it closest to
-Klax. (Jewels is like a combination of Klax and Tetris. Bust-A-Move
-is the least similar, in my opinion, but everyone seems to have
-heard of it more than the others (except Tetris, of course!))
+It was originally ported to X11, using SDL for sound and music.
+Eventually, the Xlib graphics calls were removed and replaced with
+SDL calls.
- The game is played with YOU at the bottom of the screen. At the
-top is a random assortment of colored shapes ("gems"). As time goes
-on, more gems appear at the very top of the screen, pushing the
-rest downwards. The game is over when the gems reach the bottom.
+The concept of the game "Gem Drop" is based on an arcade game for the
+NeoGeo system called "Magical Drop III" by SNK.
+
+If you're familiar with games like Jewels, Klax, Bust-A-Move or Tetris,
+this game is similar to them all. I consider it closest to Klax.
+Some people have compared it to "Tetris meets Space Invaders."
WWW: http://www.newbreedsoftware.com/gemdropx/
diff --git a/games/gemdropx/pkg-plist b/games/gemdropx/pkg-plist
deleted file mode 100644
index fc2e81f123f5..000000000000
--- a/games/gemdropx/pkg-plist
+++ /dev/null
@@ -1,70 +0,0 @@
-bin/gemdropx
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%DATADIR%%/images/README
-%%DATADIR%%/images/action-mask.xbm
-%%DATADIR%%/images/action.xbm
-%%DATADIR%%/images/author.bmp
-%%DATADIR%%/images/block.bmp
-%%DATADIR%%/images/bluegem.bmp
-%%DATADIR%%/images/bomb.bmp
-%%DATADIR%%/images/brick.bmp
-%%DATADIR%%/images/congratulations.bmp
-%%DATADIR%%/images/credits.bmp
-%%DATADIR%%/images/diamond.bmp
-%%DATADIR%%/images/disc.bmp
-%%DATADIR%%/images/dot.bmp
-%%DATADIR%%/images/explode0.bmp
-%%DATADIR%%/images/explode1.bmp
-%%DATADIR%%/images/explode2.bmp
-%%DATADIR%%/images/explode3.bmp
-%%DATADIR%%/images/fuji.bmp
-%%DATADIR%%/images/gemdropx-icon.xpm
-%%DATADIR%%/images/happy.bmp
-%%DATADIR%%/images/left-mask.xbm
-%%DATADIR%%/images/left.xbm
-%%DATADIR%%/images/level.bmp
-%%DATADIR%%/images/lines.bmp
-%%DATADIR%%/images/need.bmp
-%%DATADIR%%/images/nothing-mask.xbm
-%%DATADIR%%/images/nothing.xbm
-%%DATADIR%%/images/numbers.bmp
-%%DATADIR%%/images/patience.bmp
-%%DATADIR%%/images/paused.bmp
-%%DATADIR%%/images/right-mask.xbm
-%%DATADIR%%/images/right.xbm
-%%DATADIR%%/images/sad.bmp
-%%DATADIR%%/images/score.bmp
-%%DATADIR%%/images/stopwatch.bmp
-%%DATADIR%%/images/title.bmp
-%%DATADIR%%/images/triangle.bmp
-%%DATADIR%%/images/uhoh.bmp
-%%DATADIR%%/images/warning.bmp
-%%DATADIR%%/images/warning1.bmp
-%%DATADIR%%/images/warning2.bmp
-%%DATADIR%%/images/warning3.bmp
-%%DATADIR%%/images/warning4.bmp
-%%DATADIR%%/images/wildcard.bmp
-%%DATADIR%%/images/win1.bmp
-%%DATADIR%%/images/win2.bmp
-%%DATADIR%%/images/yellowgem.bmp
-%%DATADIR%%/sounds/22drops.mod
-%%DATADIR%%/sounds/2force.xm
-%%DATADIR%%/sounds/README
-%%DATADIR%%/sounds/applause.wav
-%%DATADIR%%/sounds/begin.wav
-%%DATADIR%%/sounds/bomb.wav
-%%DATADIR%%/sounds/buzzer.wav
-%%DATADIR%%/sounds/citron.mod
-%%DATADIR%%/sounds/clock.wav
-%%DATADIR%%/sounds/gameover.wav
-%%DATADIR%%/sounds/got.wav
-%%DATADIR%%/sounds/grab.wav
-%%DATADIR%%/sounds/hr_suds.xm
-%%DATADIR%%/sounds/levelselect.wav
-%%DATADIR%%/sounds/throw.wav
-%%DATADIR%%/sounds/wildcard.wav
-%%DATADIR%%/sounds/win.wav
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%