aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-gtk-games/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-04-29 13:04:10 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-04-29 13:04:10 +0000
commit0da8fdc35594e7e9ff299102bed254ccf907ffda (patch)
tree0bb05dc4a43321afb8ca8c8944deea4f546821ce /games/ggz-gtk-games/Makefile
parentcb14e56be440c2a0bc07a681844a117ca6a984e3 (diff)
downloadports-0da8fdc35594e7e9ff299102bed254ccf907ffda.tar.gz
ports-0da8fdc35594e7e9ff299102bed254ccf907ffda.zip
Notes
Diffstat (limited to 'games/ggz-gtk-games/Makefile')
-rw-r--r--games/ggz-gtk-games/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index 8c16d0235b26..e25b87539088 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -7,12 +7,12 @@
#
PORTNAME= ggz-gtk-games
-PORTVERSION= 0.0.12
-PORTREVISION= 1
+PORTVERSION= 0.0.13
CATEGORIES= games
MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
+DIST_SUBDIR= ggz
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - GTK+ Games
@@ -31,4 +31,18 @@ CONFIGURE_ARGS= --disable-debug
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.mk>
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= depends on libggz which does not build on 4.x
+.endif
+
+.include <bsd.port.post.mk>