aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-sdl-games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-21 13:33:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-21 13:33:10 +0000
commit24d078a41c5cb737095ba7f7cc7e1beaeba79f89 (patch)
tree8f38349e61c5f7a431dd6b232f2758989c7adcbc /games/ggz-sdl-games
parentb612847503eadfb51a7d87b1433de92d04558538 (diff)
downloadports-24d078a41c5cb737095ba7f7cc7e1beaeba79f89.tar.gz
ports-24d078a41c5cb737095ba7f7cc7e1beaeba79f89.zip
Notes
Diffstat (limited to 'games/ggz-sdl-games')
-rw-r--r--games/ggz-sdl-games/Makefile45
-rw-r--r--games/ggz-sdl-games/distinfo3
-rw-r--r--games/ggz-sdl-games/files/patch-ttt3d-main.c10
-rw-r--r--games/ggz-sdl-games/pkg-descr5
-rw-r--r--games/ggz-sdl-games/pkg-plist19
5 files changed, 82 insertions, 0 deletions
diff --git a/games/ggz-sdl-games/Makefile b/games/ggz-sdl-games/Makefile
new file mode 100644
index 000000000000..8d70e6b26381
--- /dev/null
+++ b/games/ggz-sdl-games/Makefile
@@ -0,0 +1,45 @@
+# ex:ts=8
+# Ports collection makefile for: ggz-sdl-games
+# Date created: Nov 7, 2005
+# Whom: yinjieh
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggz-sdl-games
+PORTVERSION= 0.0.12
+CATEGORIES= games
+MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
+ http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+COMMENT= The GGZ Gaming Zone - SDL-based games
+
+LIB_DEPENDS= ggzcore.8:${PORTSDIR}/games/ggz-client-libs
+
+USE_GETOPT_LONG= yes
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+USE_SDL= image mixer sdl ttf
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-debug
+
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|SDL/SDL.h|SDL11/SDL.h|; \
+ s|SDL/SDL_image.h|SDL11/SDL_image.h|; \
+ s|SDL/SDL_mixer.h|SDL11/SDL_mixer.h|; \
+ s|SDL/SDL_syswm.h|SDL11/SDL_syswm.h|; \
+ s|SDL/SDL_ttf.h|SDL11/SDL_ttf.h|' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/geekgame/intro.c \
+ ${WRKSRC}/geekgame/main.c \
+ ${WRKSRC}/ttt3d/display.c \
+ ${WRKSRC}/ttt3d/main.c
+
+.include <bsd.port.mk>
diff --git a/games/ggz-sdl-games/distinfo b/games/ggz-sdl-games/distinfo
new file mode 100644
index 000000000000..fa4b62be3696
--- /dev/null
+++ b/games/ggz-sdl-games/distinfo
@@ -0,0 +1,3 @@
+MD5 (ggz-sdl-games-0.0.12.tar.gz) = 08414070a548df5718e9c2cfcef015e0
+SHA256 (ggz-sdl-games-0.0.12.tar.gz) = 3188374dbf34c71fd2e19634fa19fa0474a64dd1fc74a92590ccae70307dbba2
+SIZE (ggz-sdl-games-0.0.12.tar.gz) = 237649
diff --git a/games/ggz-sdl-games/files/patch-ttt3d-main.c b/games/ggz-sdl-games/files/patch-ttt3d-main.c
new file mode 100644
index 000000000000..5b55e3c149df
--- /dev/null
+++ b/games/ggz-sdl-games/files/patch-ttt3d-main.c
@@ -0,0 +1,10 @@
+--- ttt3d/main.c.orig Mon Nov 21 14:25:08 2005
++++ ttt3d/main.c Mon Nov 21 14:25:39 2005
+@@ -26,6 +26,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <sys/time.h>
+ #ifdef HAVE_WINSOCK_H
+ # include <winsock.h>
+ #endif
diff --git a/games/ggz-sdl-games/pkg-descr b/games/ggz-sdl-games/pkg-descr
new file mode 100644
index 000000000000..813a4416aedf
--- /dev/null
+++ b/games/ggz-sdl-games/pkg-descr
@@ -0,0 +1,5 @@
+This core client is not only useful for environments where no
+graphical desktop is available, but does also serve as a reference
+implementation of the ggzcore functionality.
+
+WWW: http://www.ggzgamingzone.org/
diff --git a/games/ggz-sdl-games/pkg-plist b/games/ggz-sdl-games/pkg-plist
new file mode 100644
index 000000000000..abe4aa39f8e8
--- /dev/null
+++ b/games/ggz-sdl-games/pkg-plist
@@ -0,0 +1,19 @@
+etc/ggz.modules
+lib/ggz/ggz.ttt3d
+lib/ggz/geekgame
+share/ggz/geekgame/bot.png
+share/ggz/geekgame/one.png
+share/ggz/geekgame/zero.png
+share/ggz/geekgame/icon.png
+share/ggz/geekgame/default.png
+share/ggz/geekgame/board.bmp
+share/ggz/geekgame/lines.bmp
+share/ggz/geekgame/banner.bmp
+share/ggz/ttt3d/board.bmp
+share/ggz/ttt3d/cursor.bmp
+share/ggz/ttt3d/figure.bmp
+share/ggz/ttt3d/lines.bmp
+@dirrm lib/ggz
+@dirrm share/ggz/geekgame
+@dirrm share/ggz/ttt3d
+@unexec rmdir %D/share/ggz 2>/dev/null || true