aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-txt-client
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-09 01:47:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-09 01:47:02 +0000
commit88653deefeddc22888f406025dad9d9c38ae3a17 (patch)
treeebea047ccb73b423eee27ffee216923560ac730e /games/ggz-txt-client
parentc00e6d0d8b587c4b83b97cd4745dce54aae9d03e (diff)
downloadports-88653deefeddc22888f406025dad9d9c38ae3a17.tar.gz
ports-88653deefeddc22888f406025dad9d9c38ae3a17.zip
Notes
Diffstat (limited to 'games/ggz-txt-client')
-rw-r--r--games/ggz-txt-client/Makefile30
-rw-r--r--games/ggz-txt-client/distinfo1
-rw-r--r--games/ggz-txt-client/pkg-descr5
-rw-r--r--games/ggz-txt-client/pkg-plist2
4 files changed, 38 insertions, 0 deletions
diff --git a/games/ggz-txt-client/Makefile b/games/ggz-txt-client/Makefile
new file mode 100644
index 000000000000..fe021ad2fe94
--- /dev/null
+++ b/games/ggz-txt-client/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: ggz-txt-client
+# Date created: Oct 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggz-txt-client
+PORTVERSION= 0.0.7
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ggz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The GGZ Gaming Zone - Console (Text) Frontend
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ ggz.1:${PORTSDIR}/games/libggz \
+ ggzcore.3:${PORTSDIR}/games/ggz-clientp-libs
+
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+LDFLAGS+= -L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}
+CONFIGURE_ARGS= --disable-debug
+
+MAN6= ggz-txt.6
+
+.include <bsd.port.mk>
diff --git a/games/ggz-txt-client/distinfo b/games/ggz-txt-client/distinfo
new file mode 100644
index 000000000000..91c154047784
--- /dev/null
+++ b/games/ggz-txt-client/distinfo
@@ -0,0 +1 @@
+MD5 (ggz-txt-client-0.0.7.tar.gz) = 070f4706b016cbcdab1346a50bfb6093
diff --git a/games/ggz-txt-client/pkg-descr b/games/ggz-txt-client/pkg-descr
new file mode 100644
index 000000000000..813a4416aedf
--- /dev/null
+++ b/games/ggz-txt-client/pkg-descr
@@ -0,0 +1,5 @@
+This core client is not only useful for environments where no
+graphical desktop is available, but does also serve as a reference
+implementation of the ggzcore functionality.
+
+WWW: http://www.ggzgamingzone.org/
diff --git a/games/ggz-txt-client/pkg-plist b/games/ggz-txt-client/pkg-plist
new file mode 100644
index 000000000000..6c24c4b10f96
--- /dev/null
+++ b/games/ggz-txt-client/pkg-plist
@@ -0,0 +1,2 @@
+bin/ggz-txt
+share/locale/de/LC_MESSAGES/ggz-txt.mo