aboutsummaryrefslogtreecommitdiff
path: root/games/glaxium
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-23 13:08:41 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-23 13:08:41 +0000
commit21646392b027298c4aca08ad5386649a6869ccea (patch)
tree902ae1e48303d70f1045908f9eb477d7722924c8 /games/glaxium
parent6c8d9e9eb93b758a9136ea26f6d089c61feae712 (diff)
downloadports-21646392b027298c4aca08ad5386649a6869ccea.tar.gz
ports-21646392b027298c4aca08ad5386649a6869ccea.zip
- Support staging
- Use new LIB_DEPENDS syntax - Use options helpers - Convert to USES - Minor changes/fixes
Notes
Notes: svn path=/head/; revision=331383
Diffstat (limited to 'games/glaxium')
-rw-r--r--games/glaxium/Makefile10
-rw-r--r--games/glaxium/files/patch-Makefile.in16
-rw-r--r--games/glaxium/pkg-plist1
3 files changed, 22 insertions, 5 deletions
diff --git a/games/glaxium/Makefile b/games/glaxium/Makefile
index 2849cc6fe975..7e3aee17b140 100644
--- a/games/glaxium/Makefile
+++ b/games/glaxium/Makefile
@@ -11,16 +11,14 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= OpenGL based space-ship "shoot-em-up" game
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+USES= gmake
USE_SDL= sdl mixer
USE_GL= glut
-USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= ${PORTNAME}
-MAN6= glaxium.6
-
USE_DOS2UNIX= variables.cpp scene.cpp
DESKTOP_ENTRIES= "Glaxium" \
@@ -30,7 +28,6 @@ DESKTOP_ENTRIES= "Glaxium" \
"Game;ArcadeGame;" \
false
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g; \
s|/games/glaxium|/glaxium|g' ${WRKSRC}/configure
@@ -41,4 +38,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|TankFire::TankFire|TankFire|g' \
${WRKSRC}/tank.hpp
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
.include <bsd.port.mk>
diff --git a/games/glaxium/files/patch-Makefile.in b/games/glaxium/files/patch-Makefile.in
new file mode 100644
index 000000000000..37ff8100794c
--- /dev/null
+++ b/games/glaxium/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- ./Makefile.in.orig 2002-10-20 18:30:12.000000000 +0000
++++ ./Makefile.in 2013-10-22 22:38:44.900225905 +0000
+@@ -13,10 +13,10 @@
+ bindir=@bindir@
+ mandir=@mandir@
+
+-GLAXIUM_INSTALLDIR=$(bindir)
++GLAXIUM_INSTALLDIR=$(DESTDIR)$(bindir)
+ DATA_DIRS=samples textures
+-GLAXIUM_HOME=$(datadir)/games/glaxium
+-MAN_DIR=$(mandir)
++GLAXIUM_HOME=$(DESTDIR)$(datadir)/games/glaxium
++MAN_DIR=$(DESTDIR)$(mandir)
+
+ glaxium : $(OBJ)
+ gcc -g -o glaxium $(OBJ) $(LIB)
diff --git a/games/glaxium/pkg-plist b/games/glaxium/pkg-plist
index 2a17d327539f..c8949385a61a 100644
--- a/games/glaxium/pkg-plist
+++ b/games/glaxium/pkg-plist
@@ -1,4 +1,5 @@
bin/glaxium
+man/man6/glaxium.6.gz
%%DATADIR%%/samples/detection.wav
%%DATADIR%%/samples/explode1.wav
%%DATADIR%%/samples/explode2.wav