aboutsummaryrefslogtreecommitdiff
path: root/games/glightoff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-07 18:29:58 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-05-07 18:29:58 +0000
commit543d87aa2c4a9aac7cbc8bb8b81f8918f27e50ee (patch)
treea52baa28d5cef26ed71914a5e8e7d701f35801b2 /games/glightoff
parent1213a51516efdb698344fc5f785fc5ea479db79d (diff)
downloadports-543d87aa2c4a9aac7cbc8bb8b81f8918f27e50ee.tar.gz
ports-543d87aa2c4a9aac7cbc8bb8b81f8918f27e50ee.zip
GLightOff is a simple (but not so easy to solve!) puzzle game.
The goal is to switch off all the lights on the 5x5 board. WWW: http://glightoff.sourceforge.net/ PR: ports/167232 Submitted by: nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=296159
Diffstat (limited to 'games/glightoff')
-rw-r--r--games/glightoff/Makefile53
-rw-r--r--games/glightoff/distinfo2
-rw-r--r--games/glightoff/pkg-descr4
-rw-r--r--games/glightoff/pkg-plist10
4 files changed, 69 insertions, 0 deletions
diff --git a/games/glightoff/Makefile b/games/glightoff/Makefile
new file mode 100644
index 000000000000..4525ebfd4c3f
--- /dev/null
+++ b/games/glightoff/Makefile
@@ -0,0 +1,53 @@
+# New Ports collection makefile for: glightoff
+# Date created: 21 April 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= glightoff
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= GLightOff is a simple (but not so easy to solve!) puzzle game
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20 intltool pkgconfig
+USE_XORG= x11
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+
+OPTIONS= NLS "Enable gettext support" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-configure:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} 's|src po|src|' ${WRKSRC}/Makefile
+.endif
+
+post-install:
+# Documentations
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/glightoff/distinfo b/games/glightoff/distinfo
new file mode 100644
index 000000000000..20f3a6352967
--- /dev/null
+++ b/games/glightoff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (glightoff-1.0.0.tar.gz) = 14dd3174e75c175b437cd5a6c8a9eddc29865b62c588463892031cd0a355938a
+SIZE (glightoff-1.0.0.tar.gz) = 349274
diff --git a/games/glightoff/pkg-descr b/games/glightoff/pkg-descr
new file mode 100644
index 000000000000..cdc3029b0437
--- /dev/null
+++ b/games/glightoff/pkg-descr
@@ -0,0 +1,4 @@
+GLightOff is a simple (but not so easy to solve!) puzzle game.
+The goal is to switch off all the lights on the 5x5 board.
+
+WWW: http://glightoff.sourceforge.net/
diff --git a/games/glightoff/pkg-plist b/games/glightoff/pkg-plist
new file mode 100644
index 000000000000..351116914d77
--- /dev/null
+++ b/games/glightoff/pkg-plist
@@ -0,0 +1,10 @@
+bin/glightoff
+share/applications/glightoff.desktop
+%%NLS%%share/locale/es/LC_MESSAGES/glightoff.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/glightoff.mo
+%%NLS%%share/locale/it/LC_MESSAGES/glightoff.mo
+share/pixmaps/glightoff.png
+share/pixmaps/glightoff/bulb_on.svg
+share/pixmaps/glightoff/bulb_off.svg
+@dirrm share/pixmaps/glightoff
+@dirrmtry share/applications