aboutsummaryrefslogtreecommitdiff
path: root/games/glsfcave
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-26 16:53:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-26 16:53:46 +0000
commit20f659d957b3d48aea334a2aa401b01a64c10f0d (patch)
treea0d1a975564bc655e7bd6938cb9311ae65d1a0f8 /games/glsfcave
parentcaafd75abed8cee44804cbda24c41828a0c4c607 (diff)
downloadports-20f659d957b3d48aea334a2aa401b01a64c10f0d.tar.gz
ports-20f659d957b3d48aea334a2aa401b01a64c10f0d.zip
GLSFcave is a port of SunFlat's SFcave for UNIX/OpenGL. SFcave is
a game where the player controls a ribbon to avoid hitting walls. You have only one control: when you hold the mouse button, the ribbon goes up. Otherwise the ribbon goes down. The game uses OpenGL for drawing two-dimensional frames. This is for portability(for MacOS X) and to offload CPU. WWW: http://user.ecc.u-tokyo.ac.jp/~g650192/glsfcave/ PR: ports/121847 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=209886
Diffstat (limited to 'games/glsfcave')
-rw-r--r--games/glsfcave/Makefile42
-rw-r--r--games/glsfcave/distinfo3
-rw-r--r--games/glsfcave/pkg-descr10
3 files changed, 55 insertions, 0 deletions
diff --git a/games/glsfcave/Makefile b/games/glsfcave/Makefile
new file mode 100644
index 000000000000..b88294ffd603
--- /dev/null
+++ b/games/glsfcave/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: glsfcave
+# Date created: 19 Mar 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glsfcave
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://user.ecc.u-tokyo.ac.jp/~g650192/glsfcave/ \
+ http://www.amdmi3.ru/distfiles/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Control a ribbon to avoid hitting walls
+
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
+USE_BZIP2= yes
+USE_GL= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PORTDOCS= README
+PLIST_FILES= bin/glsfcave
+
+do-build:
+ cd ${WRKSRC} && ${CC} -o glsfcave main.c -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib -lglut -lGL -lGLU
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glsfcave ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/glsfcave/distinfo b/games/glsfcave/distinfo
new file mode 100644
index 000000000000..5f5f7bf0c965
--- /dev/null
+++ b/games/glsfcave/distinfo
@@ -0,0 +1,3 @@
+MD5 (glsfcave-1.0.tar.bz2) = ff0f7897c1c6366ed41cf59fde4efed5
+SHA256 (glsfcave-1.0.tar.bz2) = 778655f28452d104fcb3b23b48938b2d1a52076be464f0c658a165f89821f6e9
+SIZE (glsfcave-1.0.tar.bz2) = 4017
diff --git a/games/glsfcave/pkg-descr b/games/glsfcave/pkg-descr
new file mode 100644
index 000000000000..4d9b8f6a0e20
--- /dev/null
+++ b/games/glsfcave/pkg-descr
@@ -0,0 +1,10 @@
+GLSFcave is a port of SunFlat's SFcave for UNIX/OpenGL. SFcave is
+a game where the player controls a ribbon to avoid hitting walls.
+
+You have only one control: when you hold the mouse button, the
+ribbon goes up. Otherwise the ribbon goes down.
+
+The game uses OpenGL for drawing two-dimensional frames. This is
+for portability(for MacOS X) and to offload CPU.
+
+WWW: http://user.ecc.u-tokyo.ac.jp/~g650192/glsfcave/