aboutsummaryrefslogtreecommitdiff
path: root/games/gltron
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-27 18:56:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-27 18:56:10 +0000
commita26d7c7f14536089a98485aeffda350a49078059 (patch)
tree4a0d062b1290de767a095313dbab847c9012f8ad /games/gltron
parent8475aa1b40e436b8bf6a9e8e97dd39bbb6c0225b (diff)
downloadports-a26d7c7f14536089a98485aeffda350a49078059.tar.gz
ports-a26d7c7f14536089a98485aeffda350a49078059.zip
Notes
Diffstat (limited to 'games/gltron')
-rw-r--r--games/gltron/Makefile26
-rw-r--r--games/gltron/distinfo2
-rw-r--r--games/gltron/files/patch-Makefile.in14
-rw-r--r--games/gltron/files/patch-ac46
-rw-r--r--games/gltron/files/patch-ad161
-rw-r--r--games/gltron/files/patch-ae34
-rw-r--r--games/gltron/files/patch-af15
-rw-r--r--games/gltron/files/patch-gltron.c27
-rw-r--r--games/gltron/pkg-descr2
-rw-r--r--games/gltron/pkg-plist128
10 files changed, 268 insertions, 187 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index 3492644a7d69..bc32b8ceba9e 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -6,35 +6,37 @@
#
PORTNAME= gltron
-PORTVERSION= 0.59
+PORTVERSION= 0.61
CATEGORIES= games
-MASTER_SITES= http://gltron.sourceforge.net/download/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://gltron.sourceforge.net/download/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= -source.tar.gz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ SDL_net.0:${PORTSDIR}/net/sdl_net \
png.4:${PORTSDIR}/graphics/png
-.if defined(NO_SOUND)
-SOUND=""
-.else
-SOUND="-DSOUND"
-.endif
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
USE_MESA= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-MAKE_ENV+= OPT="${CFLAGS}" SOUND="${SOUND}"
+CONFIGURE_ENV= X11BASE="${X11BASE}" \
+ LOCALBASE="${LOCALBASE}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ SDL_CONFIG="${SDL_CONFIG}"
pre-build:
${PERL} -pi -e "s+#include <SDL\/+#include <+g" ${WRKSRC}/*.[ch]
do-install:
- @${MKDIR} ${PREFIX}/share/gltron/ ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/data/*tx* ${WRKSRC}/data/*.png ${WRKSRC}/data/*.obj \
- ${WRKSRC}/data/*mtl ${WRKSRC}/data/*.it ${WRKSRC}/sounds/*wav \
- ${PREFIX}/share/gltron
+ @${MKDIR} ${PREFIX}/share/gltron
+ (cd ${WRKSRC} && ${TAR} -c -f - art data sounds) \
+ | (cd ${PREFIX}/share/gltron && ${TAR} --unlink -x -f -)
${INSTALL_PROGRAM} ${WRKSRC}/gltron ${PREFIX}/bin
post-install:
diff --git a/games/gltron/distinfo b/games/gltron/distinfo
index 232d24f7a61c..f53a05ae3b7e 100644
--- a/games/gltron/distinfo
+++ b/games/gltron/distinfo
@@ -1 +1 @@
-MD5 (gltron-0.59.tar.gz) = 2927d29a83e500b3f8e1eff7cb1ed3ce
+MD5 (gltron-0.61-source.tar.gz) = bf2360ebb6c47ffa2f4d80a934aeb351
diff --git a/games/gltron/files/patch-Makefile.in b/games/gltron/files/patch-Makefile.in
new file mode 100644
index 000000000000..3ee216a447cd
--- /dev/null
+++ b/games/gltron/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2001/04/27 18:30:04 1.1
++++ Makefile.in 2001/04/27 18:31:32
+@@ -20,7 +20,7 @@
+
+ CC = @CC@
+
+-CFLAGS = -c @CFLAGS@ @INCS@
++CFLAGS = -c @CFLAGS@ @INCS@ -DPREFIX=\"@prefix@\"
+ LIBS = @LIBS@
+
+ # fix these later
diff --git a/games/gltron/files/patch-ac b/games/gltron/files/patch-ac
deleted file mode 100644
index e2bdd1d9aeca..000000000000
--- a/games/gltron/files/patch-ac
+++ /dev/null
@@ -1,46 +0,0 @@
---- file.c Mon Apr 24 23:19:46 2000
-+++ file.c.new Mon Apr 24 23:25:07 2000
-@@ -1,14 +1,18 @@
- #include "gltron.h"
-
-+#ifndef SHARE1
-+#define SHARE1 "\"/usr/local/share/gltron\""
-+#endif
-+#ifndef SHARE2
-+#define SHARE2 "\"/usr/X11R6/share/gltron\""
-+#endif
-+
- static char* subdir = "data";
- char* getFullPath(char *filename) {
- char *path;
- FILE *fp = NULL;
- char *base;
-
-- char *share1 = "/usr/share/games/gltron";
-- char *share2 = "/usr/local/share/games/gltron";
--
- /* check a few directories for the files and */
- /* return the full path. */
-
-@@ -44,8 +48,8 @@
- printf("unsuccessful\n");
- }
-
-- path = malloc(strlen(share1) + 1 + strlen(filename) + 1);
-- sprintf(path, "%s%c%s", share1, SEPERATOR, filename);
-+ path = malloc(strlen(SHARE1) + 1 + strlen(filename) + 1);
-+ sprintf(path, "%s%c%s", SHARE1, SEPERATOR, filename);
-
- printf("checking '%s'", path);
- fp = fopen(path, "r");
-@@ -57,8 +61,8 @@
- free(path);
- printf("unsuccessful\n");
-
-- path = malloc(strlen(share2) + 1 + strlen(filename) + 1);
-- sprintf(path, "%s%c%s", share2, SEPERATOR, filename);
-+ path = malloc(strlen(SHARE2) + 1 + strlen(filename) + 1);
-+ sprintf(path, "%s%c%s", SHARE2, SEPERATOR, filename);
-
- printf("checking '%s'", path);
- fp = fopen(path, "r");
diff --git a/games/gltron/files/patch-ad b/games/gltron/files/patch-ad
index 07ca7abf1cb0..725c0c90fec6 100644
--- a/games/gltron/files/patch-ad
+++ b/games/gltron/files/patch-ad
@@ -1,91 +1,160 @@
---- configure.orig Thu Mar 30 11:22:00 2000
-+++ configure Fri Apr 28 14:46:13 2000
-@@ -523,7 +523,7 @@
+
+$FreeBSD$
+
+--- configure.orig Thu Apr 12 23:27:42 2001
++++ configure Fri Apr 27 21:44:23 2001
+@@ -536,7 +536,7 @@
-LIBS='-L/usr/X11R6/lib'
-+LIBS='-L$ac_default_prefix/lib -L/usr/X11R6/lib'
- CC='gcc'
- echo $ac_n "checking for main in -lm""... $ac_c" 1>&6
- echo "configure:530: checking for main in -lm" >&5
-@@ -701,14 +701,14 @@
- { echo "configure: error: GLU should come with OpenGL" 1>&2; exit 1; }
++LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+
+ # Extract the first word of "gcc", so it can be a program name with args.
+ set dummy gcc; ac_word=$2
+@@ -972,7 +972,7 @@
+ fi
+
+
+-CFLAGS=""
++CFLAGS="$CFLAGS -I${X11BASE}/include -I${LOCALBASE}/include"
+
+ # Check whether --enable-warn or --disable-warn was given.
+ if test "${enable_warn+set}" = set; then
+@@ -1023,7 +1023,7 @@
+ fi
+
+ if test "x$enable_optimize" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
++# CFLAGS="$CFLAGS -O$enable_optimize"
fi
--echo $ac_n "checking for main in -lpthread""... $ac_c" 1>&6
--echo "configure:706: checking for main in -lpthread" >&5
-+echo $ac_n "checking for main in -pthread""... $ac_c" 1>&6
-+echo "configure:706: checking for main in -pthread" >&5
- ac_lib_var=`echo pthread'_'main | sed 'y%./+-%__p_%'`
- if eval "test \"\${ac_cv_lib_$ac_lib_var+set}\" = set"; then
+ # Check whether --enable-network or --disable-network was given.
+@@ -1042,7 +1042,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
--LIBS="-lpthread $LIBS"
-+LIBS="-pthread $LIBS"
+-LIBS="-lSDL_net $LIBS"
++LIBS="$LIBS -lSDL_net"
cat > conftest.$ac_ext <<EOF
- #line 714 "configure"
+ #line 1048 "configure"
#include "confdefs.h"
-@@ -738,21 +738,21 @@
+@@ -1072,7 +1072,7 @@
#define $ac_tr_lib 1
EOF
-- LIBS="-lpthread $LIBS"
-+ LIBS="-pthread $LIBS"
+- LIBS="-lSDL_net $LIBS"
++ LIBS="$LIBS -lSDL_net"
else
echo "$ac_t""no" 1>&6
- { echo "configure: error: SDL needs pthread to run properly" 1>&2; exit 1; }
- fi
-
--echo $ac_n "checking for main in -lSDL""... $ac_c" 1>&6
--echo "configure:750: checking for main in -lSDL" >&5
-+echo $ac_n "checking for main in -lSDL-1.1""... $ac_c" 1>&6
-+echo "configure:750: checking for main in -lSDL-1.1" >&5
- ac_lib_var=`echo SDL'_'main | sed 'y%./+-%__p_%'`
- if eval "test \"\${ac_cv_lib_$ac_lib_var+set}\" = set"; then
+@@ -1147,7 +1147,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
--LIBS="-lSDL -lpthread $LIBS"
-+LIBS="-L$ac_default_prefix/lib -lSDL-1.1 -pthread $LIBS"
+-LIBS="-lX11 $LIBS"
++LIBS="$LIBS -lX11"
cat > conftest.$ac_ext <<EOF
- #line 758 "configure"
+ #line 1153 "configure"
#include "confdefs.h"
-@@ -782,7 +782,7 @@
+@@ -1177,7 +1177,7 @@
#define $ac_tr_lib 1
EOF
-- LIBS="-lSDL $LIBS"
-+ LIBS="-L$ac_default_prefix/lib -lSDL-1.1 $LIBS"
+- LIBS="-lX11 $LIBS"
++ LIBS="$LIBS -lX11"
else
echo "$ac_t""no" 1>&6
-@@ -796,7 +796,7 @@
+@@ -1191,7 +1191,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
--LIBS="-lSDL_mixer $LIBS"
-+LIBS="-L$ac_default_prefix/lib -lSDL_mixer -lsmpeg $LIBS"
+-LIBS="-lGL $LIBS"
++LIBS="$LIBS -lGL"
cat > conftest.$ac_ext <<EOF
- #line 802 "configure"
+ #line 1197 "configure"
#include "confdefs.h"
-@@ -826,7 +826,7 @@
+@@ -1221,7 +1221,7 @@
#define $ac_tr_lib 1
EOF
-- LIBS="-lSDL_mixer $LIBS"
-+ LIBS="-lSDL_mixer -lsmpeg $LIBS"
+- LIBS="-lGL $LIBS"
++ LIBS="$LIBS -lGL"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -1229,14 +1229,14 @@
+ fi
+
+-echo $ac_n "checking for main in -lSDL""... $ac_c" 1>&6
+-echo "configure:1234: checking for main in -lSDL" >&5
++echo $ac_n "checking for main in -lSDL-1.1""... $ac_c" 1>&6
++echo "configure:1234: checking for main in -lSDL-1.1" >&5
+ ac_lib_var=`echo SDL'_'main | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lSDL $LIBS"
++LIBS="$LIBS -lSDL-1.1 ${PTHREAD_LIBS}"
+ cat > conftest.$ac_ext <<EOF
+ #line 1242 "configure"
+ #include "confdefs.h"
+@@ -1262,8 +1262,8 @@
+ echo "$ac_t""yes" 1>&6
+ ${LN_S} -f system_sdl.c system.c ; \
+ ${LN_S} -f system_sdl.h system.h ; \
+-LIBS="$LIBS `sdl-config --libs`" ; \
+-CFLAGS="$CFLAGS `sdl-config --cflags`" ; \
++LIBS="$LIBS `$SDL_CONFIG --libs`" ; \
++CFLAGS="$CFLAGS `$SDL_CONFIG --cflags`" ; \
+ HAVE_SDL=1
else
echo "$ac_t""no" 1>&6
-@@ -840,7 +840,7 @@
+@@ -1274,7 +1274,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lglut $LIBS"
++LIBS="$LIBS -lglut"
+ cat > conftest.$ac_ext <<EOF
+ #line 1280 "configure"
+ #include "confdefs.h"
+@@ -1320,7 +1320,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lSDL_mixer $LIBS"
++LIBS="-L$ac_default_prefix/lib -lSDL_mixer -lsmpeg $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1326 "configure"
+ #include "confdefs.h"
+@@ -1357,7 +1357,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lmikmod $LIBS"
++LIBS="$LIBS -lmikmod"
+ cat > conftest.$ac_ext <<EOF
+ #line 1363 "configure"
+ #include "confdefs.h"
+@@ -1445,7 +1445,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lpng $LIBS"
-+LIBS="-L$ac_default_prefix/lib -lpng $LIBS"
++LIBS="$LIBS -lpng"
cat > conftest.$ac_ext <<EOF
- #line 846 "configure"
+ #line 1451 "configure"
#include "confdefs.h"
+@@ -1475,7 +1475,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpng $LIBS"
++ LIBS="$LIBS -lpng"
+
+ else
+ echo "$ac_t""no" 1>&6
diff --git a/games/gltron/files/patch-ae b/games/gltron/files/patch-ae
deleted file mode 100644
index 9438f671c396..000000000000
--- a/games/gltron/files/patch-ae
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.in.orig Tue Mar 21 23:34:04 2000
-+++ Makefile.in Fri Apr 28 14:22:24 2000
-@@ -1,11 +1,16 @@
- # Makefile for gltron
-
--SHELL = /bin/sh
--OPT = -O2
--CFLAGS = -c -pedantic -Wall -DSOUND
--GL_LIBS = -lm -lGL -lGLU -lSDL -lpthread -lpng
--XLIBS = -L/usr/X11/lib -L/usr/X11R6/lib -lX11
--SNDLIBS = -lSDL_mixer
-+PREFIX ?= /usr/X11R6
-+LOCALBASE ?= /usr/local
-+X11BASE ?= /usr/X11R6
-+SHELL = /bin/sh
-+SOUND ?= -DSOUND
-+OPT = -Wall ${SOUND} -DSHARE1="\"$(PREFIX)/share/gltron\"" -DSHARE2="\"$(X11BASE)/share/gltron\""
-+INCS = -I$(LOCALBASE)/include -I$(X11BASE)/include -I$(LOCALBASE)/include/SDL11
-+CFLAGS ?= -O -pipe
-+GL_LIBS = -lm -lGL -lGLU -lSDL-1.1 -pthread -lpng
-+XLIBS = -L$(X11BASE)/lib -lX11
-+SNDLIBS = -L$(LOCALBASE)/lib -lSDL_mixer -lSDL-1.1 -lsmpeg
-
- GLTRON_INSTALLDIR = /usr/bin
- GLTRON_HOME = /usr/share/games/gltron
-@@ -45,7 +50,7 @@
- all: gltron
-
- .c.o:
-- $(CC) $(CFLAGS) $(OPT) $<
-+ $(CC) -c $(CFLAGS) $(OPT) $(INCS) $<
-
- gltron: $(OBJ_SOUND)
- $(CC) $(OPT) -o gltron $(OBJ_SOUND) $(GL_LIBS) $(XLIBS) $(SNDLIBS)
diff --git a/games/gltron/files/patch-af b/games/gltron/files/patch-af
deleted file mode 100644
index acc41285baad..000000000000
--- a/games/gltron/files/patch-af
+++ /dev/null
@@ -1,15 +0,0 @@
---- system_sdl.c 2000/05/26 09:21:17 1.1
-+++ system_sdl.c 2000/05/26 09:27:15
-@@ -17,7 +17,11 @@
- }
-
- void SystemInit(int *argc, char *argv[]) {
-- if(SDL_Init(SDL_INIT_VIDEO | SDL_INIT_AUDIO) < 0 ){
-+ Uint32 sflag = 0;
-+#ifdef SOUND
-+ sflag = SDL_INIT_AUDIO;
-+#endif
-+ if(SDL_Init(SDL_INIT_VIDEO | sflag) < 0 ){
- fprintf(stderr, "Couldn't initialize SDL: %s\n", SDL_GetError());
- exit(1);
- }
diff --git a/games/gltron/files/patch-gltron.c b/games/gltron/files/patch-gltron.c
new file mode 100644
index 000000000000..22aa490bb87f
--- /dev/null
+++ b/games/gltron/files/patch-gltron.c
@@ -0,0 +1,27 @@
+
+$FreeBSD$
+
+--- gltron.c.orig Sun Apr 15 16:23:13 2001
++++ gltron.c Fri Apr 27 21:33:07 2001
+@@ -3,6 +3,8 @@
+ Copyright (C) 1999 by Andreas Umbach <marvin@dataway.ch>
+ */
+
++#include <unistd.h>
++
+ #include "gltron.h"
+
+ /* todo: define the globals where I need them */
+@@ -98,7 +100,11 @@
+ SystemInit(&argc, argv);
+
+ #ifndef CURRENT_EQ_DATA_DIR
+- goto_installpath(argv[0]);
++/* goto_installpath(argv[0]);*/
++ if (chdir(PREFIX "/share/gltron") != 0) {
++ fprintf(stderr, "gltron: can't chdir into data directory");
++ exit(1);
++ }
+ #endif
+
+ /* initialize artpack list before loading settigns! */
diff --git a/games/gltron/pkg-descr b/games/gltron/pkg-descr
index 6ee07492194c..8e53e027e87e 100644
--- a/games/gltron/pkg-descr
+++ b/games/gltron/pkg-descr
@@ -1,3 +1,3 @@
Objective for game is not to drive into a wall.
-WWW: http://www.ards.net/Andreas/gltron.html
+WWW: http://www.gltron.org/
diff --git a/games/gltron/pkg-plist b/games/gltron/pkg-plist
index a7033a460eb8..1e9e6865b81f 100644
--- a/games/gltron/pkg-plist
+++ b/games/gltron/pkg-plist
@@ -1,38 +1,102 @@
bin/gltron
-share/gltron/babbage.0.png
-share/gltron/babbage.1.png
-share/gltron/babbage.ftx
-share/gltron/fonts.txt
-share/gltron/game_crash.wav
-share/gltron/game_engine.wav
-share/gltron/game_lose.wav
-share/gltron/game_start.wav
-share/gltron/game_win.wav
-share/gltron/gltron.it
-share/gltron/gltron.png
-share/gltron/gltron_crash.png
-share/gltron/gltron_floor.png
-share/gltron/gltron_logo.png
-share/gltron/gltron_trail.png
-share/gltron/gltron_traildecal.png
-share/gltron/gltron_wall_1.png
-share/gltron/gltron_wall_2.png
-share/gltron/gltron_wall_3.png
-share/gltron/gltron_wall_4.png
-share/gltron/lightcycle high.obj
-share/gltron/lightcycle low.obj
-share/gltron/lightcycle med.obj
-share/gltron/menu.txt
-share/gltron/menu_action.wav
-share/gltron/menu_highlight.wav
-share/gltron/settings.txt
-share/gltron/tron.mtl
-share/gltron/tron2.mtl
-share/gltron/xenotron.0.png
-share/gltron/xenotron.1.png
-share/gltron/xenotron.ftx
share/doc/gltron/CHANGELOG
share/doc/gltron/CREDITS
share/doc/gltron/README
+share/gltron/art/arcade_spots/gltron_floor.png
+share/gltron/art/arcade_spots/gltron_traildecal.png
+share/gltron/art/arcade_spots/gltron_wall_1.png
+share/gltron/art/arcade_spots/gltron_wall_2.png
+share/gltron/art/arcade_spots/gltron_wall_3.png
+share/gltron/art/arcade_spots/gltron_wall_4.png
+share/gltron/art/arcade_spots/skybox0.png
+share/gltron/art/arcade_spots/skybox1.png
+share/gltron/art/arcade_spots/skybox2.png
+share/gltron/art/arcade_spots/skybox3.png
+share/gltron/art/arcade_spots/skybox4.png
+share/gltron/art/arcade_spots/skybox5.png
+share/gltron/art/biohazard/artpack.ini
+share/gltron/art/biohazard/babbage.0.png
+share/gltron/art/biohazard/babbage.1.png
+share/gltron/art/biohazard/gltron.png
+share/gltron/art/biohazard/gltron_crash.png
+share/gltron/art/biohazard/gltron_floor.png
+share/gltron/art/biohazard/gltron_logo.png
+share/gltron/art/biohazard/gltron_trail.png
+share/gltron/art/biohazard/gltron_traildecal.png
+share/gltron/art/biohazard/gltron_wall_1.png
+share/gltron/art/biohazard/gltron_wall_2.png
+share/gltron/art/biohazard/gltron_wall_3.png
+share/gltron/art/biohazard/gltron_wall_4.png
+share/gltron/art/biohazard/skybox0.png
+share/gltron/art/biohazard/skybox1.png
+share/gltron/art/biohazard/skybox2.png
+share/gltron/art/biohazard/skybox3.png
+share/gltron/art/biohazard/skybox4.png
+share/gltron/art/biohazard/skybox5.png
+share/gltron/art/default/artpack.ini
+share/gltron/art/default/babbage.0.png
+share/gltron/art/default/babbage.1.png
+share/gltron/art/default/gltron.png
+share/gltron/art/default/gltron_bitmap.png
+share/gltron/art/default/gltron_crash.png
+share/gltron/art/default/gltron_floor.png
+share/gltron/art/default/gltron_logo.png
+share/gltron/art/default/gltron_trail.png
+share/gltron/art/default/gltron_trail.png.bak
+share/gltron/art/default/gltron_traildecal.png
+share/gltron/art/default/gltron_wall_1.png
+share/gltron/art/default/gltron_wall_2.png
+share/gltron/art/default/gltron_wall_3.png
+share/gltron/art/default/gltron_wall_4.png
+share/gltron/art/default/skybox0.png
+share/gltron/art/default/skybox1.png
+share/gltron/art/default/skybox2.png
+share/gltron/art/default/skybox3.png
+share/gltron/art/default/skybox4.png
+share/gltron/art/default/skybox5.png
+share/gltron/art/default/test.bitmap.png
+share/gltron/art/default/xenotron.0.png
+share/gltron/art/default/xenotron.1.png
+share/gltron/art/metalTron/gltron_floor.png
+share/gltron/art/metalTron/gltron_wall_1.png
+share/gltron/art/metalTron/gltron_wall_2.png
+share/gltron/art/metalTron/gltron_wall_3.png
+share/gltron/art/metalTron/gltron_wall_4.png
+share/gltron/art/metalTron/skybox0.png
+share/gltron/art/metalTron/skybox1.png
+share/gltron/art/metalTron/skybox2.png
+share/gltron/art/metalTron/skybox3.png
+share/gltron/art/metalTron/skybox4.png
+share/gltron/art/metalTron/skybox5.png
+share/gltron/data/babbage.ftx
+share/gltron/data/fonts.txt
+share/gltron/data/game_crash.wav
+share/gltron/data/game_engine.wav
+share/gltron/data/lightcycle high.obj
+share/gltron/data/lightcycle low.obj
+share/gltron/data/lightcycle med.obj
+share/gltron/data/menu.txt
+share/gltron/data/music/song_revenge_of_cats.it
+share/gltron/data/recognizer.obj
+share/gltron/data/settings.txt
+share/gltron/data/test.fbmp
+share/gltron/data/tron.mtl
+share/gltron/data/tron2.mtl
+share/gltron/data/xenotron.ftx
+share/gltron/sounds/game_crash.wav
+share/gltron/sounds/game_engine.wav
+share/gltron/sounds/game_lose.wav
+share/gltron/sounds/game_start.wav
+share/gltron/sounds/game_win.wav
+share/gltron/sounds/menu_action.wav
+share/gltron/sounds/menu_highlight.wav
+@dirrm share/gltron/sounds
+@dirrm share/gltron/data/music
+@dirrm share/gltron/data
+@dirrm share/gltron/art/metalTron
+@dirrm share/gltron/art/default
+@dirrm share/gltron/art/biohazard
+@dirrm share/gltron/art/arcade_spots
+@dirrm share/gltron/art
@dirrm share/gltron
@dirrm share/doc/gltron