aboutsummaryrefslogtreecommitdiff
path: root/games/gltron
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-03 18:58:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-03 18:58:57 +0000
commitff57a36a5814648f6bbfc2b0c2df08bc52a60e40 (patch)
tree2338a6cdc3ec0a38a33fcec714afb3bcb87bc1fa /games/gltron
parentdad068d84dfe0bc26ed25ce1f808672be2a764c2 (diff)
downloadports-ff57a36a5814648f6bbfc2b0c2df08bc52a60e40.tar.gz
ports-ff57a36a5814648f6bbfc2b0c2df08bc52a60e40.zip
audio/sdl_sound:
- USES=libtool. - Strip library. - Replace patch+reinplace with a single reinplace. - Remove a patch so we use the upstream library name again. Bump PORTREVISION on all dependent ports. games/alephone: - USES=gmake tar:bzip2. - Remove unneeded PKG_CONFIG variable. - Staging. - New LIB_DEPENDS syntax. games/asc: - USES=libtool. games/gltron: - New LIB_DEPENDS syntax. - USES=gmake. - Remove references to PTHREAD_CFLAGS and PTHREAD_LIBS. - Use option helpers. - Staging. lang/kroc: (still BROKEN due to use of "python" command) - New LIB_DEPENDS syntax. - USES=pathfix tar:bzip2. - Staging. - Replace patches with post-patch. - Replace MAKE with MAKE_CMD. lang/smalltalk: - USES=libtool tar:xz. - Use BROKEN_sparc64.
Notes
Notes: svn path=/head/; revision=352933
Diffstat (limited to 'games/gltron')
-rw-r--r--games/gltron/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index dc78d46cb10b..8fec8233b48f 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -3,27 +3,29 @@
PORTNAME= gltron
PORTVERSION= 0.70
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
EXTRACT_SUFX= -source.tar.gz
MAINTAINER= lx@FreeBSD.org
-COMMENT= A 3D worm game for two players for X Window System
+COMMENT= 3D worm game for two players for X Window System
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+USES= gmake
USE_GL= gl
USE_SDL= sdl sound
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-warn
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= SDL_NET
SDL_NET_DESC= Network Support
+SDL_NET_USE= SDL=net
+SLD_NET_CONFIGURE_ENABLE= network
DESKTOP_ENTRIES= "GLtron" \
"3D lightcycle game" \
@@ -32,14 +34,6 @@ DESKTOP_ENTRIES= "GLtron" \
"Game;ArcadeGame;" \
false
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSDL_NET}
-USE_SDL+= net
-CONFIGURE_ARGS+= --enable-network
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS="-D|CFLAGS="$$CFLAGS -D|g ; \
s|-O$$enable_optimize||g' ${WRKSRC}/configure
@@ -49,11 +43,9 @@ post-patch:
s|-ansi -pedantic||g'
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ChangeLog README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>