aboutsummaryrefslogtreecommitdiff
path: root/games/gnuchess
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-01-30 19:02:37 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-01-30 19:02:37 +0000
commit81ff34883fd9a58104d735330efce0598f70b9d3 (patch)
treef3ddb7e67509fe6b29fe462d69fb40a9f51520e9 /games/gnuchess
parentd1c49198a9a8c02d9f5d63c9f7c9509860ba80a0 (diff)
downloadports-81ff34883fd9a58104d735330efce0598f70b9d3.tar.gz
ports-81ff34883fd9a58104d735330efce0598f70b9d3.zip
- Update gnuchess to 5.08 (now under GPLv3+)
- Claim maintainership - Remove obsoleted patch Feature safe: yes
Notes
Notes: svn path=/head/; revision=268458
Diffstat (limited to 'games/gnuchess')
-rw-r--r--games/gnuchess/Makefile14
-rw-r--r--games/gnuchess/distinfo6
-rw-r--r--games/gnuchess/files/patch-input.c11
3 files changed, 7 insertions, 24 deletions
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index 4e96a77c624e..a5ea8d168a94 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -6,26 +6,22 @@
#
PORTNAME= gnuchess
-PORTVERSION= 5.07
+PORTVERSION= 5.08
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= chess
# The DISTFILES here is explicitly needed because it can be extended later.
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= "Classic" Gnu Chess
PLIST_FILES= bin/gnuchess \
bin/gnuchessx
-.if !defined(NOPORTDOCS)
-PORTDOCS= ChangeLog \
- NEWS \
- README
-.endif
+PORTDOCS= *
-OPTIONS= OPENING_BOOK "Install opening book (24 MB download)" on
+OPTIONS= OPENING_BOOK "Install opening book (25 MB download)" on
.include <bsd.port.pre.mk>
@@ -37,7 +33,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" MKDIR_P="${MKDIR}"
post-patch:
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS:S/"//g}|g ; \
diff --git a/games/gnuchess/distinfo b/games/gnuchess/distinfo
index 0b6bfaa926f5..1d792a56922e 100644
--- a/games/gnuchess/distinfo
+++ b/games/gnuchess/distinfo
@@ -1,6 +1,4 @@
-MD5 (gnuchess-5.07.tar.gz) = 259da00aa559e5624c65279484fccaf7
-SHA256 (gnuchess-5.07.tar.gz) = b388e0265fe5ad3ee64da95b0dc0e28d943d29bfc95aa5c2cc7a7d57462d017e
-SIZE (gnuchess-5.07.tar.gz) = 234542
-MD5 (book_1.01.pgn.gz) = 1be508d7a38a8c9a7d599d0cd92b24a6
+SHA256 (gnuchess-5.08.tar.gz) = c4e49e0dec210f5d131a02ff89588b482787cd702a08456791ba9100b4c6ffc0
+SIZE (gnuchess-5.08.tar.gz) = 279309
SHA256 (book_1.01.pgn.gz) = 35df43a342c73e6624e8dbfed78d588c2085208168c3cd3300295e3c57981be0
SIZE (book_1.01.pgn.gz) = 26070544
diff --git a/games/gnuchess/files/patch-input.c b/games/gnuchess/files/patch-input.c
deleted file mode 100644
index 188fced02522..000000000000
--- a/games/gnuchess/files/patch-input.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/input.c.orig Tue Jun 5 23:34:06 2007
-+++ src/input.c Tue Jun 5 23:34:14 2007
-@@ -92,7 +92,7 @@
- fgets(inputstr, MAXSTR, stdin);
- }
-
--static pthread_t input_thread;
-+pthread_t input_thread;
-
- /* Mutex and condition variable for thread communication */
-