aboutsummaryrefslogtreecommitdiff
path: root/games/golly/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-12 12:32:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-12 12:32:08 +0000
commit0eb0adb1ef47f147c34035ee47cf015d5ee019c6 (patch)
tree86574b26646b9cdf92a2769b92eface4d87b777c /games/golly/Makefile
parent271e76a4a52ebad2ab743c41addb9de9525961dc (diff)
downloadports-0eb0adb1ef47f147c34035ee47cf015d5ee019c6.tar.gz
ports-0eb0adb1ef47f147c34035ee47cf015d5ee019c6.zip
games/golly: Fix build on aarch64 or when objdump is missing
Golly dlopens Python at runtime and looks up its shared library name during configure. It first tries to do this using distutils.sysconfig.get_config_var("LDLIBRARY"), and then tries to use objdump if that fails. Since the former is unlikely to ever fail on FreeBSD, objdump will never actually be called and we can pacify configure by pretending objdump is available.
Notes
Notes: svn path=/head/; revision=476986
Diffstat (limited to 'games/golly/Makefile')
-rw-r--r--games/golly/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/golly/Makefile b/games/golly/Makefile
index 209073dad408..ef32d9109fba 100644
--- a/games/golly/Makefile
+++ b/games/golly/Makefile
@@ -12,14 +12,17 @@ COMMENT= Conway's Game of Life and other cellular automata
LICENSE= GPLv2+
-BROKEN_aarch64= fails to configure: missing objdump
-
USES= compiler:c++11-lib python:2.7
USE_GL= gl glu
USE_WX= 3.0+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG:T}
+# Pretend objdump is available even if it is not e.g. on aarch64.
+# The Python shared library name is already looked up via
+# distutils.sysconfig.get_config_var("LDLIBRARY") which is unlikely
+# to fail; objdump is never actually used.
+CONFIGURE_ARGS= ac_cv_prog_OBJDUMP=/usr/bin/false \
+ --with-wx-config=${WX_CONFIG:T}
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib