aboutsummaryrefslogtreecommitdiff
path: root/games/golly
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-21 16:32:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-21 16:32:53 +0000
commit9ea2ab7d5e9ebc7b2e6d3388741db3419f433625 (patch)
treef851f9e176955f3fa43a673761c1aa09a74c5fec /games/golly
parent9d48dcd3f67a9b042cb314f3d7037989da25482c (diff)
downloadports-9ea2ab7d5e9ebc7b2e6d3388741db3419f433625.tar.gz
ports-9ea2ab7d5e9ebc7b2e6d3388741db3419f433625.zip
- Add LICENSE
- Fix plist
Notes
Notes: svn path=/head/; revision=439098
Diffstat (limited to 'games/golly')
-rw-r--r--games/golly/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/golly/Makefile b/games/golly/Makefile
index 6890466d1f34..2ad330bfee09 100644
--- a/games/golly/Makefile
+++ b/games/golly/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Conway's Game of Life and other cellular automata
+LICENSE= GPLv2+
+
USES= compiler:c++11-lib cmake:outsource perl5 python
USE_CXXSTD= c++11
USE_WX= 3.0
@@ -17,11 +19,14 @@ WX_UNICODE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/gui-wx
-DESKTOP_ENTRIES= "Golly" "${COMMENT}" "${PREFIX}/share/pixmaps/golly.xpm" \
- "${PREFIX}/bin/golly" "Education;" "true"
+DESKTOP_ENTRIES="Golly" "${COMMENT}" "${PREFIX}/share/pixmaps/golly.xpm" \
+ "${PREFIX}/bin/golly" "Education;" "true"
SUB_FILES= golly
+post-extract:
+ @${FIND} ${WRKSRC} -name "._*" -delete
+
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/golly ${STAGEDIR}/${PREFIX}/bin