aboutsummaryrefslogtreecommitdiff
path: root/games/gtypist
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-07-19 18:11:48 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-07-19 18:11:48 +0000
commiteb17ea2e314772512696152c2d8e50652781bd86 (patch)
treec4a25a31e90c3dbdd965f94556e409e7a987e4af /games/gtypist
parent7a1fcb907a4a2c6431f7c20a15c8176a87c36581 (diff)
downloadports-eb17ea2e314772512696152c2d8e50652781bd86.tar.gz
ports-eb17ea2e314772512696152c2d8e50652781bd86.zip
Update to 2.6. Notable changes in this release:
- New `typefortune' (perl-)script which creates lessons from `fortune'. - New interface messages in Czech. - New lessons in Czech.
Notes
Notes: svn path=/head/; revision=63255
Diffstat (limited to 'games/gtypist')
-rw-r--r--games/gtypist/Makefile18
-rw-r--r--games/gtypist/distinfo2
-rw-r--r--games/gtypist/files/patch-aclocal.m446
-rw-r--r--games/gtypist/files/patch-lessons_Makefile.am18
-rw-r--r--games/gtypist/files/patch-lessons_Makefile.in21
-rw-r--r--games/gtypist/pkg-plist6
6 files changed, 106 insertions, 5 deletions
diff --git a/games/gtypist/Makefile b/games/gtypist/Makefile
index 073ab2910ede..67d6cceace2c 100644
--- a/games/gtypist/Makefile
+++ b/games/gtypist/Makefile
@@ -5,20 +5,30 @@
# $FreeBSD$
PORTNAME= gtypist
-PORTVERSION= 2.5
-PORTREVISION= 1
+PORTVERSION= 2.6
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= naddy@FreeBSD.org
+# requires autoconf 2.5
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ CONFIG_SHELL="${SH}" \
+ EMACS=no
-MAN1= gtypist.1
+MAN1= gtypist.1 typefortune.1
+
+post-patch:
+ @cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/autoconf
+
+# Note:
+# Reformatting the info documentation would require makeinfo 4.2,
+# so we'll install multiple gtypist.info-* files as included.
.include <bsd.port.mk>
diff --git a/games/gtypist/distinfo b/games/gtypist/distinfo
index 13c5a82b22bf..1673e271ef6f 100644
--- a/games/gtypist/distinfo
+++ b/games/gtypist/distinfo
@@ -1 +1 @@
-MD5 (gtypist-2.5.tar.gz) = 401ab1b4ea346eb2f61d490bcbc8c417
+MD5 (gtypist-2.6.tar.gz) = ad75a481300ae874f6b8d6fb21f3cc10
diff --git a/games/gtypist/files/patch-aclocal.m4 b/games/gtypist/files/patch-aclocal.m4
new file mode 100644
index 000000000000..a65b366fd1a0
--- /dev/null
+++ b/games/gtypist/files/patch-aclocal.m4
@@ -0,0 +1,46 @@
+
+$FreeBSD$
+
+--- aclocal.m4.orig Sun Apr 28 07:34:23 2002
++++ aclocal.m4 Sun Jul 7 21:56:31 2002
+@@ -853,7 +853,7 @@
+ ]
+ )
+
+-# gettext.m4 serial 13 (gettext-0.11.1)
++# gettext.m4 serial 14 (gettext-0.11.2)
+ dnl Copyright (C) 1995-2002 Free Software Foundation, Inc.
+ dnl This file is free software, distributed under the terms of the GNU
+ dnl General Public License. As a special exception to the GNU General
+@@ -997,14 +997,13 @@
+ dnl Now see whether libintl exists and does not depend on libiconv.
+ AC_TRY_LINK([#include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ const char *_nl_expand_alias ();],
+ [bindtextdomain ("", "");
+-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
++return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
+ gt_cv_func_gnugettext_libintl=yes,
+ gt_cv_func_gnugettext_libintl=no)
+ dnl Now see whether libintl exists and depends on libiconv.
+@@ -1012,14 +1011,13 @@
+ LIBS="$LIBS $LIBICONV"
+ AC_TRY_LINK([#include <libintl.h>
+ extern int _nl_msg_cat_cntr;
+-extern int *_nl_domain_bindings;
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ const char *_nl_expand_alias ();],
+ [bindtextdomain ("", "");
+-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
++return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
+ [LIBINTL="$LIBINTL $LIBICONV"
+ LTLIBINTL="$LTLIBINTL $LTLIBICONV"
+ gt_cv_func_gnugettext_libintl=yes
diff --git a/games/gtypist/files/patch-lessons_Makefile.am b/games/gtypist/files/patch-lessons_Makefile.am
new file mode 100644
index 000000000000..9d3d46508468
--- /dev/null
+++ b/games/gtypist/files/patch-lessons_Makefile.am
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- lessons/Makefile.am.orig Sun Jul 7 23:08:16 2002
++++ lessons/Makefile.am Sun Jul 7 23:15:01 2002
+@@ -1,4 +1,11 @@
+ ## Process this file with automake to produce Makefile.in
+
+-pkgdata_DATA = $(wildcard *.typ)
++pkgdata_DATA = cs.typ d.typ demo.typ \
++ esp.typ gtypist.typ ktde.typ \
++ kten.typ ktfr.typ ktlecten.typ \
++ ktno.typ ktnumber.typ m.typ \
++ n.typ q.typ r.typ \
++ s.typ t.typ tinydemo.typ \
++ ttde.typ u.typ v.typ
++
+ EXTRA_DIST= $(pkgdata_DATA)
diff --git a/games/gtypist/files/patch-lessons_Makefile.in b/games/gtypist/files/patch-lessons_Makefile.in
new file mode 100644
index 000000000000..8353e82cf00e
--- /dev/null
+++ b/games/gtypist/files/patch-lessons_Makefile.in
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- lessons/Makefile.in.orig Sun Jul 7 23:08:19 2002
++++ lessons/Makefile.in Sun Jul 7 23:15:23 2002
+@@ -104,7 +104,14 @@
+ install_sh = @install_sh@
+ lispdir = @lispdir@
+
+-pkgdata_DATA = $(wildcard *.typ)
++pkgdata_DATA = cs.typ d.typ demo.typ \
++ esp.typ gtypist.typ ktde.typ \
++ kten.typ ktfr.typ ktlecten.typ \
++ ktno.typ ktnumber.typ m.typ \
++ n.typ q.typ r.typ \
++ s.typ t.typ tinydemo.typ \
++ ttde.typ u.typ v.typ
++
+ EXTRA_DIST = $(pkgdata_DATA)
+ subdir = lessons
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/games/gtypist/pkg-plist b/games/gtypist/pkg-plist
index 09cc1a27b11d..457bcb5ba726 100644
--- a/games/gtypist/pkg-plist
+++ b/games/gtypist/pkg-plist
@@ -1,8 +1,12 @@
@comment $FreeBSD$
@unexec install-info --delete %D/info/gtypist.info %D/info/dir
info/gtypist.info
+info/gtypist.info-1
+info/gtypist.info-2
@exec install-info %D/info/gtypist.info %D/info/dir
bin/gtypist
+bin/typefortune
+share/gtypist/cs.typ
share/gtypist/d.typ
share/gtypist/demo.typ
share/gtypist/esp.typ
@@ -19,9 +23,11 @@ share/gtypist/q.typ
share/gtypist/r.typ
share/gtypist/s.typ
share/gtypist/t.typ
+share/gtypist/tinydemo.typ
share/gtypist/ttde.typ
share/gtypist/u.typ
share/gtypist/v.typ
+share/locale/cs/LC_MESSAGES/gtypist.mo
share/locale/de/LC_MESSAGES/gtypist.mo
share/locale/es/LC_MESSAGES/gtypist.mo
share/locale/fi/LC_MESSAGES/gtypist.mo