aboutsummaryrefslogtreecommitdiff
path: root/games/hangman/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-11 15:31:49 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-11 15:31:49 +0000
commita8a78b71034397cfd9fcbc3a1d3fcb0dc4df1d0e (patch)
tree235960567becb2e2b3588b741f8f013045f41413 /games/hangman/Makefile
parentaf6fa01c54585239fa5267fb8aa136a913e55a6c (diff)
downloadports-a8a78b71034397cfd9fcbc3a1d3fcb0dc4df1d0e.tar.gz
ports-a8a78b71034397cfd9fcbc3a1d3fcb0dc4df1d0e.zip
Notes
Diffstat (limited to 'games/hangman/Makefile')
-rw-r--r--games/hangman/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/games/hangman/Makefile b/games/hangman/Makefile
new file mode 100644
index 000000000000..0e886439ab87
--- /dev/null
+++ b/games/hangman/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: hangman
+# Date created: 10 Nov 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hangman
+PORTVERSION= 0.9.2
+CATEGORIES= games
+MASTER_SITES= http://www.shiftygames.com/hangman/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Challenge your spelling skills in the old western style
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_SDL= sdl mixer image ttf
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="`${SDL_CONFIG} --libs`" \
+ CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ SDL_CONFIG="${SDL_CONFIG}"
+
+MAN6= hangman.6
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DICTIONARY)
+DICTIONARY=${WITH_DICTIONARY}
+.else
+DICTIONARY=/usr/share/dict/words
+
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "You may want to use different dictionary instead of the default one,"
+ @${ECHO} "which is /usr/share/dict/words. If so, use the following option:"
+ @${ECHO} ""
+ @${ECHO} " WITH_DICTIONARY=/path/to/your/dictionary"
+ @${ECHO} ""
+.endif
+
+.if !exists(${DICTIONARY})
+pre-configure:
+ @${ECHO} ""
+ @${ECHO} "Dictionary ${DICTIONARY} does not exist"
+ @${ECHO} "Please, specify correct one with WITH_DICTIONARY option"
+ @${FALSE}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/share/dict/words|${DICTIONARY}|g' ${WRKSRC}/src/hangman.c
+ @${REINPLACE_CMD} -e 's|-std=gnu99||g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>