aboutsummaryrefslogtreecommitdiff
path: root/games/hedgewars
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2019-05-16 09:46:29 +0000
committerGleb Popov <arrowd@FreeBSD.org>2019-05-16 09:46:29 +0000
commit22f8369c2407ec0db16d9f8e53c327f29b1aaaee (patch)
tree0a15e0ee4d6480ea1d9b8fbcc6fd710bcb46bd0c /games/hedgewars
parent11309e7b2c9c96b91e75b0d16451f214a48ea3e6 (diff)
downloadports-22f8369c2407ec0db16d9f8e53c327f29b1aaaee.tar.gz
ports-22f8369c2407ec0db16d9f8e53c327f29b1aaaee.zip
games/hedgewars: Fix build on i386 arch.
It turned out that GHC is still required in the build process to create a small utility program written in Haskell and used in the build. Reported by: antoine Reviewed by: tcberner (mentor, implicit)
Notes
Notes: svn path=/head/; revision=501782
Diffstat (limited to 'games/hedgewars')
-rw-r--r--games/hedgewars/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
index 7d6c40dd0e30..e0d6a2720877 100644
--- a/games/hedgewars/Makefile
+++ b/games/hedgewars/Makefile
@@ -15,8 +15,10 @@ COMMENT= Free Worms-like turn based strategy game
LICENSE= GPLv2 GFDL
LICENSE_COMB= multi
-LIB_DEPENDS= libphysfs.so:devel/physfs \
- libpng.so:graphics/png
+BUILD_DEPENDS= ${${ARCH}_BUILD_DEPENDS}
+i386_BUILD_DEPENDS= ghc:lang/ghc
+LIB_DEPENDS= libphysfs.so:devel/physfs \
+ libpng.so:graphics/png
USES= cmake:noninja desktop-file-utils fpc gl lua:51 qt:5 tar:bzip2 pkgconfig
USE_SDL= sdl2 mixer2 image2 ttf2 net2