aboutsummaryrefslogtreecommitdiff
path: root/games/hedgewars
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-08 21:42:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-07-08 21:42:37 +0000
commitfb928f69096853c4fcfdb80fb46620f8e1dcf616 (patch)
tree3814cdb5bd2338c7a5456b8fc098be62e605b5ed /games/hedgewars
parentf9a88a2faee7b980dc930317cf15ea89978f4f21 (diff)
downloadports-fb928f69096853c4fcfdb80fb46620f8e1dcf616.tar.gz
ports-fb928f69096853c4fcfdb80fb46620f8e1dcf616.zip
Fix build on i386
Notes
Notes: svn path=/head/; revision=541719
Diffstat (limited to 'games/hedgewars')
-rw-r--r--games/hedgewars/Makefile4
-rw-r--r--games/hedgewars/files/patch-CMakeLists.txt22
-rw-r--r--games/hedgewars/files/patch-QTfrontend_CMakeLists.txt16
3 files changed, 40 insertions, 2 deletions
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
index d95d505fd554..720aecc157e3 100644
--- a/games/hedgewars/Makefile
+++ b/games/hedgewars/Makefile
@@ -15,8 +15,6 @@ COMMENT= Free Worms-like turn based strategy game
LICENSE= GPLv2 GFDL
LICENSE_COMB= multi
-BROKEN_i386= uSound.pas: hGetContents: invalid argument (invalid byte sequence)
-
LIB_DEPENDS= libphysfs.so:devel/physfs \
libpng.so:graphics/png
@@ -40,6 +38,8 @@ PLIST_FILES= bin/${PORTNAME} bin/hwengine \
lib/libphyslayer.so.1.0
PORTDATA= *
+USE_LOCALE= en_US.UTF-8
+
OPTIONS_DEFINE= VIDEOREC
OPTIONS_DEFAULT=VIDEOREC
OPTIONS_EXCLUDE_i386= VIDEOREC # some pascal issues preventing to use it
diff --git a/games/hedgewars/files/patch-CMakeLists.txt b/games/hedgewars/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..fd504f47a7b2
--- /dev/null
+++ b/games/hedgewars/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2019-10-10 13:38:46 UTC
++++ CMakeLists.txt
+@@ -180,19 +180,6 @@ else()
+ endif()
+
+
+-#build engine without freepascal
+-if(BUILD_ENGINE_C AND NOT BUILD_ENGINE_JS)
+- find_package(Clang REQUIRED)
+-
+- if(${CLANG_VERSION} VERSION_LESS "3.0")
+- message(FATAL_ERROR "LLVM/Clang compiler required version is 3.0 but version ${CLANG_VERSION} was found!")
+- endif()
+-
+- set(CMAKE_C_COMPILER ${CLANG_EXECUTABLE})
+- set(CMAKE_CXX_COMPILER ${CLANG_EXECUTABLE})
+-endif()
+-
+-
+ #server
+ if(NOT NOSERVER)
+ add_subdirectory(gameServer)
diff --git a/games/hedgewars/files/patch-QTfrontend_CMakeLists.txt b/games/hedgewars/files/patch-QTfrontend_CMakeLists.txt
new file mode 100644
index 000000000000..0b0c826624b9
--- /dev/null
+++ b/games/hedgewars/files/patch-QTfrontend_CMakeLists.txt
@@ -0,0 +1,16 @@
+--- QTfrontend/CMakeLists.txt.orig 2019-10-10 13:38:46 UTC
++++ QTfrontend/CMakeLists.txt
+@@ -247,13 +247,6 @@ if(WIN32 AND NOT UNIX)
+ )
+ endif()
+
+-if(CMAKE_CXX_COMPILER MATCHES "clang*")
+- list(APPEND HW_LINK_LIBS stdc++ m)
+- if(NOT APPLE)
+- list(APPEND HW_LINK_LIBS atomic)
+- endif()
+-endif()
+-
+ if(WIN32 AND VCPKG_TOOLCHAIN)
+ list(APPEND HW_LINK_LIBS Qt5::WinMain)
+ endif()