aboutsummaryrefslogtreecommitdiff
path: root/games/help_hannahs_horse
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-26 14:47:29 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-26 14:47:29 +0000
commit444fb1d6dfedb1ba8e074b3459e900659093f0b7 (patch)
tree417321dd03f15b4122910c52d56a1709cc178858 /games/help_hannahs_horse
parentb0d9fbdad98615a309c05870c3c0e1778d53b4ad (diff)
downloadports-444fb1d6dfedb1ba8e074b3459e900659093f0b7.tar.gz
ports-444fb1d6dfedb1ba8e074b3459e900659093f0b7.zip
- Change Makefile header
- Change master sites - USES gmake instead of USE_GMAKE - Add DOCS Option - Change Desktop entry file - Support STAGEDIR - Break lines around 80 characters - Mute dir install Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=337528
Diffstat (limited to 'games/help_hannahs_horse')
-rw-r--r--games/help_hannahs_horse/Makefile49
1 files changed, 24 insertions, 25 deletions
diff --git a/games/help_hannahs_horse/Makefile b/games/help_hannahs_horse/Makefile
index 7406cf4ba479..4ab6e1de59a9 100644
--- a/games/help_hannahs_horse/Makefile
+++ b/games/help_hannahs_horse/Makefile
@@ -1,11 +1,11 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= help_hannahs_horse
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= SF/hannah/hannah/hannah-${DISTVERSION}/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= hhh-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons.tar.gz:icons
DIST_SUBDIR= ${PORTNAME}
@@ -18,51 +18,50 @@ LICENSE_COMB= dual
WRKSRC= ${WRKDIR}/hhh-2008-03-29
+USES= gmake
USE_SDL= sdl image mixer ttf
-USE_GMAKE= yes
ALL_TARGET= # empty
PORTDOCS= CHANGELOG README TODO
+OPTIONS_DEFINE= DOCS
+
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
-DESKTOP_ENTRIES="Help Hannah's Horse" "${COMMENT}" "${PORTNAME}.png" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="Help Hannah's Horse" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/games/hhh|${DATADIR}|' \
- -e 's|/usr/local/bin|${PREFIX}/bin|' \
- -e 's|CXX = g++|CXX ?= g++|' \
- -e 's|CXXFLAGS = -O2 -Wall -g|CXXFLAGS +=|' \
- -e 's|OUT = hhh|OUT = ${PORTNAME}|' \
- -e 's|-include deps|#-include deps|' \
+ @${REINPLACE_CMD} -e 's|/usr/local/games/hhh|${DATADIR}| ; \
+ s|/usr/local/bin|${PREFIX}/bin| ; \
+ s|CXX = g++|CXX ?= g++}| ; \
+ s|CXXFLAGS = -O2 -Wall -g|CXXFLAGS +=| ; \
+ s|OUT = hhh|OUT = ${PORTNAME}| ; \
+ s|-include deps|#-include deps|' \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
-.for d in blue carrot default freeze hannah images invert invis maps newanim pink red sounds stop
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+.for d in blue carrot default freeze hannah images invert invis maps newanim \
+ pink red sounds stop
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
.for d in *.ogg *.ttf *.dat *.png
- @(cd ${WRKSRC} && ${INSTALL_DATA} ${d} ${DATADIR})
+ @(cd ${WRKSRC} && ${INSTALL_DATA} ${d} ${STAGEDIR}${DATADIR})
.endfor
post-install:
.for s in ${ICON_SIZES}
- ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
- ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>