aboutsummaryrefslogtreecommitdiff
path: root/games/heroes
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-07 05:57:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-07 05:57:31 +0000
commit78b6d3b86ec2285a52d33c3186629af12ccbe050 (patch)
treedc9d38e006fa7111c1913b76c6d08f12568fd4ea /games/heroes
parent2947194cb463fdfc88c905997b621a830431203f (diff)
downloadports-78b6d3b86ec2285a52d33c3186629af12ccbe050.tar.gz
ports-78b6d3b86ec2285a52d33c3186629af12ccbe050.zip
BROKEN on alpha 5.x: Does not compile
Notes
Notes: svn path=/head/; revision=103171
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 9b3de82b2048..004a565695e9 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -49,6 +49,12 @@ INFO= heroes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+BROKEN= "Does not compile on alpha >=5.x"
+.endif
+
post-patch:
@for dir in ${DATASRC} ${SOUNDSRC} ${MUSICSRC}; do \
${FIND} $${dir} -name "Makefile*" | ${XARGS} ${RM}; \
@@ -66,4 +72,4 @@ post-install:
${MKDIR} ${DATADIR}/mod
${INSTALL_DATA} ${MUSICSRC}/*.xm ${MUSICSRC}/sound.conf ${DATADIR}/mod
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>