aboutsummaryrefslogtreecommitdiff
path: root/games/heroes
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-25 22:42:39 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-25 22:42:39 +0000
commitbb1032b31055cbe8e5372dfe9d47e29479a41871 (patch)
tree7151cf13e0cce298d1132b2240c910a6cde785ad /games/heroes
parent67f362deb11608426e6fd6b93a32052d63148b4b (diff)
downloadports-bb1032b31055cbe8e5372dfe9d47e29479a41871.tar.gz
ports-bb1032b31055cbe8e5372dfe9d47e29479a41871.zip
Notes
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile34
-rw-r--r--games/heroes/files/patch-configure10
-rw-r--r--games/heroes/files/patch-src__menus.c6
-rw-r--r--games/heroes/files/patch-src_hedlite.c36
-rw-r--r--games/heroes/files/patch-src_persona.h13
5 files changed, 58 insertions, 41 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index ab347efef9a9..10feffdf6e98 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -3,7 +3,7 @@
PORTNAME= heroes
PORTVERSION= 0.21
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= games
MASTER_SITES= SF \
SF/${PORTNAME}/${PORTNAME}-data/${DATAVERSION}:data \
@@ -20,30 +20,34 @@ COMMENT= Game of yore similar to the "Tron" and "Nibbles"
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-DATAVERSION= 1.5
-SOUNDVERSION= 1.0
-MUSICVERSION= 1.0
-DATADISTNAME= ${PORTNAME}-data-${DATAVERSION}
-SOUNDISTNAME= ${PORTNAME}-sound-effects-${SOUNDVERSION}
-MUSICDISTNAME= ${PORTNAME}-sound-tracks-${MUSICVERSION}
-DATASRC= ${WRKDIR}/${DATADISTNAME}
-SOUNDSRC= ${WRKDIR}/${SOUNDISTNAME}
-MUSICSRC= ${WRKDIR}/${MUSICDISTNAME}
+LIB_DEPENDS= libsmpeg.so:multimedia/smpeg
-USE_SDL= mixer sdl
USES= gettext gmake iconv makeinfo sdl
+USE_SDL= mixer sdl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split"
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE} --without-gii --without-ggi
+CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split"
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lsmpeg -lm
+
+INFO= heroes
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
OPTIMIZED_CFLAGS_CONFIGURE_ENABLE= optimizations
-INFO= heroes
+DATADISTNAME= ${PORTNAME}-data-${DATAVERSION}
+DATASRC= ${WRKDIR}/${DATADISTNAME}
+DATAVERSION= 1.5
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lsmpeg -lm
+MUSICDISTNAME= ${PORTNAME}-sound-tracks-${MUSICVERSION}
+MUSICSRC= ${WRKDIR}/${MUSICDISTNAME}
+MUSICVERSION= 1.0
+
+SOUNDISTNAME= ${PORTNAME}-sound-effects-${SOUNDVERSION}
+SOUNDSRC= ${WRKDIR}/${SOUNDISTNAME}
+SOUNDVERSION= 1.0
post-patch:
@for dir in ${DATASRC} ${SOUNDSRC} ${MUSICSRC}; do \
diff --git a/games/heroes/files/patch-configure b/games/heroes/files/patch-configure
index 69671e1f7c4e..7d7bdf5dff75 100644
--- a/games/heroes/files/patch-configure
+++ b/games/heroes/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sat Mar 30 19:36:16 2002
-+++ configure Sat Apr 6 16:11:51 2002
-@@ -13339,7 +13339,7 @@
+--- configure.orig 2002-03-30 17:36:16 UTC
++++ configure
+@@ -13339,7 +13339,7 @@ _ACEOF
CFLAGS="$CFLAGS -ggdb3"
else
if test "${ac_cv_prog_cc_g}" = yes; then
@@ -9,7 +9,7 @@
fi
fi
;;
-@@ -13347,7 +13347,7 @@
+@@ -13347,7 +13347,7 @@ _ACEOF
;;
*)
if test "${ac_cv_prog_cc_g}" = yes; then
@@ -18,7 +18,7 @@
fi
;;
esac
-@@ -13367,7 +13367,7 @@
+@@ -13367,7 +13367,7 @@ else
int main(int argc, char *argv[]) { return argv[argc-1] == 0; }
EOF
cf_save_CFLAGS="$CFLAGS"
diff --git a/games/heroes/files/patch-src__menus.c b/games/heroes/files/patch-src__menus.c
index 134b7c35774b..f37646330a7a 100644
--- a/games/heroes/files/patch-src__menus.c
+++ b/games/heroes/files/patch-src__menus.c
@@ -1,6 +1,6 @@
---- src/menus.c.orig Mon Jan 14 17:13:59 2002
-+++ src/menus.c Mon Mar 1 16:25:56 2004
-@@ -219,7 +219,8 @@
+--- src/menus.c.orig 2002-01-14 22:13:59 UTC
++++ src/menus.c
+@@ -219,7 +219,8 @@ a_menu_entry editor_entries[] = {
{ N_("NEW LEVEL"), editor_menu },
/* TRANS: Load an existing level for edition. */
{ N_("LOAD LEVEL"), editor_selector },
diff --git a/games/heroes/files/patch-src_hedlite.c b/games/heroes/files/patch-src_hedlite.c
index 75c829771191..71ecf66dc9a1 100644
--- a/games/heroes/files/patch-src_hedlite.c
+++ b/games/heroes/files/patch-src_hedlite.c
@@ -1,5 +1,5 @@
---- src/hedlite.c.orig 2002-02-06 22:49:44.000000000 +0100
-+++ src/hedlite.c 2007-10-02 16:33:06.000000000 +0200
+--- src/hedlite.c.orig 2002-02-06 21:49:44 UTC
++++ src/hedlite.c
@@ -45,7 +45,7 @@
#include "dirname.h"
@@ -9,7 +9,7 @@
unsigned short int xdalles = 0;
unsigned short int ydalles = 0;
-@@ -144,9 +144,9 @@
+@@ -144,9 +144,9 @@ rectangle_copy (int xs, int ys, int xd, int yd,
static void
copy_tile (int src_, a_pixel *dest)
{
@@ -21,7 +21,7 @@
for (j = 20; j > 0; j--) {
fastmem4 (src, dest, 24 >> 2);
src += i;
-@@ -157,9 +157,9 @@
+@@ -157,9 +157,9 @@ copy_tile (int src_, a_pixel *dest)
static void
copy_tile_pcx (int src_, a_pixel *dest)
{
@@ -33,7 +33,7 @@
for (j = 20; j > 0; j--) {
fastmem4 (src, dest, 24 >> 2);
src += i;
-@@ -170,9 +170,9 @@
+@@ -170,9 +170,9 @@ copy_tile_pcx (int src_, a_pixel *dest)
static void
copy_tile_transp (int src_, a_pixel *dest)
{
@@ -45,7 +45,7 @@
for (j = 20; j > 0; j--) {
for (k = 24; k > 0; k--) {
if (*src != 0)
-@@ -188,9 +188,9 @@
+@@ -188,9 +188,9 @@ copy_tile_transp (int src_, a_pixel *dest)
static void
copy_tile_transp_pcx (int src_, a_pixel *dest)
{
@@ -57,7 +57,7 @@
for (j = 20; j > 0; j--) {
for (k = 24; k > 0; k--) {
if (*src != 0)
-@@ -555,7 +555,7 @@
+@@ -555,7 +555,7 @@ anim_mod_bcl (int i, int x, int y)
static void
update_middle_panel (void)
{
@@ -66,7 +66,7 @@
frame (145 + xdallesdec, ydalles, 23, 19, 15);
rectangle_copy (0, 64, 30, 6, 290, 64, &heditrsc);
sprintf (nombre, "%u", (xdalles + xdallesdec) / 24);
-@@ -670,7 +670,7 @@
+@@ -670,7 +670,7 @@ static int
curdalled (void)
{
int i =
@@ -75,7 +75,7 @@
return i;
}
-@@ -894,7 +894,7 @@
+@@ -894,7 +894,7 @@ save_level_as_pcx (void)
free (tempc);
putc (0xC, fpcx);
for (i1 = 0; i1 < 768; i1++)
@@ -84,7 +84,7 @@
fclose (fpcx);
}
-@@ -1225,7 +1225,7 @@
+@@ -1225,7 +1225,7 @@ gestclav (a_keycode i, a_keycode mod)
}
} else if (i == HK_End) {
if (mod & HK_MOD_Ctrl) {
@@ -93,7 +93,7 @@
update_middle_panel ();
}
} else if (i == HK_PageDown) {
-@@ -1250,7 +1250,7 @@
+@@ -1250,7 +1250,7 @@ gestclav (a_keycode i, a_keycode mod)
}
} else if (i == HK_Right) {
if (mod & HK_MOD_Ctrl) {
@@ -102,7 +102,7 @@
xdalles += 24;
update_middle_panel ();
} else if (xdallesdec < 120) {
-@@ -1337,7 +1337,7 @@
+@@ -1337,7 +1337,7 @@ gestclav (a_keycode i, a_keycode mod)
} else if (i == HK_Space) {
j = curdallep ();
level_map[j].number =
@@ -111,7 +111,7 @@
level_map[j].type = ddef[curdalled ()].type;
level_map[j].info = ddef[curdalled ()].info;
gestclav (HK_i, HK_MOD_None);
-@@ -1351,9 +1351,9 @@
+@@ -1351,9 +1351,9 @@ gestclav (a_keycode i, a_keycode mod)
level_map[j].collision[3] = 0;
}
for (j = hplaninfo.xt * hplaninfo.yt - 1; j >= 0; j--) {
@@ -124,7 +124,7 @@
level_map[j].type = ddef[k].type;
if (level_map[j].type != t_tunnel) {
if (level_map[j].type == t_anim || i == 0x1749)
-@@ -1404,7 +1404,7 @@
+@@ -1404,7 +1404,7 @@ gestclav (a_keycode i, a_keycode mod)
if (mod & HK_MOD_Ctrl) {
for (j = hplaninfo.xt * hplaninfo.yt - 1; j >= 0; j--) {
level_map[j].number = xdalles + xdallesdec +
@@ -133,7 +133,7 @@
level_map[j].type = ddef[curdalled ()].type;
level_map[j].info = ddef[curdalled ()].info;
}
-@@ -1414,7 +1414,7 @@
+@@ -1414,7 +1414,7 @@ gestclav (a_keycode i, a_keycode mod)
level_map[j].number =
(((j % hplaninfo.xt) + (j / hplaninfo.xt)) & 1) * 20 *
@@ -142,7 +142,7 @@
update_left_panel ();
}
} else if (i == HK_F3) {
-@@ -1427,7 +1427,7 @@
+@@ -1427,7 +1427,7 @@ gestclav (a_keycode i, a_keycode mod)
if (level_map[curdallep ()].sprite == 0)
level_map[curdallep ()].sprite =
@@ -151,7 +151,7 @@
else
level_map[curdallep ()].sprite = 0;
update_left_panel ();
-@@ -1707,17 +1707,17 @@
+@@ -1707,17 +1707,17 @@ hmain (const char* lname, const char* tset_name,
hplaninfo.tile_set_name), ".pie");
pcx_load_from_rsc ("editor-img", &heditrsc);
@@ -173,7 +173,7 @@
rectangle_copy (0, 0, 30, 200, 290, 0, &heditrsc);
strupr (levelnomshort);
draw_text (levelnomshort, 305, 29, 8, 1);
-@@ -1767,7 +1767,7 @@
+@@ -1767,7 +1767,7 @@ hmain (const char* lname, const char* tset_name,
free (ddef);
free (level_map);
img_free (&heditrsc);
diff --git a/games/heroes/files/patch-src_persona.h b/games/heroes/files/patch-src_persona.h
new file mode 100644
index 000000000000..92b14b7c2da1
--- /dev/null
+++ b/games/heroes/files/patch-src_persona.h
@@ -0,0 +1,13 @@
+--- src/persona.h.orig 2001-09-21 10:43:54 UTC
++++ src/persona.h
+@@ -28,8 +28,8 @@
+ * difference only if the program has a sgid or suid bit.
+ */
+
+-bool keep_sgid; /* Whether we should keep the */
+-bool keep_suid; /* SGID or SUID priviledge. */
++extern bool keep_sgid; /* Whether we should keep the */
++extern bool keep_suid; /* SGID or SUID priviledge. */
+
+ /* Get information about the current persona,
+ and switch to the user persona. */