aboutsummaryrefslogtreecommitdiff
path: root/games/heroes
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-02 08:52:05 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-02 08:52:05 +0000
commitbb61b57fa680294e9f8294060712ebda179dcf1e (patch)
tree9b1db70a2026f3d0884d01ab5ae191fce669c4bb /games/heroes
parent71ce93513259551f9576c619f373a5f2e4029a19 (diff)
downloadports-bb61b57fa680294e9f8294060712ebda179dcf1e.tar.gz
ports-bb61b57fa680294e9f8294060712ebda179dcf1e.zip
- Fix segfaults
- Assign maintainership to submitter PR: ports/63618 Submitted by: Josh Elsasser <jre@vineyard.net>
Notes
Notes: svn path=/head/; revision=102704
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile6
-rw-r--r--games/heroes/files/patch-src::menus.c12
2 files changed, 15 insertions, 3 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index ca3060be1e6f..9b3de82b2048 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= heroes
PORTVERSION= 0.21
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
#PATCH_SITES= ftp://heroes.sourceforge.net/pub/heroes/patches/
#PATCHFILES= heroes-0.7-errata.patch
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jre@vineyard.net
COMMENT= A game of yore similar to the "Tron" and "Nibbles"
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
@@ -41,7 +41,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE} --without-gii
+CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE} --without-gii --without-ggi
MAN6= heroes.6 heroeslvl.6
INFO= heroes
diff --git a/games/heroes/files/patch-src::menus.c b/games/heroes/files/patch-src::menus.c
new file mode 100644
index 000000000000..134b7c35774b
--- /dev/null
+++ b/games/heroes/files/patch-src::menus.c
@@ -0,0 +1,12 @@
+--- src/menus.c.orig Mon Jan 14 17:13:59 2002
++++ src/menus.c Mon Mar 1 16:25:56 2004
+@@ -219,7 +219,8 @@
+ { N_("NEW LEVEL"), editor_menu },
+ /* TRANS: Load an existing level for edition. */
+ { N_("LOAD LEVEL"), editor_selector },
+- { N_("GO BACK"), 0 }
++ { N_("GO BACK"), 0 },
++ { 0, 0 }
+ };
+
+ a_menu *editor_menu_data;