aboutsummaryrefslogtreecommitdiff
path: root/games/hex-a-hop
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /games/hex-a-hop
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'games/hex-a-hop')
-rw-r--r--games/hex-a-hop/Makefile3
-rw-r--r--games/hex-a-hop/files/patch-src-text.cpp11
2 files changed, 2 insertions, 12 deletions
diff --git a/games/hex-a-hop/Makefile b/games/hex-a-hop/Makefile
index 2ec960f0efcc..512d351a25ed 100644
--- a/games/hex-a-hop/Makefile
+++ b/games/hex-a-hop/Makefile
@@ -3,13 +3,14 @@
PORTNAME= hex-a-hop
PORTVERSION= 1.1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME:S/-//g}/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Puzzle game based on hexagonal tiles
+USES= iconv
USE_SDL= sdl
GNU_CONFIGURE= yes
diff --git a/games/hex-a-hop/files/patch-src-text.cpp b/games/hex-a-hop/files/patch-src-text.cpp
deleted file mode 100644
index 8bfce50bf2dd..000000000000
--- a/games/hex-a-hop/files/patch-src-text.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/text.cpp~
-+++ src/text.cpp
-@@ -439,7 +439,7 @@ void ConvertToUTF8(const std::string &te
- errno = 0;
- static const char *locale_enc = gettext_init.GetEncoding();
- iconv_t cd = iconv_open("UTF-8", locale_enc);
-- char *in_buf = const_cast<char *>(&text_locally_encoded[0]);
-+ const char *in_buf = const_cast<char *>(&text_locally_encoded[0]);
- char *out_buf = &text_utf8[0];
- iconv(cd, &in_buf, &text_length, &out_buf, &text_utf8_length);
- iconv_close(cd);