aboutsummaryrefslogtreecommitdiff
path: root/games/hex-a-hop
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
commitc7c32639cce504dbfefa9d1a09034d60600acaca (patch)
tree542278ecb4449b3df78960fd5f6cf7d8be50914f /games/hex-a-hop
parent42aab3eb75f5152697ee03e5e8457ce58906e2c1 (diff)
downloadports-c7c32639cce504dbfefa9d1a09034d60600acaca.tar.gz
ports-c7c32639cce504dbfefa9d1a09034d60600acaca.zip
Convert my ports to new options helpers
Notes
Notes: svn path=/head/; revision=395231
Diffstat (limited to 'games/hex-a-hop')
-rw-r--r--games/hex-a-hop/Makefile43
1 files changed, 15 insertions, 28 deletions
diff --git a/games/hex-a-hop/Makefile b/games/hex-a-hop/Makefile
index 512d351a25ed..b554a9a3cd23 100644
--- a/games/hex-a-hop/Makefile
+++ b/games/hex-a-hop/Makefile
@@ -20,41 +20,28 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= PANGO SOUND NLS DEBUG
OPTIONS_DEFAULT= SOUND
+
+DEBUG_CONFIGURE_ENABLE= debug
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENV= ac_cv_header_libintl_h=yes
+NLS_CONFIGURE_ENV_OFF= ac_cv_header_libintl_h=no
+NLS_LDFLAGS= -lintl
+
PANGO_DESC= Use sdl_pango instead of sdl_ttf
+PANGO_USE= SDL=pango
+PANGO_USE_OFF= SDL=ttf
+PANGO_CONFIGURE_ENABLE= sdlttf
+
SOUND_DESC= Sound support
+SOUND_USE= SDL=mixer
+SOUND_CONFIGURE_ENABLE= sound
DESKTOP_ENTRIES="Hex-a-Hop" "${COMMENT}" \
"${DATADIR}/icon.bmp" \
"hex-a-hop" "LogicGame;Game;" false
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--disable-debug
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ENV+= ac_cv_header_libintl_h=yes
-LDFLAGS+= -lintl
-.else
-CONFIGURE_ENV+= ac_cv_header_libintl_h=no
-.endif
-
-.if ${PORT_OPTIONS:MPANGO}
-USE_SDL+= pango
-CONFIGURE_ARGS+=--disable-sdlttf
-.else
-USE_SDL+= ttf
-.endif
-
-.if ${PORT_OPTIONS:MSOUND}
-USE_SDL+= mixer
-.else
-CONFIGURE_ARGS+=--disable-sound
-.endif
-
-post-patch: .SILENT
+post-patch:
${REINPLACE_CMD} -E '/CFLAGS|CXXFLAGS/s/-g//' ${WRKSRC}/configure
.include <bsd.port.mk>