aboutsummaryrefslogtreecommitdiff
path: root/games/hllib
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-10-22 20:39:45 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-10-22 20:39:45 +0000
commitc5e65a3c7f54287caa26066bb1dab90c9805b18e (patch)
treec2153f5e6623a30e7e7a32c204930c3962c0d10f /games/hllib
parentd5b8cef6a5981c00e1a04f9be8ec74ba50b47e5d (diff)
downloadports-c5e65a3c7f54287caa26066bb1dab90c9805b18e.tar.gz
ports-c5e65a3c7f54287caa26066bb1dab90c9805b18e.zip
Add HLLib, library for Half-Life that abstracts several package formats and
provides a simple interface for all of them. WWW: http://nemesis.thewavelength.net/index.php?p=35
Notes
Notes: svn path=/head/; revision=201771
Diffstat (limited to 'games/hllib')
-rw-r--r--games/hllib/Makefile31
-rw-r--r--games/hllib/distinfo3
-rw-r--r--games/hllib/pkg-descr8
3 files changed, 42 insertions, 0 deletions
diff --git a/games/hllib/Makefile b/games/hllib/Makefile
new file mode 100644
index 000000000000..c79d93bd9cdb
--- /dev/null
+++ b/games/hllib/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: HLLib
+# Date created: 22 Oct 2007
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hllib
+PORTVERSION= 2.0.6
+CATEGORIES= games devel
+MASTER_SITES= http://nemesis.thewavelength.net/files/files/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}208
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Library to work with various Half-Life file formats
+
+USE_ZIP= yes
+USE_DOS2UNIX= Makefile
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/HLLib
+
+PLIST_FILES= include/hl.h lib/libhl.so.${PORTVERSION} \
+ lib/libhl.so.2 lib/libhl.so
+
+post-extract:
+# Allow propagating of CXX, CXXFLAGS, and PREFIX; fix Linuxism and symlinks
+ @${REINPLACE_CMD} -E 's,^([CP][^=]*)=,\1?=, ; s,g root,g wheel, ; \
+ s,s \$$\(PREFIX\)/lib/,s ,' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/games/hllib/distinfo b/games/hllib/distinfo
new file mode 100644
index 000000000000..b941dbdee71d
--- /dev/null
+++ b/games/hllib/distinfo
@@ -0,0 +1,3 @@
+MD5 (hllib208.zip) = 4065e54e092ab657a9250393d8e5548d
+SHA256 (hllib208.zip) = 0f43a282887ac007f6ecb0bd081fefb486c1fd63c9e92e3e9febe536f846e7d9
+SIZE (hllib208.zip) = 316370
diff --git a/games/hllib/pkg-descr b/games/hllib/pkg-descr
new file mode 100644
index 000000000000..daf5949172a6
--- /dev/null
+++ b/games/hllib/pkg-descr
@@ -0,0 +1,8 @@
+HLLib is a package library for Half-Life that abstracts several package
+formats and provides a simple interface for all of them. HLLib is written
+in native C++ but exposes both a C and C++ interfaces which can be used in
+any C or C++ application (additional languages may also use the library with
+standard C imports). HLLib works natively in both Windows and *nix. BSP,
+GCF, NCF, PAK, WAD, XZP, and uncompressed ZIP package formats are supported.
+
+WWW: http://nemesis.thewavelength.net/index.php?p=35