aboutsummaryrefslogtreecommitdiff
path: root/games/holotz-castle
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-21 22:46:49 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-21 22:46:49 +0000
commitf0fa52bb42565a03335f29ae7af47e16fc617dff (patch)
tree0c832b1bd98ca51fc383dfd98fb065cb97d06817 /games/holotz-castle
parent4eeb0f2ae6f2a391b63f809d183641cc4f93e2b2 (diff)
downloadports-f0fa52bb42565a03335f29ae7af47e16fc617dff.tar.gz
ports-f0fa52bb42565a03335f29ae7af47e16fc617dff.zip
- Change master sites
- Change maintainer email to @FreeBSD.org - USES gmake instead of USE_GMAKE - Support STAGEDIR and add OPTIONS_SUB Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=331204
Diffstat (limited to 'games/holotz-castle')
-rw-r--r--games/holotz-castle/Makefile41
-rw-r--r--games/holotz-castle/pkg-plist2
2 files changed, 20 insertions, 23 deletions
diff --git a/games/holotz-castle/Makefile b/games/holotz-castle/Makefile
index a78bbe96a3ff..99e88165ae9e 100644
--- a/games/holotz-castle/Makefile
+++ b/games/holotz-castle/Makefile
@@ -5,27 +5,25 @@ PORTNAME= holotz-castle
PORTVERSION= 1.3.14
PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= SF/nemysisfreebsdp/holotz-castle/
+MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Platform game with high doses of mystery
LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-MAKE_ARGS= HC_BASE=${PREFIX}/share/${PORTNAME}/ HC_BIN_DIR=${PREFIX}/bin/
+MAKE_ARGS= HC_BASE=${STAGEDIR}${PREFIX}/share/${PORTNAME}/ HC_BIN_DIR=${STAGEDIR}${PREFIX}/bin/
MAKE_JOBS_UNSAFE= yes
+USES= gmake
USE_GL= gl
USE_SDL= image mixer sdl ttf
-USE_GMAKE= yes
-
-MAN6= ${PORTNAME}.6 ${PORTNAME}-editor.6
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
@@ -35,42 +33,39 @@ SUB_FILES= pkg-message ${PORTNAME}-solutions
DESKTOP_ENTRIES="Holotz's Castle" "${COMMENT}" ${PORTNAME} \
"${PORTNAME}" "Game;LogicGame;" false
-DESKTOP_ENTRIES="Holotz's Castle Solutions" "${COMMENT}" ${PORTNAME} \
+DESKTOP_ENTRIES+="Holotz's Castle Solutions" "${COMMENT}" ${PORTNAME} \
"xterm -e ${PORTNAME}-solutions" "Game;LogicGame;" false
OPTIONS_DEFINE= SOLUTIONS
OPTIONS_DEFAULT=SOLUTIONS
SOLUTIONS_DESC= Solutions for Holotz's Castle
-NO_STAGE= yes
+OPTIONS_SUB= yes
+
+SOLUTIONS_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ xterm:${PORTSDIR}/x11/xterm
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSOLUTIONS}
DISTFILES+= ${PORTNAME}_solutions${EXTRACT_SUFX}
EXTRACT_ONLY+= ${PORTNAME}_solutions${EXTRACT_SUFX}
-RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
- xterm:${PORTSDIR}/x11/xterm
-PLIST_SUB+= SOLUTIONS=""
-.else
-PLIST_SUB+= SOLUTIONS="@comment "
.endif
post-install:
.for s in ${ICON_SIZES}
- ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
- ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
- (cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN6} ${MAN6PREFIX}/man/man6)
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+ (cd ${WRKSRC}/man && ${INSTALL_MAN} *.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/)
.if ${PORT_OPTIONS:MSOLUTIONS}
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-solutions ${PREFIX}/bin
- @${MKDIR} ${DATADIR}/solutions
- @(cd ${WRKDIR} ; ${INSTALL_DATA} *.avi ${DATADIR}/solutions)
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-solutions ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DATADIR}/solutions
+ @(cd ${WRKDIR} ; ${INSTALL_DATA} *.avi ${STAGEDIR}${DATADIR}/solutions)
.endif
.include <bsd.port.mk>
diff --git a/games/holotz-castle/pkg-plist b/games/holotz-castle/pkg-plist
index ae5312672fca..9bb3f6b377e8 100644
--- a/games/holotz-castle/pkg-plist
+++ b/games/holotz-castle/pkg-plist
@@ -1,5 +1,7 @@
bin/holotz-castle
bin/holotz-castle-editor
+man/man6/holotz-castle-editor.6.gz
+man/man6/holotz-castle.6.gz
%%SOLUTIONS%%bin/holotz-castle-solutions
%%DATADIR%%/editor/EnemyMenu/0.tga
%%DATADIR%%/editor/EnemyMenu/0_hi.tga