aboutsummaryrefslogtreecommitdiff
path: root/games/homura
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-12-22 19:54:23 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-12-22 19:54:23 +0000
commit3428ea2f56eacd0b458cecc8e21936f26116cb71 (patch)
treedfe47f64eb781a31fcbc8029df202a3fb8ce0a99 /games/homura
parent019ebca301c790783e99d69dd89a5bb8e4b288c3 (diff)
downloadports-3428ea2f56eacd0b458cecc8e21936f26116cb71.tar.gz
ports-3428ea2f56eacd0b458cecc8e21936f26116cb71.zip
New port: games/homura: Windows Games Launcher for FreeBSD
Inspired by Lutris. Homura is a launcher that makes it easy to run windows games/launcher just with one click on FreeBSD. The Windows emulation is provided by Wine WWW: https://github.com/The-Homura-Project/Homura PR: 241042 Submitted by: Alexander Vereeken <Alexander88207@protonmail.com>
Notes
Notes: svn path=/head/; revision=520657
Diffstat (limited to 'games/homura')
-rw-r--r--games/homura/Makefile46
-rw-r--r--games/homura/distinfo3
-rw-r--r--games/homura/pkg-descr6
-rw-r--r--games/homura/pkg-message5
4 files changed, 60 insertions, 0 deletions
diff --git a/games/homura/Makefile b/games/homura/Makefile
new file mode 100644
index 000000000000..ee5c50d7f3fd
--- /dev/null
+++ b/games/homura/Makefile
@@ -0,0 +1,46 @@
+# Created by: Alexander Vereeken <Alexander88207@protonmail.com>
+# $FreeBSD$
+
+PORTNAME= homura
+PORTVERSION= 3.2
+CATEGORIES= games
+
+MAINTAINER= Alexander88207@protonmail.com
+COMMENT= Windows Games Launcher for FreeBSD
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= Wine only runs on x86 architecture
+
+RUN_DEPENDS= zenity:x11/zenity \
+ xdg-open:devel/xdg-utils \
+ curl:ftp/curl \
+ bash:shells/bash \
+ 7z:archivers/p7zip \
+ webfonts>=0:x11-fonts/webfonts \
+ winetricks:emulators/winetricks \
+ vulkaninfo:devel/vulkan-tools \
+ glxinfo:graphics/mesa-demos \
+ noto>=0:x11-fonts/noto
+
+USE_GITHUB= yes
+GH_ACCOUNT= the-homura-project
+
+NO_BUILD= yes
+
+PLIST_FILES= ${LOCALBASE}/bin/Homura
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+RUN_DEPENDS+= wine:emulators/wine-devel
+.else
+RUN_DEPENDS+= wine:emulators/i386-wine-devel
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/Homura ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/games/homura/distinfo b/games/homura/distinfo
new file mode 100644
index 000000000000..04c91e873b17
--- /dev/null
+++ b/games/homura/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1576336710
+SHA256 (the-homura-project-homura-3.2_GH0.tar.gz) = c7b215cc05c2da869e375a1071d142150206bb612dd9629bc3629a94533ba26d
+SIZE (the-homura-project-homura-3.2_GH0.tar.gz) = 3057772
diff --git a/games/homura/pkg-descr b/games/homura/pkg-descr
new file mode 100644
index 000000000000..517660c2f078
--- /dev/null
+++ b/games/homura/pkg-descr
@@ -0,0 +1,6 @@
+Homura is a launcher that makes it easy to run windows games/launcher easily on
+FreeBSD by providing the required fixes and workarounds.
+
+The Windows emulation is provided by Wine.
+
+WWW: https://github.com/the-homura-project/homura
diff --git a/games/homura/pkg-message b/games/homura/pkg-message
new file mode 100644
index 000000000000..7b475c3edfc7
--- /dev/null
+++ b/games/homura/pkg-message
@@ -0,0 +1,5 @@
+[
+{
+ message: "If you use Homura for the first time, then you need open it via the commandline first."
+}
+]