aboutsummaryrefslogtreecommitdiff
path: root/games/imaze
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-30 02:35:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-30 02:35:30 +0000
commit6d03337886617776f5e3d2cd84afd2cc55bccfc2 (patch)
treeda54d915672c0f89331378aea4d272d0e97a1aa6 /games/imaze
parentf58354d8a2f437a00213d8c99e071aa47f75fa15 (diff)
downloadports-6d03337886617776f5e3d2cd84afd2cc55bccfc2.tar.gz
ports-6d03337886617776f5e3d2cd84afd2cc55bccfc2.zip
Notes
Diffstat (limited to 'games/imaze')
-rw-r--r--games/imaze/Makefile98
1 files changed, 51 insertions, 47 deletions
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index ac3ae46398fc..6c4f99694612 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -1,72 +1,76 @@
-# New ports collection makefile for: imaze
-# Date created: 27. April 1996
-# Whom: Ronald Kuehn <rk@ronald.org>
-#
+# Created by: Ronald Kuehn <rk@ronald.org>
# $FreeBSD$
-#
PORTNAME= imaze
PORTVERSION= 1.4
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= http://home.tu-clausthal.de/student/iMaze/files/
+MASTER_SITES= TUCOWS/x11/entertain/ \
+ http://www.sourcefiles.org/Games/Arcade/
PKGNAMESUFFIX= -${TOOLKIT}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A multi-player network action game for TCP/IP with 3D graphics
+COMMENT= Multi-player network action game for TCP/IP with 3D graphics
-.if defined(WITH_MOTIF) && defined(HAVE_MOTIF)
-USE_MOTIF= yes
-TOOLKIT= motif
-.elif defined(WITH_ATHENA)
-TOOLKIT= athena
-USE_XORG+= xaw
-.else
-LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
-TOOLKIT= xview
-USE_XORG+= xaw
-.endif
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/Copyright
+
+OPTIONS_DEFINE= AUDIO JOYSTICK
+OPTIONS_RADIO= GUI
+OPTIONS_RADIO_GUI= XVIEW MOTIF
+OPTIONS_DEFAULT= AUDIO JOYSTICK XVIEW
+AUDIO_DESC= Audio support
+JOYSTICK_DESC= Joystick support
+XVIEW_DESC= XView widget library support
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= ${TOOLKIT} X11Dir=${LOCALBASE} CFlags="${CFLAGS}"
CONFIGURE_WRKSRC=${WRKSRC}/source
BUILD_WRKSRC= ${WRKSRC}/source
-MAKE_ENV= SOUNDDIR=${SOUNDDIR}
+
+USE_XORG= x11 xaw xt
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= ${TOOLKIT} X11Dir="${LOCALBASE}" CFlags="${CFLAGS}"
+MAKE_ENV= SOUNDDIR="${DATADIR}/sounds"
+MAKE_JOBS_SAFE= yes
+
MAN6= genlab.6 imaze.6 imazesrv.6 imazestat.6 ninja.6 xlabed.6
-MANCOMPRESSED= no
-USE_XORG+= x11 xt
-.if defined(WITHOUT_AUDIO)
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MAUDIO)
CONFIGURE_ARGS+=noaudio
.endif
-.if defined(WITHOUT_JOYSTICK)
+
+.if empty(PORT_OPTIONS:MJOYSTICK)
CONFIGURE_ARGS+=nojoystick
.endif
-PROGRAMS= imaze imazesrv imazestat ninja genlab xlabed
-SOUNDDIR= ${PREFIX}/share/imaze/sounds
+.if empty(PORT_OPTIONS:MMOTIF) && empty(PORT_OPTIONS:MXVIEW)
+TOOLKIT= athena
+.endif
+
+.if ${PORT_OPTIONS:MMOTIF}
+USE_MOTIF= yes
+TOOLKIT= motif
+.endif
-pre-everything::
- @$(ECHO_MSG) "iMaze can be built with XView (default), Motif or" \
- "Athena widgets."
- @$(ECHO_MSG) "Use \"-DWITH_MOTIF\" or \"-DWITH_ATHENA\" to select" \
- "Motif or Athena widgets."
- @$(ECHO_MSG) "Audio and joystick support can be disabled with" \
- "\"-DWITHOUT_AUDIO\""
- @$(ECHO_MSG) "and/or \"-DWITHOUT_JOYSTICK\""
+.if ${PORT_OPTIONS:MXVIEW}
+LIB_DEPENDS+= xview:${PORTSDIR}/x11-toolkits/xview
+TOOLKIT= xview
+.endif
do-install:
- @(cd ${WRKSRC}/source && for f in ${PROGRAMS}; do \
- ${INSTALL_PROGRAM} $$f ${PREFIX}/bin; done)
- @(cd ${WRKSRC}/man6 && for f in *.6; do \
- ${INSTALL_MAN} $$f ${PREFIX}/man/man6; done)
- @${MKDIR} ${PREFIX}/share/imaze/labs
- @(cd ${WRKSRC}/labs && for f in *.lab; do \
- ${INSTALL_DATA} $$f ${PREFIX}/share/imaze/labs; done)
- @${MKDIR} ${SOUNDDIR}
- @(cd ${WRKSRC}/sounds && for f in *.au; do \
- ${INSTALL_DATA} $$f ${SOUNDDIR}; done)
- @(cd ${WRKSRC} && ${INSTALL_DATA} README ${PREFIX}/share/imaze)
- @$(ECHO_MSG) "Please read the file \"${PREFIX}/share/imaze/README\"."
+.for i in genlab imaze imazesrv imazestat ninja xlabed
+ (cd ${WRKSRC}/source && ${INSTALL_PROGRAM} ${i} ${PREFIX}/bin)
+.endfor
+.for i in ${MAN6}
+ (cd ${WRKSRC}/man6 && ${INSTALL_MAN} ${i} ${MAN6PREFIX}/man/man6)
+.endfor
+ @${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README ${DATADIR})
+ @${MKDIR} ${DATADIR}/labs
+ (cd ${WRKSRC}/labs && ${INSTALL_DATA} *.lab ${DATADIR}/labs)
+ @${MKDIR} ${DATADIR}/sounds
+ (cd ${WRKSRC}/sounds && ${INSTALL_DATA} *.au ${DATADIR}/sounds)
+ @${ECHO_MSG} "Please read the file \"${DATADIR}/README\"."
.include <bsd.port.mk>