aboutsummaryrefslogtreecommitdiff
path: root/games/instead
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-25 14:55:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-25 14:55:33 +0000
commit13ccc1cadf1d78c518964cffdee9d3f229c0eb72 (patch)
tree98a56a1265de7ad59e628e9613e4bf5b507f47c1 /games/instead
parent30f4742849d6418686f8d0c8de219e1c9fba933a (diff)
downloadports-13ccc1cadf1d78c518964cffdee9d3f229c0eb72.tar.gz
ports-13ccc1cadf1d78c518964cffdee9d3f229c0eb72.zip
- Fix broken upstream staging support
Notes
Notes: svn path=/head/; revision=337420
Diffstat (limited to 'games/instead')
-rw-r--r--games/instead/Makefile2
-rw-r--r--games/instead/files/patch-desktop-Makefile11
-rw-r--r--games/instead/files/patch-src-instead-Makefile11
-rw-r--r--games/instead/files/patch-src-sdl-instead-Makefile11
4 files changed, 34 insertions, 1 deletions
diff --git a/games/instead/Makefile b/games/instead/Makefile
index fb5367011e1c..7490bfcbe7d7 100644
--- a/games/instead/Makefile
+++ b/games/instead/Makefile
@@ -3,7 +3,7 @@
PORTNAME= instead
PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/instead/instead/${PORTVERSION}/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/instead/files/patch-desktop-Makefile b/games/instead/files/patch-desktop-Makefile
new file mode 100644
index 000000000000..293b2547a10e
--- /dev/null
+++ b/games/instead/files/patch-desktop-Makefile
@@ -0,0 +1,11 @@
+--- desktop/Makefile.orig 2013-06-23 15:26:58.000000000 +0400
++++ desktop/Makefile 2013-12-25 18:47:41.313221986 +0400
+@@ -7,7 +7,7 @@
+ all: instead.desktop
+
+ instead.desktop: instead.desktop.in
+- cat instead.desktop.in | sed -e "s|@BIN|$(BIN)|g" > instead.desktop
++ cat instead.desktop.in | sed -e "s|@BIN|$(BIN:${DESTDIR}%=%)|g" > instead.desktop
+
+ install:
+ $(INSTALLD) $(DESTDIR)$(PREFIX)/share/applications
diff --git a/games/instead/files/patch-src-instead-Makefile b/games/instead/files/patch-src-instead-Makefile
new file mode 100644
index 000000000000..e86fa0fa9fd6
--- /dev/null
+++ b/games/instead/files/patch-src-instead-Makefile
@@ -0,0 +1,11 @@
+--- src/instead/Makefile.orig 2013-06-23 15:26:48.000000000 +0400
++++ src/instead/Makefile 2013-12-25 18:45:45.639220432 +0400
+@@ -4,7 +4,7 @@
+
+ all: instead
+ instead: instead.c rline.c
+- $(CC) $(CFLAGS) -DSTEAD_PATH=\"${STEADPATH}/\" instead.c $(LUA_CFLAGS) rline.c $(LUA_LFLAGS) -lncurses -lreadline -o instead
++ $(CC) $(CFLAGS) -DSTEAD_PATH=\"${STEADPATH:${DESTDIR}%=%}/\" instead.c $(LUA_CFLAGS) rline.c $(LUA_LFLAGS) -lncurses -lreadline -o instead
+ clean:
+ $(RM) -rf *.o instead
+ install:
diff --git a/games/instead/files/patch-src-sdl-instead-Makefile b/games/instead/files/patch-src-sdl-instead-Makefile
new file mode 100644
index 000000000000..8d208f40872c
--- /dev/null
+++ b/games/instead/files/patch-src-sdl-instead-Makefile
@@ -0,0 +1,11 @@
+--- src/sdl-instead/Makefile.orig 2013-06-23 15:26:49.000000000 +0400
++++ src/sdl-instead/Makefile 2013-12-25 18:46:16.823227850 +0400
+@@ -1,7 +1,7 @@
+ include ../../Rules.make
+ include ../../config.make
+
+-CFLAGS += $(SDL_CFLAGS) $(LUA_CFLAGS) $(ZLIB_CFLAGS) $(EXTRA_CFLAGS) -DLANG_PATH=\"${LANGPATH}/\" -DSTEAD_PATH=\"${STEADPATH}/\" -DGAMES_PATH=\"${GAMESPATH}/\" -DTHEMES_PATH=\"${THEMESPATH}/\" -DVERSION=\"$(VERSION)\" -DICON_PATH=\"${ICONPATH}/\"
++CFLAGS += $(SDL_CFLAGS) $(LUA_CFLAGS) $(ZLIB_CFLAGS) $(EXTRA_CFLAGS) -DLANG_PATH=\"${LANGPATH:${DESTDIR}%=%}/\" -DSTEAD_PATH=\"${STEADPATH:${DESTDIR}%=%}/\" -DGAMES_PATH=\"${GAMESPATH:${DESTDIR}%=%}/\" -DTHEMES_PATH=\"${THEMESPATH:${DESTDIR}%=%}/\" -DVERSION=\"$(VERSION)\" -DICON_PATH=\"${ICONPATH:${DESTDIR}%=%}/\"
+
+ LDFLAGS += $(SDL_LFLAGS) $(LUA_LFLAGS) $(ZLIB_LFLAGS) $(EXTRA_LDFLAGS)
+