aboutsummaryrefslogtreecommitdiff
path: root/games/ioquake3
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-18 20:21:53 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-18 20:21:53 +0000
commit3b64ffeba3280ff8a220ae36696876ccc297897f (patch)
tree99e266cd9b7aaf695b1ed438bbf7caf5462291da /games/ioquake3
parentc4ff8f3272e7e12d4eba66ed97680e48dfaf3f5a (diff)
downloadports-3b64ffeba3280ff8a220ae36696876ccc297897f.tar.gz
ports-3b64ffeba3280ff8a220ae36696876ccc297897f.zip
- split out -server part from ioquake3-based ports:
- games/ioquake3-devel-server added - games/ioquake3-server added - games/iourbanterror-server - games/openarena-server added - update games/ioquake3-devel to svn revision 2244 - update games/openarena to 0.8.8 - update games/openarena-data to 0.8.8 Doing this in single commit since all this ports are tightly interconnected. PR: ports/165842 Submitted by: Dominic Fandrey <kamikaze at bsdforen dot de> (maintainer)
Notes
Notes: svn path=/head/; revision=296922
Diffstat (limited to 'games/ioquake3')
-rw-r--r--games/ioquake3/Makefile63
-rw-r--r--games/ioquake3/files/patch-code-client-cl_curl.h12
-rw-r--r--games/ioquake3/pkg-descr2
-rw-r--r--games/ioquake3/pkg-plist8
4 files changed, 52 insertions, 33 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 2b3720d7eadc..68fe89d4111d 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ioquake3
DISTVERSION?= 1.36
-PORTREVISION?= 9
+PORTREVISION?= 10
CATEGORIES= games
MASTER_SITES?= http://ioquake3.org/files/${DISTVERSION}/
# Using zip this way enables slaves to override it.
@@ -20,25 +20,46 @@ BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
USE_GMAKE= yes
-OPTIONS+= CLIENT "Build client" on \
- DEDICATED "Build dedicated server" on \
+.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX:M*-server}
+# Server config
+WITH_DEDICATED= yes
+WITHOUT_CLIENT= yes
+WITHOUT_SERVER= yes
+WITHOUT_CURL= yes
+WITHOUT_OPENAL= yes
+WITHOUT_MUMBLE= yes
+WITHOUT_VORBIS= yes
+WITHOUT_TOOLS= yes
+WITHOUT_DLRENDERER= yes
+.else
+# Client config
+WITH_CLIENT= yes
+WITHOUT_DEDICATED= yes
+OPTIONS+= SERVER "Install dedicated server" on \
CURL "Enable cURL for http/ftp download" on \
OPENAL "Enable OpenAL audio output" on \
MUMBLE "Enable Mumble support (no dependencies)" on \
VORBIS "Enable Ogg Vorbis support" on
-.if !defined(NO_GAMELIBS)
-OPTIONS+= GAMELIBS "Build game libraries" off
-.endif
-.if defined(HAS_DLRENDERER)
+. if defined(NO_TOOLS)
+WITHOUT_TOOLS= yes
+. else
+OPTIONS+= TOOLS "Enable modding tools" on
+. endif
+. if defined(HAS_DLRENDERER)
OPTIONS+= DLRENDERER "Build dynamically loaded renderer" on
-.else
+. else
WITHOUT_DLRENDERER= yes
+. endif
+.endif
+# Common config
+.if !defined(NO_GAMELIBS)
+OPTIONS+= GAMELIBS "Build game libraries" off
.endif
MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
DEFAULT_LIBDIR="${LIBDIR}" \
HOMEPATH="${HOMEPATH}" \
- VERSION="${DISTVERSION}" \
+ VERSION="${Q3ENGINEVER}" \
ARCH="${ARCH}" \
USE_LOCAL_HEADERS=0
PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
@@ -47,7 +68,8 @@ PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
ALL_TARGET= release
MAKE_JOBS_SAFE= yes
-LIBDIR= ${PREFIX}/lib/${PORTNAME}
+LIBDIR= ${PREFIX}/lib/${PORTNAME}${PKGNAMESUFFIX}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
BUILDDIR= ${WRKSRC}/build/${ALL_TARGET}-${OPSYS:L}-${ARCH}
BINSUFFIX?=
HOMEPATH?= /.${PORTNAME}
@@ -62,13 +84,10 @@ Q3BASE?= baseq3 \
Q3ICON?= ${PREFIX}/share/pixmaps/quake3.xpm
Q3RENDERER?= renderer_opengl1_${ARCH}
Q3INSTALL?=
+Q3ENGINEVER?= ${DISTVERSION}
ONLY_FOR_ARCHS= amd64 i386
-# Make sure TARGET and CFLAGS fit together for cross-compiling.
-MACHINE_ARCH= ${ARCH}
-.include <bsd.cpu.mk>
-
.include <bsd.port.options.mk>
.if defined(NO_GAMELIBS) && defined(WITH_GAMELIBS)
@@ -82,14 +101,18 @@ IGNORE= does not support WITH_DLRENDERER
ALL_TARGET= debug
.endif
+.if !defined(WITHOUT_SERVER)
+RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:${PORTSDIR}/games/${PORTNAME}-server
+.endif
+
.if !defined(DESKTOP_ENTRIES)
. if !defined(WITHOUT_CLIENT)
-DESKTOP_ENTRIES+= "${Q3CLIENT} ${DISTVERSION}" "${COMMENT}" \
+DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER}" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}${BINSUFFIX}" "Application;Game;" false
. endif
. if defined(WITH_SMP)
-DESKTOP_ENTRIES+= "${Q3CLIENT} ${DISTVERSION} SMP" "${COMMENT}" \
+DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER} SMP" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}-smp${BINSUFFIX}" "Application;Game;" false
. endif
@@ -179,15 +202,23 @@ MAKE_ARGS+= USE_RENDERER_DLOPEN=0
PLIST_SUB+= DLRENDERER="@comment "
.endif
+.if !defined(WITHOUT_TOOLS)
+PLIST_SUB+= TOOLS=""
+.else
+PLIST_SUB+= TOOLS="@comment "
+.endif
+
do-install: ${Q3INSTALL}
.for bin in ${Q3BIN}
${INSTALL_PROGRAM} ${BUILDDIR}/${bin}.${ARCH} \
${PREFIX}/bin/${bin}${BINSUFFIX}
.endfor
+.if !defined(WITHOUT_TOOLS)
.for bin in ${Q3TOOLS}
${INSTALL_PROGRAM} ${BUILDDIR}/tools/${bin} \
${PREFIX}/bin/${bin}${BINSUFFIX}
.endfor
+.endif
.if !defined(WITHOUT_DLRENDERER)
.for renderer in ${Q3RENDERER}
${MKDIR} ${LIBDIR}
diff --git a/games/ioquake3/files/patch-code-client-cl_curl.h b/games/ioquake3/files/patch-code-client-cl_curl.h
deleted file mode 100644
index ca97eb61347d..000000000000
--- a/games/ioquake3/files/patch-code-client-cl_curl.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- code/client/cl_curl.h.orig 2011-11-03 10:16:32.000000000 +0100
-+++ code/client/cl_curl.h 2011-11-03 10:16:56.000000000 +0100
-@@ -34,8 +34,7 @@
- #elif defined(MACOS_X)
- #define DEFAULT_CURL_LIB "libcurl.dylib"
- #else
--#define DEFAULT_CURL_LIB "libcurl.so.4"
--#define ALTERNATE_CURL_LIB "libcurl.so.3"
-+#define DEFAULT_CURL_LIB "libcurl.so"
- #endif
-
- #ifdef USE_LOCAL_HEADERS
diff --git a/games/ioquake3/pkg-descr b/games/ioquake3/pkg-descr
index d49d4c07954b..f6cbe35744e7 100644
--- a/games/ioquake3/pkg-descr
+++ b/games/ioquake3/pkg-descr
@@ -8,4 +8,4 @@ playing Quake 3: Arena, Team Arena, and all popular mods. This distribution of
the engine has been ported to many new platforms and has had a slew of new
features added, along with massive bug extermination.
-WWW: http://ioquake3.org/
+WWW: http://ioquake3.org/
diff --git a/games/ioquake3/pkg-plist b/games/ioquake3/pkg-plist
index 28ba1453d551..8be318c64485 100644
--- a/games/ioquake3/pkg-plist
+++ b/games/ioquake3/pkg-plist
@@ -1,10 +1,10 @@
%%DEDICATED%%bin/ioq3ded%%BINSUFFIX%%
%%CLIENT%%bin/ioquake3%%BINSUFFIX%%
%%SMP%%bin/ioquake3-smp%%BINSUFFIX%%
-bin/q3asm%%BINSUFFIX%%
-bin/q3cpp%%BINSUFFIX%%
-bin/q3lcc%%BINSUFFIX%%
-bin/q3rcc%%BINSUFFIX%%
+%%TOOLS%%bin/q3asm%%BINSUFFIX%%
+%%TOOLS%%bin/q3cpp%%BINSUFFIX%%
+%%TOOLS%%bin/q3lcc%%BINSUFFIX%%
+%%TOOLS%%bin/q3rcc%%BINSUFFIX%%
%%DLRENDERER%%%%LIBDIR%%/renderer_opengl1_%%ARCH%%.so
%%GAMELIBS%%%%LIBDIR%%/baseq3/cgame%%ARCH%%.so
%%GAMELIBS%%%%LIBDIR%%/baseq3/qagame%%ARCH%%.so