aboutsummaryrefslogtreecommitdiff
path: root/games/ioquake3
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /games/ioquake3
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
downloadports-4e1b79a0a61f4973df8b4b0864d22086c769e219.tar.gz
ports-4e1b79a0a61f4973df8b4b0864d22086c769e219.zip
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412346
Diffstat (limited to 'games/ioquake3')
-rw-r--r--games/ioquake3/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 3de55ae78eae..a55052caf92a 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -98,7 +98,7 @@ ALL_TARGET= debug
.endif
.if ${PORT_OPTIONS:MSERVER}
-RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:${PORTSDIR}/games/${PORTNAME}-server
+RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:games/${PORTNAME}-server
.endif
.if !defined(DESKTOP_ENTRIES)
@@ -130,7 +130,7 @@ MAKE_ARGS+= BUILD_SERVER=0
.endif
.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:ftp/curl
MAKE_ARGS+= USE_CURL=1 USE_CURL_DLOPEN=0
.else
MAKE_ARGS+= USE_CURL=0
@@ -145,7 +145,7 @@ MAKE_ARGS+= USE_OPENAL=0
.if ${PORT_OPTIONS:MVORBIS}
NEED_OGG= yes
-LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:audio/libvorbis
MAKE_ARGS+= USE_CODEC_VORBIS=1
.else
MAKE_ARGS+= USE_CODEC_VORBIS=0
@@ -153,15 +153,15 @@ MAKE_ARGS+= USE_CODEC_VORBIS=0
.if ${PORT_OPTIONS:MOPUS}
NEED_OGG= yes
-LIB_DEPENDS+= libopusfile.so:${PORTSDIR}/audio/opusfile \
- libopus.so:${PORTSDIR}/audio/opus
+LIB_DEPENDS+= libopusfile.so:audio/opusfile \
+ libopus.so:audio/opus
MAKE_ARGS+= USE_CODEC_OPUS=1 USE_INTERNAL_OPUS=0
.else
MAKE_ARGS+= USE_CODEC_OPUS=0
.endif
.if defined(NEED_OGG)
-LIB_DEPENDS+= libogg.so:${PORTSDIR}/audio/libogg
+LIB_DEPENDS+= libogg.so:audio/libogg
MAKE_ARGS+= USE_INTERNAL_OGG=0
.endif