aboutsummaryrefslogtreecommitdiff
path: root/games/ioquake3
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-15 01:47:49 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-15 01:47:49 +0000
commit6becb5e688d9bda372c9595148270270ee2257cf (patch)
tree4762fd179682a7c9624d69093a9a032a42083a6d /games/ioquake3
parent44b22afe1167644c44272a18525e15955d955c99 (diff)
downloadports-6becb5e688d9bda372c9595148270270ee2257cf.tar.gz
ports-6becb5e688d9bda372c9595148270270ee2257cf.zip
games/ioquake3: fix build on powerpc64le
Notes
Notes: svn path=/head/; revision=565282
Diffstat (limited to 'games/ioquake3')
-rw-r--r--games/ioquake3/Makefile2
-rw-r--r--games/ioquake3/files/patch-Makefile20
2 files changed, 19 insertions, 3 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 6402ecd1b7d3..c48b4419824b 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -87,7 +87,7 @@ Q3INSTALL?=
Q3ENGINEVER?= ${DISTVERSION}
IOQUAKE3VER= 1.36
-ONLY_FOR_ARCHS= amd64 i386 powerpc64
+ONLY_FOR_ARCHS= amd64 i386 powerpc64 powerpc64le
DEBUG_VARS= ALL_TARGET=debug
SERVER_RUN_DEPENDS= ${Q3SERVER}${BINSUFFIX}:games/${PORTNAME}-server
diff --git a/games/ioquake3/files/patch-Makefile b/games/ioquake3/files/patch-Makefile
index c4d5e74ad3c1..021c800c5e3f 100644
--- a/games/ioquake3/files/patch-Makefile
+++ b/games/ioquake3/files/patch-Makefile
@@ -151,7 +151,7 @@
else
CLIENT_LIBS += -lspeex
endif
-@@ -1442,6 +1457,9 @@ ifeq ($(HAVE_VM_COMPILED),true)
+@@ -1442,12 +1461,18 @@
ifeq ($(ARCH),x86_64)
Q3OBJ += $(B)/client/vm_x86_64.o $(B)/client/vm_x86_64_assembler.o
endif
@@ -161,7 +161,16 @@
ifeq ($(ARCH),ppc)
Q3OBJ += $(B)/client/vm_powerpc.o $(B)/client/vm_powerpc_asm.o
endif
-@@ -1591,6 +1609,9 @@ ifeq ($(HAVE_VM_COMPILED),true)
+ ifeq ($(ARCH),ppc64)
+ Q3OBJ += $(B)/client/vm_powerpc.o $(B)/client/vm_powerpc_asm.o
+ endif
++ ifeq ($(ARCH),ppc64le)
++ Q3OBJ += $(B)/client/vm_powerpc.o $(B)/client/vm_powerpc_asm.o
++ endif
+ ifeq ($(ARCH),sparc)
+ Q3OBJ += $(B)/client/vm_sparc.o
+ endif
+@@ -1591,10 +1616,16 @@
ifeq ($(ARCH),x86_64)
Q3DOBJ += $(B)/ded/vm_x86_64.o $(B)/ded/vm_x86_64_assembler.o
endif
@@ -171,3 +180,10 @@
ifeq ($(ARCH),ppc)
Q3DOBJ += $(B)/ded/vm_powerpc.o $(B)/ded/vm_powerpc_asm.o
endif
+ ifeq ($(ARCH),ppc64)
+ Q3DOBJ += $(B)/ded/vm_powerpc.o $(B)/ded/vm_powerpc_asm.o
+ endif
++ ifeq ($(ARCH),ppc64le)
++ Q3DOBJ += $(B)/ded/vm_powerpc.o $(B)/ded/vm_powerpc_asm.o
++ endif
+ ifeq ($(ARCH),sparc)