aboutsummaryrefslogtreecommitdiff
path: root/games/iortcw
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-04-09 09:33:46 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-04-09 09:33:46 +0000
commit352a4e2152034d660eab3e8bd4a76a3a0d2e1c53 (patch)
tree34667d0892a23ca26efc0a28b75cf22cca4e3280 /games/iortcw
parent0479e16b611e61bbfd456c2caa25331df2f8c95c (diff)
downloadports-352a4e2152034d660eab3e8bd4a76a3a0d2e1c53.tar.gz
ports-352a4e2152034d660eab3e8bd4a76a3a0d2e1c53.zip
games/iortcw: Fix build on powerpc64
powerpc64 needs ARCH_STRING properly defined. PR: 237149 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=498470
Diffstat (limited to 'games/iortcw')
-rw-r--r--games/iortcw/Makefile2
-rw-r--r--games/iortcw/files/patch-MP_code_qcommon_q__platform.h11
-rw-r--r--games/iortcw/files/patch-SP_code_qcommon_q__platform.h11
3 files changed, 17 insertions, 7 deletions
diff --git a/games/iortcw/Makefile b/games/iortcw/Makefile
index 61930e58783b..ef8c25ae61af 100644
--- a/games/iortcw/Makefile
+++ b/games/iortcw/Makefile
@@ -11,7 +11,7 @@ COMMENT= Game engine for Return to Castle Wolfenstein
LICENSE= GPLv3
-NOT_FOR_ARCHS= aarch64 armv6 armv7 powerpc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= fails to configure: Architecture not supported
LIB_DEPENDS= libcurl.so:ftp/curl \
diff --git a/games/iortcw/files/patch-MP_code_qcommon_q__platform.h b/games/iortcw/files/patch-MP_code_qcommon_q__platform.h
index df8ffe75c7f0..bb3687ed95d4 100644
--- a/games/iortcw/files/patch-MP_code_qcommon_q__platform.h
+++ b/games/iortcw/files/patch-MP_code_qcommon_q__platform.h
@@ -1,6 +1,6 @@
---- MP/code/qcommon/q_platform.h.orig 2016-07-29 22:00:04 UTC
+--- MP/code/qcommon/q_platform.h.orig 2019-03-16 18:09:48 UTC
+++ MP/code/qcommon/q_platform.h
-@@ -35,11 +35,7 @@ Foundation, Inc., 51 Franklin St, Fifth
+@@ -35,11 +35,7 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#else
@@ -12,7 +12,7 @@
#if (defined(powerc) || defined(powerpc) || defined(ppc) || \
defined(__ppc) || defined(__ppc__)) && !defined(C_ONLY)
-@@ -229,8 +225,6 @@ Foundation, Inc., 51 Franklin St, Fifth
+@@ -224,11 +220,11 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#ifdef __i386__
#define ARCH_STRING "i386"
#elif defined __amd64__
@@ -21,3 +21,8 @@
#define ARCH_STRING "amd64"
#elif defined __axp__
#define ARCH_STRING "alpha"
++#elif defined __powerpc64__
++#define ARCH_STRING "powerpc64"
+ #endif
+
+ #if BYTE_ORDER == BIG_ENDIAN
diff --git a/games/iortcw/files/patch-SP_code_qcommon_q__platform.h b/games/iortcw/files/patch-SP_code_qcommon_q__platform.h
index e103bf7c91ef..5d53ad0dd042 100644
--- a/games/iortcw/files/patch-SP_code_qcommon_q__platform.h
+++ b/games/iortcw/files/patch-SP_code_qcommon_q__platform.h
@@ -1,6 +1,6 @@
---- SP/code/qcommon/q_platform.h.orig 2015-12-26 14:21:49 UTC
+--- SP/code/qcommon/q_platform.h.orig 2019-03-16 18:09:48 UTC
+++ SP/code/qcommon/q_platform.h
-@@ -35,11 +35,7 @@ Foundation, Inc., 51 Franklin St, Fifth
+@@ -35,11 +35,7 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#else
@@ -12,7 +12,7 @@
#if (defined(powerc) || defined(powerpc) || defined(ppc) || \
defined(__ppc) || defined(__ppc__)) && !defined(C_ONLY)
-@@ -229,8 +225,6 @@ Foundation, Inc., 51 Franklin St, Fifth
+@@ -224,11 +220,11 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#ifdef __i386__
#define ARCH_STRING "i386"
#elif defined __amd64__
@@ -21,3 +21,8 @@
#define ARCH_STRING "amd64"
#elif defined __axp__
#define ARCH_STRING "alpha"
++#elif defined __powerpc64__
++#define ARCH_STRING "powerpc64"
+ #endif
+
+ #if BYTE_ORDER == BIG_ENDIAN