aboutsummaryrefslogtreecommitdiff
path: root/games/irrlamb
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-21 00:43:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-21 00:43:38 +0000
commit2d7392d2d73d725ccfee8fe76020b79b0c6d53ff (patch)
tree4c4389b3687eaed2a78721054374dc564c576009 /games/irrlamb
parent17fae564aa4e98e9c11535227d5f3fd8cc9c1c5a (diff)
downloadports-2d7392d2d73d725ccfee8fe76020b79b0c6d53ff.tar.gz
ports-2d7392d2d73d725ccfee8fe76020b79b0c6d53ff.zip
- Support staging
- Fix build on 10.x
Notes
Notes: svn path=/head/; revision=337111
Diffstat (limited to 'games/irrlamb')
-rw-r--r--games/irrlamb/Makefile22
-rw-r--r--games/irrlamb/files/patch-src-objects-orb.cpp20
-rw-r--r--games/irrlamb/files/patch-src-objects-player.cpp20
3 files changed, 48 insertions, 14 deletions
diff --git a/games/irrlamb/Makefile b/games/irrlamb/Makefile
index d668071e5d4d..4e8e7128fc32 100644
--- a/games/irrlamb/Makefile
+++ b/games/irrlamb/Makefile
@@ -17,21 +17,20 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libIrrlicht.so:${PORTSDIR}/x11-toolkits/irrlicht
USE_LUA= 5.1+
USE_SCONS= yes
-USE_DOS2UNIX= src/engine/save.h
+USES= scons dos2unix
+DOS2UNIX_FILES= src/engine/save.h src/objects/orb.cpp src/objects/player.cpp
CPPPATH= ${LOCALBASE}/include ${LUA_INCDIR}
LIBPATH= ${LOCALBASE}/lib ${LUA_LIBDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}
-PORTDOCS= readme.txt changelog.txt
-PORTDATA= *
-
PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= *
+PORTDATA= *
DATA_DIRS= art campaigns collision fonts levels meshes scenes scripts textures
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -44,14 +43,9 @@ post-patch:
@${FIND} ${WRKSRC} -name "*.bak" -delete
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/irrlamb ${PREFIX}/bin
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATA_DIRS}" ${DATADIR}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/irrlamb ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATA_DIRS}" ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} readme.txt changelog.txt ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/irrlamb/files/patch-src-objects-orb.cpp b/games/irrlamb/files/patch-src-objects-orb.cpp
new file mode 100644
index 000000000000..5c1210679e88
--- /dev/null
+++ b/games/irrlamb/files/patch-src-objects-orb.cpp
@@ -0,0 +1,20 @@
+--- src/objects/orb.cpp.orig 2013-12-19 22:19:20.406056087 +0400
++++ src/objects/orb.cpp 2013-12-19 22:19:55.234053221 +0400
+@@ -40,7 +40,7 @@
+ else
+ Node->setMaterialTexture(0, irrDriver->getTexture("/home/amdmi3/projects/freebsd/ports/games/irrlamb/prefix/share/irrlamb/textures/orb_outer0.png"));
+ Node->setMaterialType(EMT_ONETEXTURE_BLEND);
+- Node->getMaterial(0).MaterialTypeParam = pack_texureBlendFunc(EBF_ONE, EBF_ONE);
++ Node->getMaterial(0).MaterialTypeParam = pack_textureBlendFunc(EBF_ONE, EBF_ONE);
+
+ // Create glow
+ //GlowColor = SColor(255, 255, 240, 130);
+@@ -50,7 +50,7 @@
+ InnerNode->setMaterialFlag(EMF_LIGHTING, false);
+ InnerNode->setMaterialFlag(EMF_ZBUFFER, false);
+ InnerNode->setMaterialType(EMT_ONETEXTURE_BLEND);
+- InnerNode->getMaterial(0).MaterialTypeParam = pack_texureBlendFunc(EBF_ONE, EBF_ONE);
++ InnerNode->getMaterial(0).MaterialTypeParam = pack_textureBlendFunc(EBF_ONE, EBF_ONE);
+ if(Template->Textures[1] != "")
+ InnerNode->setMaterialTexture(0, irrDriver->getTexture(Template->Textures[1].c_str()));
+ else
diff --git a/games/irrlamb/files/patch-src-objects-player.cpp b/games/irrlamb/files/patch-src-objects-player.cpp
new file mode 100644
index 000000000000..8ea456c81a08
--- /dev/null
+++ b/games/irrlamb/files/patch-src-objects-player.cpp
@@ -0,0 +1,20 @@
+--- src/objects/player.cpp.orig 2013-12-19 22:20:16.890052259 +0400
++++ src/objects/player.cpp 2013-12-19 22:20:57.089132087 +0400
+@@ -45,7 +45,7 @@
+ Node->setMaterialType(EMT_TRANSPARENT_ADD_COLOR);
+ Node->setMaterialFlag(EMF_LIGHTING, false);
+ Node->setMaterialType(EMT_ONETEXTURE_BLEND);
+- Node->getMaterial(0).MaterialTypeParam = pack_texureBlendFunc(EBF_ONE, EBF_ONE);
++ Node->getMaterial(0).MaterialTypeParam = pack_textureBlendFunc(EBF_ONE, EBF_ONE);
+
+ // Light
+ //Light = irrScene->addLightSceneNode(0, core::vector3df(0.0f, 0.0f, 0.0f), video::SColorf(0.2f, 0.2f, 1.0f), 20.0f);
+@@ -57,7 +57,7 @@
+ InnerNode->setMaterialFlag(EMF_ZBUFFER, false);
+ InnerNode->setMaterialTexture(0, irrDriver->getTexture("/home/amdmi3/projects/freebsd/ports/games/irrlamb/prefix/share/irrlamb/textures/player_glow0.png"));
+ InnerNode->setMaterialType(EMT_ONETEXTURE_BLEND);
+- InnerNode->getMaterial(0).MaterialTypeParam = pack_texureBlendFunc(EBF_ONE, EBF_ONE);
++ InnerNode->getMaterial(0).MaterialTypeParam = pack_textureBlendFunc(EBF_ONE, EBF_ONE);
+
+ // Particle system
+ IParticleSystemSceneNode *ParticleSystem = irrScene->addParticleSystemSceneNode(false, Node);