aboutsummaryrefslogtreecommitdiff
path: root/games/jfsw/Makefile
diff options
context:
space:
mode:
authorGiuseppe Pilichi <jacula@FreeBSD.org>2010-05-31 21:21:31 +0000
committerGiuseppe Pilichi <jacula@FreeBSD.org>2010-05-31 21:21:31 +0000
commit43a95308f3649adecfd05a997b1a35811e0c5806 (patch)
tree51ce22b0b00e97109af7dcc62770b96f1f9486dd /games/jfsw/Makefile
parentfa2be9ee8b9cb816c9579f3e0e591d46382aa83c (diff)
This is JonoF's Shadow Warrior port with additional
patches for FX sound support. WWW: http://www.jonof.id.au/jfsw PR: ports/144846 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> Approved by: tabthorpe
Notes
Notes: svn path=/head/; revision=255411
Diffstat (limited to 'games/jfsw/Makefile')
-rw-r--r--games/jfsw/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/games/jfsw/Makefile b/games/jfsw/Makefile
new file mode 100644
index 000000000000..f4ad389602f6
--- /dev/null
+++ b/games/jfsw/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: jfsw
+# Date Created: 11 March 2010
+# Whom: Ganael Laplanche <ganael.laplanche@martymac.com>
+#
+# $FreeBSD$
+
+PORTNAME= jfsw
+PORTVERSION= 20051009
+CATEGORIES= games
+MASTER_SITES= http://users.on.net/~jonof/buildport/
+DISTFILES= ${PORTNAME}_src_${PORTVERSION}.zip \
+ jfbuild_src_${PORTVERSION}.zip
+
+MAINTAINER= ganael.laplanche@martymac.com
+COMMENT= Jonathon Fowler's Shadow Warrior Port
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS_REASON= uses x86 assembly code
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_GL= gl
+USE_GNOME= gtk20
+USE_SDL= mixer sdl
+WRKSRC= ${WRKDIR}/${PORTNAME}_src_${PORTVERSION}
+PATCH_WRKSRC= ${WRKDIR}
+
+SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -Ee \
+ 's|^(EROOT=)../build/|\1../jfbuild_src_${PORTVERSION}/|; \
+ s|^(CC=).*|\1${CC}|; \
+ s|^(CFLAGS=).*|\1${CFLAGS}|; \
+ s|^(NASMFLAGS=).*|\1 -s -f elf|; \
+ s|/usr/X11R6|${LOCALBASE}|; \
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/Makefile \
+ ${WRKDIR}/jfbuild_src_${PORTVERSION}/Makefile \
+ ${WRKDIR}/jfbuild_src_${PORTVERSION}/Makefile.shared
+ @${REINPLACE_CMD} -e 's|/usr/share/games/jfsw|${DATADIR}|' \
+ ${WRKSRC}/source/game.c ${WRKSRC}/source/jnstub.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sw ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/build ${PREFIX}/bin/${PORTNAME}-build
+ ${MKDIR} ${DATADIR}
+.if !defined(NOPORTDOCS)
+.for f in readme.txt releasenotes.html
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>