aboutsummaryrefslogtreecommitdiff
path: root/games/jigzo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-28 08:34:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-28 08:34:21 +0000
commit879c21205012b7a84c8e58fc8445491e9eee14c3 (patch)
treefb4ad766d7ddf92d3ac29fca804a1901acee6309 /games/jigzo
parent39fcf29276c95d3074869924a412e00cd9f28336 (diff)
downloadports-879c21205012b7a84c8e58fc8445491e9eee14c3.tar.gz
ports-879c21205012b7a84c8e58fc8445491e9eee14c3.zip
- Update to 0.5
PR: 122407 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=212144
Diffstat (limited to 'games/jigzo')
-rw-r--r--games/jigzo/Makefile28
-rw-r--r--games/jigzo/distinfo6
-rw-r--r--games/jigzo/files/patch-Loader.cxx13
-rw-r--r--games/jigzo/files/patch-Makefile40
-rw-r--r--games/jigzo/files/patch-main.cxx10
-rw-r--r--games/jigzo/pkg-descr10
-rw-r--r--games/jigzo/pkg-plist37
7 files changed, 60 insertions, 84 deletions
diff --git a/games/jigzo/Makefile b/games/jigzo/Makefile
index aaac10f37cb0..b7b5f23caa73 100644
--- a/games/jigzo/Makefile
+++ b/games/jigzo/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
#
-PORTNAME= glpuzzle
-PORTVERSION= 0.2
-PORTREVISION= 4
+PORTNAME= jigzo
+PORTVERSION= 0.5
CATEGORIES= games
-MASTER_SITES= http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/ \
+MASTER_SITES= http://www.iua.upf.es/~mdeboer/resorama/jigzo/ \
http://www.amdmi3.ru/distfiles/
EXTRACT_SUFX= .tgz
@@ -23,24 +22,21 @@ USE_SDL= sdl mixer
USE_GL= gl
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" \
- CPPFLAGS="`${SDL_CONFIG} --cflags` -I${LOCALBASE}/include" \
- LDFLAGS="`${SDL_CONFIG} --libs` -L${LOCALBASE}/lib"
+MAKE_ENV= CXX="${CXX}"
+PORTDOCS= *
post-patch:
.for i in font image puzzles sound
- @${REINPLACE_CMD} -e "s|${i}/|${DATADIR}/${i}/|g" ${WRKSRC}/main.cxx
+ @${REINPLACE_CMD} -e "s|${i}/|${DATADIR}/${i}/|g" \
+ ${WRKSRC}/src/main.cxx
.endfor
- @${REINPLACE_CMD} -e "s|g++|${CXX}|g" ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e "s|INCLFLAGS|CPPFLAGS|" ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e "/^include.*DEPENDS/ d" ${WRKSRC}/Makefile
+ @${FIND} ${WRKSRC} -name .thumbnails | ${XARGS} ${RM} -rf
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/glpuzzle ${PREFIX}/bin
-.for i in font image puzzles sound
- ${MKDIR} ${DATADIR}/${i}
- ${INSTALL_DATA} ${WRKSRC}/${i}/* ${DATADIR}/${i}
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "font image puzzles sound" \
+ ${DATADIR}/
.ifndef (NOPORTDOCS)
post-install:
diff --git a/games/jigzo/distinfo b/games/jigzo/distinfo
index 6fd331024a28..4fb02c2dfb4d 100644
--- a/games/jigzo/distinfo
+++ b/games/jigzo/distinfo
@@ -1,3 +1,3 @@
-MD5 (glpuzzle-0.2.tgz) = 0dffdc8c0b9a2b689c1932d725ede2d3
-SHA256 (glpuzzle-0.2.tgz) = 2ff48c279c61329f18171c409301a49bcc0789e9085118cf74bb6c09c287f27a
-SIZE (glpuzzle-0.2.tgz) = 4111471
+MD5 (jigzo-0.5.tgz) = 4ca868ca80c2a9ad9b4bf92c7287d598
+SHA256 (jigzo-0.5.tgz) = 57bd9163f902a98440ee4ce2c9a0b7378cc6af796c2c5ecaef5d060450395d9a
+SIZE (jigzo-0.5.tgz) = 4609883
diff --git a/games/jigzo/files/patch-Loader.cxx b/games/jigzo/files/patch-Loader.cxx
deleted file mode 100644
index 39b86aa1e8e7..000000000000
--- a/games/jigzo/files/patch-Loader.cxx
+++ /dev/null
@@ -1,13 +0,0 @@
---- Loader.cxx.orig Mon Feb 6 13:45:24 2006
-+++ Loader.cxx Mon Feb 6 13:45:04 2006
-@@ -20,8 +20,10 @@
-
- #include "Loader.hxx"
-
-+extern "C" {
- #include <png.h>
- #include <jpeglib.h>
-+}
-
- void JpgLoader::Load(const std::string& filename,RGB& target,int x,int y)
- {
diff --git a/games/jigzo/files/patch-Makefile b/games/jigzo/files/patch-Makefile
index d5ce0891df88..7e5988e82e22 100644
--- a/games/jigzo/files/patch-Makefile
+++ b/games/jigzo/files/patch-Makefile
@@ -1,21 +1,25 @@
---- Makefile.orig Sun Feb 5 04:41:46 2006
-+++ Makefile Sun Feb 5 23:05:34 2006
-@@ -1,8 +1,6 @@
- PROGRAM = glpuzzle
+--- Makefile.orig 2008-04-03 01:16:52.000000000 +0400
++++ Makefile 2008-04-03 13:45:02.000000000 +0400
+@@ -19,7 +19,7 @@
+ ARCH_OK = yes
+ endif
--CXXFLAGS = -O2 -Wall
--INCLFLAGS = -I/usr/include/SDL
--LIBSFLAGS = -lpthread -lGL -lpthread -lpng -ljpeg -lSDL
-+LIBSFLAGS = $(LDFLAGS) -lGL -lpng -ljpeg
- SOURCES = main.cxx Screen.cxx Texture.cxx Loader.cxx
+-ifeq "$(ARCH_OK)" "yes"
++ifeq "yes" "yes"
+ #
+ # The given ARCH is correct
+ #
+@@ -28,8 +28,11 @@
+ # Variables
+ #
- ENABLE_SOUND = 1
-@@ -43,7 +41,7 @@
- g++ -c $(CXXFLAGS) $(INCLFLAGS) $< -o $@
+-CXXFLAGS = -O2 $(ARCHCXXFLAGS) -DENABLE_SOUND
+-LDFLAGS = -O2 $(ARCHLDFLAGS)
++STRIP = strip
++APP = jigzo
++
++CXXFLAGS += `$(SDL_CONFIG) --cflags` -DENABLE_SOUND
++LDFLAGS += `$(SDL_CONFIG) --libs` -lGL -lpng -ljpeg -lSDL_mixer
- $(PROGRAM): $(OBJECTS)
-- g++ $(OBJECTS) $(LIBSFLAGS) -o $@
-+ g++ $(OBJECTS) $(CXXFLAGS) $(CPPFLAGS) $(LIBSFLAGS) -o $@
-
- install: $(PROGRAM)
- @echo Installing in $(PREFIX)
+ #
+ # List of all source files.
diff --git a/games/jigzo/files/patch-main.cxx b/games/jigzo/files/patch-main.cxx
deleted file mode 100644
index df5e2962e8cc..000000000000
--- a/games/jigzo/files/patch-main.cxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- main.cxx.orig Sun Feb 5 04:41:46 2006
-+++ main.cxx Sun Feb 5 23:41:41 2006
-@@ -28,6 +28,7 @@
- float BG_G = 0.0;
- float BG_B = 0.0;
-
-+#include <unistd.h>
- #include <cstdio>
- #include <cstring>
- #include <cmath>
diff --git a/games/jigzo/pkg-descr b/games/jigzo/pkg-descr
index 0fc18050cd52..5478569b2694 100644
--- a/games/jigzo/pkg-descr
+++ b/games/jigzo/pkg-descr
@@ -1,6 +1,6 @@
-glpuzzle is a jigsaw puzzle game. Choose from 12 puzzles of various
-difficulties (4 to 25 pieces), and move the pieces around to create
-the desired picture. glpuzzle uses OpenGL for smooth movement and
-anti-aliased display.
+jigzo (formerly glpuzzle) is a jigsaw puzzle game. Choose from 12
+puzzles of various difficulties (4 to 25 pieces), and move the
+pieces around to create the desired picture. gigzo uses OpenGL for
+smooth movement and anti-aliased display.
-WWW: http://www.iua.upf.es/~mdeboer/resorama/glpuzzle/
+WWW: http://www.resorama.com/jigzo/
diff --git a/games/jigzo/pkg-plist b/games/jigzo/pkg-plist
index e22e2d70c65d..27fb58e8ed1a 100644
--- a/games/jigzo/pkg-plist
+++ b/games/jigzo/pkg-plist
@@ -1,28 +1,27 @@
-bin/glpuzzle
+bin/jigzo
%%DATADIR%%/font/charmap.jpg
%%DATADIR%%/font/charmap.map
%%DATADIR%%/font/charmap.png
%%DATADIR%%/image/arrow.png
-%%DATADIR%%/image/clouds-3x2.png
+%%DATADIR%%/image/folder.png
%%DATADIR%%/image/leave.png
-%%DATADIR%%/puzzles/bike-3x4.pzl
-%%DATADIR%%/puzzles/bird-4x4.pzl
-%%DATADIR%%/puzzles/blackberry-3x3.pzl
-%%DATADIR%%/puzzles/castle-6x3.pzl
-%%DATADIR%%/puzzles/clouds-4x4.pzl
-%%DATADIR%%/puzzles/goat-4x3.pzl
-%%DATADIR%%/puzzles/gorilla-4x3.pzl
-%%DATADIR%%/puzzles/heli-4x3.pzl
-%%DATADIR%%/puzzles/horse-4x3.pzl
-%%DATADIR%%/puzzles/penguin-3x2.pzl
-%%DATADIR%%/puzzles/penguins-5x5.pzl
-%%DATADIR%%/puzzles/train-2x2.pzl
+%%DATADIR%%/puzzles/00_default/bike-3x4.pzl
+%%DATADIR%%/puzzles/00_default/bird-2x3.pzl
+%%DATADIR%%/puzzles/00_default/blackberry-3x3.pzl
+%%DATADIR%%/puzzles/00_default/castle-6x3.pzl
+%%DATADIR%%/puzzles/00_default/clouds-4x4.pzl
+%%DATADIR%%/puzzles/00_default/gorilla2-3x3.pzl
+%%DATADIR%%/puzzles/00_default/heli-4x3.pzl
+%%DATADIR%%/puzzles/00_default/horse-4x3.pzl
+%%DATADIR%%/puzzles/00_default/penguin-3x2.pzl
+%%DATADIR%%/puzzles/00_default/tobogan-4x3.pzl
+%%DATADIR%%/puzzles/00_default/train-2x2.pzl
+%%DATADIR%%/puzzles/00_default/windmill-4x4.pzl
%%DATADIR%%/sound/connect.wav
%%DATADIR%%/sound/finish.wav
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/font
-@dirrm %%DATADIR%%/image
-@dirrm %%DATADIR%%/puzzles
@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/puzzles/00_default
+@dirrm %%DATADIR%%/puzzles
+@dirrm %%DATADIR%%/image
+@dirrm %%DATADIR%%/font
@dirrm %%DATADIR%%