aboutsummaryrefslogtreecommitdiff
path: root/games/jin
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-03-06 09:07:23 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-03-06 09:07:23 +0000
commit59fe2fc57065d9686082109ed3990dd79f972a2e (patch)
tree085b7f3d8688bf9cfb0efd4bd97fdb19711b0b37 /games/jin
parent495503ab4d748c66c84e5ac1675649d38d9efc01 (diff)
downloadports-59fe2fc57065d9686082109ed3990dd79f972a2e.tar.gz
ports-59fe2fc57065d9686082109ed3990dd79f972a2e.zip
Jin is an open source, cross platform, graphical client (interface)
for chess servers. It currently supports these servers: * The Internet Chess Club (aka ICC) * The Free Internet Chess Server (aka FICS) A short list of Jin's main features: * Graphical chess board with many board patterns and piece sets to choose from. You can also create your own * Chat/Command console with (customizable) color-coding for different types of chat/text * A seek graph, showing the currently sought games in a visual manner * Flexible game logger, which saves your finished games to your hard disk (doesn't work in JinApplet) * A scripter, which allows you to define automatic responses to certain events * A list of common actions, which can be quickly executed at the press of a button WWW: http://www.jinchess.com/
Notes
Notes: svn path=/head/; revision=186657
Diffstat (limited to 'games/jin')
-rw-r--r--games/jin/Makefile45
-rw-r--r--games/jin/distinfo3
-rw-r--r--games/jin/files/jin.in5
-rw-r--r--games/jin/pkg-descr21
-rw-r--r--games/jin/pkg-plist98
5 files changed, 172 insertions, 0 deletions
diff --git a/games/jin/Makefile b/games/jin/Makefile
new file mode 100644
index 000000000000..bade1541c2de
--- /dev/null
+++ b/games/jin/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: jin
+# Date created: 2007-03-05
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jin
+PORTVERSION= 2.14.1
+CATEGORIES= games java
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-unix
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A graphical client for chess servers
+
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+
+SUB_FILES= ${PORTNAME}
+SUB_LIST= JINJAR=${JINJAR}
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+JINJAR= ${PORTNAME}.jar
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+FIND_DIRS= . -type d
+FIND_DATA= . -type f
+RM_FILES= ${PORTNAME} README changelog.txt gpl.txt
+
+post-extract:
+.for f in ${RM_FILES}
+ @${RM} ${WRKSRC}/${f}
+.endfor
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC} && ${FIND} ${FIND_DIRS} -exec ${MKDIR} ${DATADIR}/{} ";"
+ @cd ${WRKSRC} && ${FIND} ${FIND_DATA} -exec ${INSTALL_DATA} {} ${DATADIR}/{} ";"
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/games/jin/distinfo b/games/jin/distinfo
new file mode 100644
index 000000000000..6b18cc9ae1ec
--- /dev/null
+++ b/games/jin/distinfo
@@ -0,0 +1,3 @@
+MD5 (jin-2.14.1-unix.tar.gz) = 62256214583c3214ffb9046176b6b02d
+SHA256 (jin-2.14.1-unix.tar.gz) = 07652a896ec36f037ba9fd0af0d714a24aaf478926c9adb3677d45b5bfb08544
+SIZE (jin-2.14.1-unix.tar.gz) = 17579169
diff --git a/games/jin/files/jin.in b/games/jin/files/jin.in
new file mode 100644
index 000000000000..c75be0744b7b
--- /dev/null
+++ b/games/jin/files/jin.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+# $FreeBSD$
+cd %%DATADIR%%
+JAVA_VERSION="%%JAVA_VERSION%%" \
+exec "%%LOCALBASE%%/bin/java" -jar %%DATADIR%%/%%JINJAR%% "$@"
diff --git a/games/jin/pkg-descr b/games/jin/pkg-descr
new file mode 100644
index 000000000000..5c49f7488dd2
--- /dev/null
+++ b/games/jin/pkg-descr
@@ -0,0 +1,21 @@
+Jin is an open source, cross platform, graphical client (interface)
+for chess servers. It currently supports these servers:
+
+ * The Internet Chess Club (aka ICC)
+ * The Free Internet Chess Server (aka FICS)
+
+A short list of Jin's main features:
+
+ * Graphical chess board with many board patterns and piece sets
+ to choose from. You can also create your own
+ * Chat/Command console with (customizable) color-coding for
+ different types of chat/text
+ * A seek graph, showing the currently sought games in a visual manner
+ * Flexible game logger, which saves your finished games to your
+ hard disk (doesn't work in JinApplet)
+ * A scripter, which allows you to define automatic responses
+ to certain events
+ * A list of common actions, which can be quickly executed
+ at the press of a button
+
+WWW: http://www.jinchess.com/
diff --git a/games/jin/pkg-plist b/games/jin/pkg-plist
new file mode 100644
index 000000000000..a725c0651854
--- /dev/null
+++ b/games/jin/pkg-plist
@@ -0,0 +1,98 @@
+@comment $FreeBSD$
+bin/jin
+%%DATADIR%%/actions/askquestion.jar
+%%DATADIR%%/actions/getserverhelp.jar
+%%DATADIR%%/actions/seek.jar
+%%DATADIR%%/chess.jar
+%%DATADIR%%/copyright.txt
+%%DATADIR%%/icon.png
+%%DATADIR%%/jin.jar
+%%DATADIR%%/libs/board.jar
+%%DATADIR%%/libs/bsh-core-1.2b7.jar
+%%DATADIR%%/libs/console.jar
+%%DATADIR%%/libs/fics/timesealing.jar
+%%DATADIR%%/libs/icc/timestamping.jar
+%%DATADIR%%/libs/scripter.jar
+%%DATADIR%%/libs/seek.jar
+%%DATADIR%%/libs/sound.jar
+%%DATADIR%%/lnfs/jgoodies-plastic.jar
+%%DATADIR%%/lnfs/kunststoff.jar
+%%DATADIR%%/lnfs/liquid.jar
+%%DATADIR%%/lnfs/metouia.jar
+%%DATADIR%%/plugins/actions.jar
+%%DATADIR%%/plugins/fics/board.jar
+%%DATADIR%%/plugins/fics/console.jar
+%%DATADIR%%/plugins/fics/scripter.jar
+%%DATADIR%%/plugins/fics/seek.jar
+%%DATADIR%%/plugins/fics/sound.jar
+%%DATADIR%%/plugins/gamelogger.jar
+%%DATADIR%%/plugins/icc/board.jar
+%%DATADIR%%/plugins/icc/console.jar
+%%DATADIR%%/plugins/icc/scripter.jar
+%%DATADIR%%/plugins/icc/seek.jar
+%%DATADIR%%/plugins/icc/sound.jar
+%%DATADIR%%/resources/boards/cold-marble.zip
+%%DATADIR%%/resources/boards/crampled-paper.zip
+%%DATADIR%%/resources/boards/gray-tiles.zip
+%%DATADIR%%/resources/boards/green-marble.zip
+%%DATADIR%%/resources/boards/icc/wooden-light.zip
+%%DATADIR%%/resources/boards/pale-wood.zip
+%%DATADIR%%/resources/boards/plain.zip
+%%DATADIR%%/resources/boards/red-marble.zip
+%%DATADIR%%/resources/boards/slate.zip
+%%DATADIR%%/resources/boards/winter.zip
+%%DATADIR%%/resources/boards/wooden-dark.zip
+%%DATADIR%%/resources/pieces/adventure.zip
+%%DATADIR%%/resources/pieces/alfonso-x.zip
+%%DATADIR%%/resources/pieces/alpha.zip
+%%DATADIR%%/resources/pieces/berlin.zip
+%%DATADIR%%/resources/pieces/condal.zip
+%%DATADIR%%/resources/pieces/eyes.zip
+%%DATADIR%%/resources/pieces/fantasy.zip
+%%DATADIR%%/resources/pieces/fics/eboard.zip
+%%DATADIR%%/resources/pieces/freak.zip
+%%DATADIR%%/resources/pieces/harlequin.zip
+%%DATADIR%%/resources/pieces/icc/blitzin.zip
+%%DATADIR%%/resources/pieces/icc/bookup.zip
+%%DATADIR%%/resources/pieces/icc/dyche1.zip
+%%DATADIR%%/resources/pieces/icc/dyche2.zip
+%%DATADIR%%/resources/pieces/icc/dyche3.zip
+%%DATADIR%%/resources/pieces/kingdom.zip
+%%DATADIR%%/resources/pieces/leipzig.zip
+%%DATADIR%%/resources/pieces/line.zip
+%%DATADIR%%/resources/pieces/lucena.zip
+%%DATADIR%%/resources/pieces/magnetic.zip
+%%DATADIR%%/resources/pieces/mark.zip
+%%DATADIR%%/resources/pieces/marroquin.zip
+%%DATADIR%%/resources/pieces/maya.zip
+%%DATADIR%%/resources/pieces/medieval.zip
+%%DATADIR%%/resources/pieces/merida.zip
+%%DATADIR%%/resources/pieces/motif.zip
+%%DATADIR%%/resources/pieces/prmi.zip
+%%DATADIR%%/resources/pieces/skulls.zip
+%%DATADIR%%/resources/pieces/smart.zip
+%%DATADIR%%/resources/pieces/spatial.zip
+%%DATADIR%%/resources/pieces/usual.zip
+%%DATADIR%%/resources/pieces/utrecht.zip
+%%DATADIR%%/resources/pieces/xboard.zip
+%%DATADIR%%/servers/chessclub.jar
+%%DATADIR%%/servers/freechess.jar
+%%DATADIR%%/util.jar
+@dirrm %%DATADIR%%/actions/fics
+@dirrm %%DATADIR%%/actions/icc
+@dirrm %%DATADIR%%/actions
+@dirrm %%DATADIR%%/libs/fics
+@dirrm %%DATADIR%%/libs/icc
+@dirrm %%DATADIR%%/libs
+@dirrm %%DATADIR%%/lnfs
+@dirrm %%DATADIR%%/plugins/fics
+@dirrm %%DATADIR%%/plugins/icc
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/resources/boards/icc
+@dirrm %%DATADIR%%/resources/boards
+@dirrm %%DATADIR%%/resources/pieces/fics
+@dirrm %%DATADIR%%/resources/pieces/icc
+@dirrm %%DATADIR%%/resources/pieces
+@dirrm %%DATADIR%%/resources
+@dirrm %%DATADIR%%/servers
+@dirrm %%DATADIR%%