aboutsummaryrefslogtreecommitdiff
path: root/games/jinput
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-04-18 08:59:58 +0000
committerChris Rees <crees@FreeBSD.org>2012-04-18 08:59:58 +0000
commit80eea73f40cb5379191b6e137b222eca0f4e83a5 (patch)
treea20be72fdd0cc0b8fb19330e14c04b3dfaebf4f9 /games/jinput
parentf411d5262349c7ef4e8641514abf714b32d0ada7 (diff)
downloadports-80eea73f40cb5379191b6e137b222eca0f4e83a5.tar.gz
ports-80eea73f40cb5379191b6e137b222eca0f4e83a5.zip
Java Game Controller API
WWW: https://svn.java.net/svn/jinput~svn/trunk PR: ports/166678 Submitted by: loader
Notes
Notes: svn path=/head/; revision=295004
Diffstat (limited to 'games/jinput')
-rw-r--r--games/jinput/Makefile40
-rw-r--r--games/jinput/distinfo2
-rw-r--r--games/jinput/pkg-descr3
3 files changed, 45 insertions, 0 deletions
diff --git a/games/jinput/Makefile b/games/jinput/Makefile
new file mode 100644
index 000000000000..c5b984029d20
--- /dev/null
+++ b/games/jinput/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: jinput
+# Date created: Mar 25 2012
+# Whom: loader <loader@freebsdmall.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jinput
+DISTVERSION= 20110801.r247
+CATEGORIES= games java
+MASTER_SITES= LOCAL/loader
+
+MAINTAINER= loader@freebsdmall.com
+COMMENT= Java Game Controller API
+
+BUILD_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:${PORTSDIR}/games/jutils
+RUN_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:${PORTSDIR}/games/jutils
+
+USE_BZIP2= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6
+JAVA_OS= native
+JAVA_VENDOR= openjdk
+USE_ANT= yes
+ALL_TARGET= simple_linux
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}/${PORTNAME}.jar
+PLIST_DIRS= %%JAVAJARDIR%%/${PORTNAME}
+
+post-patch:
+ @${LN} -sf ${JAVALIBDIR}/jutils/jutils.jar ${WRKSRC}/lib/
+
+do-install:
+ @${ECHO_MSG} -n ">> Install JAR files in ${JAVAJARDIR}/${PORTNAME}/ ..."
+ @${MKDIR} ${JAVAJARDIR}/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar \
+ ${JAVAJARDIR}/${PORTNAME}/
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/games/jinput/distinfo b/games/jinput/distinfo
new file mode 100644
index 000000000000..67cd2f8e1b45
--- /dev/null
+++ b/games/jinput/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jinput-20110801.r247.tar.bz2) = 2275512294a1ed8ca739d60653ff12a4beb775dd43e929433488884e7d4691f7
+SIZE (jinput-20110801.r247.tar.bz2) = 1565811
diff --git a/games/jinput/pkg-descr b/games/jinput/pkg-descr
new file mode 100644
index 000000000000..a7031c770074
--- /dev/null
+++ b/games/jinput/pkg-descr
@@ -0,0 +1,3 @@
+Java Game Controller API
+
+WWW: https://svn.java.net/svn/jinput~svn/trunk