aboutsummaryrefslogtreecommitdiff
path: root/games/julius
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-05 14:19:52 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-05 14:19:52 +0000
commitc1e91d06601cd3004ecd035fa5e85fee6844d664 (patch)
tree31bc3efaf4bc1e5177407aaed767898bed814ede /games/julius
parent206bab499b9b68b33be2fc2c472f64b4aa15e243 (diff)
downloadports-c1e91d06601cd3004ecd035fa5e85fee6844d664.tar.gz
ports-c1e91d06601cd3004ecd035fa5e85fee6844d664.zip
games/julius: fix build with SDL 2.0.10
SDL 2.0.10 removed SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH and introduced SDL_HINT_MOUSE_TOUCH_EVENTS and SDL_HINT_TOUCH_MOUSE_EVENTS. Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D21148
Notes
Notes: svn path=/head/; revision=508175
Diffstat (limited to 'games/julius')
-rw-r--r--games/julius/Makefile2
-rw-r--r--games/julius/files/patch-src_platform_julius.c12
2 files changed, 12 insertions, 2 deletions
diff --git a/games/julius/Makefile b/games/julius/Makefile
index 42fd2acf59aa..0e4c7946f585 100644
--- a/games/julius/Makefile
+++ b/games/julius/Makefile
@@ -13,8 +13,6 @@ COMMENT= Open source re-implementation of Caesar III
LICENSE= GPLv3
-BROKEN= use of undeclared identifier 'SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH'
-
USES= cmake sdl
USE_GITHUB= yes
diff --git a/games/julius/files/patch-src_platform_julius.c b/games/julius/files/patch-src_platform_julius.c
new file mode 100644
index 000000000000..3f6e7e835bc1
--- /dev/null
+++ b/games/julius/files/patch-src_platform_julius.c
@@ -0,0 +1,12 @@
+--- src/platform/julius.c.orig 2019-08-03 16:50:03 UTC
++++ src/platform/julius.c
+@@ -369,7 +369,8 @@ static int init_sdl(void)
+ return 0;
+ }
+ #if SDL_VERSION_ATLEAST(2, 0, 4)
+- SDL_SetHint(SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH, "1");
++ SDL_SetHint(SDL_HINT_MOUSE_TOUCH_EVENTS, "0");
++ SDL_SetHint(SDL_HINT_TOUCH_MOUSE_EVENTS, "0");
+ #endif
+ SDL_Log("SDL initialized");
+ return 1;