aboutsummaryrefslogtreecommitdiff
path: root/games/julius
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2018-05-14 02:29:04 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2018-05-14 02:29:04 +0000
commitd784b575843f4f6fbb16b7a65005b933481694de (patch)
tree9470f8be534cef7253baca95d602747db7d9b230 /games/julius
parent6d3fb9beb613203ed38419f51e790a8888fbaeff (diff)
downloadports-d784b575843f4f6fbb16b7a65005b933481694de.tar.gz
ports-d784b575843f4f6fbb16b7a65005b933481694de.zip
Add julius g20180430, open source re-implementation of Caesar III.
PR: 228103 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=469845
Diffstat (limited to 'games/julius')
-rw-r--r--games/julius/Makefile33
-rw-r--r--games/julius/distinfo3
-rw-r--r--games/julius/files/julius.in3
-rw-r--r--games/julius/files/patch-CMakeLists.txt11
-rw-r--r--games/julius/files/patch-test_CMakeLists.txt8
-rw-r--r--games/julius/files/pkg-message.in1
-rw-r--r--games/julius/pkg-descr3
7 files changed, 62 insertions, 0 deletions
diff --git a/games/julius/Makefile b/games/julius/Makefile
new file mode 100644
index 000000000000..5e1da8e2842d
--- /dev/null
+++ b/games/julius/Makefile
@@ -0,0 +1,33 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= julius
+PORTVERSION= g20180430
+CATEGORIES= games
+
+MAINTAINER= pkubaj@anongoth.pl
+COMMENT= Open source re-implementation of Caesar III
+
+LICENSE= GPLv3
+
+USES= cmake:outsource
+
+USE_GITHUB= yes
+GH_ACCOUNT= bvschaik
+GH_TAGNAME= cb7ecdf
+
+USE_SDL= mixer2 sdl2
+
+SUB_FILES= julius pkg-message
+
+PLIST_FILES= bin/${PORTNAME} \
+ ${DATADIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/games/julius/distinfo b/games/julius/distinfo
new file mode 100644
index 000000000000..0048c611fd65
--- /dev/null
+++ b/games/julius/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1525895014
+SHA256 (bvschaik-julius-g20180430-cb7ecdf_GH0.tar.gz) = 7f60ba486c46c5cb55e6b581e29f8af3fd865dcbdc389f5b2ad639a568846487
+SIZE (bvschaik-julius-g20180430-cb7ecdf_GH0.tar.gz) = 2381369
diff --git a/games/julius/files/julius.in b/games/julius/files/julius.in
new file mode 100644
index 000000000000..1dfb2919f6fe
--- /dev/null
+++ b/games/julius/files/julius.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%PREFIX%%/share/julius && ./julius data
diff --git a/games/julius/files/patch-CMakeLists.txt b/games/julius/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..426008b7671f
--- /dev/null
+++ b/games/julius/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-05-09 19:46:16 UTC
++++ CMakeLists.txt
+@@ -343,7 +343,7 @@ if(MSVC)
+ include_directories(ext/dirent)
+ endif()
+
+-target_link_libraries (julius ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARY})
++target_link_libraries (julius ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARY} execinfo)
+
+ install(TARGETS julius RUNTIME DESTINATION bin)
+
diff --git a/games/julius/files/patch-test_CMakeLists.txt b/games/julius/files/patch-test_CMakeLists.txt
new file mode 100644
index 000000000000..b0f583d80323
--- /dev/null
+++ b/games/julius/files/patch-test_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- test/CMakeLists.txt.orig 2018-05-09 19:53:39 UTC
++++ test/CMakeLists.txt
+@@ -82,3 +82,5 @@ add_integration_test(sav_routing_full ro
+
+ # God curses
+ add_integration_test(sav_curses curses.sav curses-done.sav 13350)
++
++target_link_libraries (autopilot execinfo)
diff --git a/games/julius/files/pkg-message.in b/games/julius/files/pkg-message.in
new file mode 100644
index 000000000000..314ce142b1a3
--- /dev/null
+++ b/games/julius/files/pkg-message.in
@@ -0,0 +1 @@
+To play this game, copy Caesar III game files to %%DATADIR%%/data.
diff --git a/games/julius/pkg-descr b/games/julius/pkg-descr
new file mode 100644
index 000000000000..cf5bf831ed25
--- /dev/null
+++ b/games/julius/pkg-descr
@@ -0,0 +1,3 @@
+An open source re-implementation of Caesar III
+
+WWW: https://github.com/bvschaik/julius