aboutsummaryrefslogtreecommitdiff
path: root/games/khangman/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
commit24482eebf1b38a1d781b1f6c16bb588f5e652980 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /games/khangman/Makefile
parente9088ff192d5f032b73c9b2e3386bbc9bf25136b (diff)
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Notes
Notes: svn path=/head/; revision=315373
Diffstat (limited to 'games/khangman/Makefile')
-rw-r--r--games/khangman/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/khangman/Makefile b/games/khangman/Makefile
index cbe5e9a6a689..b64c20a6af25 100644
--- a/games/khangman/Makefile
+++ b/games/khangman/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= games kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Hangman game for KDE 4
@@ -14,8 +14,9 @@ CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix libkdeedu automoc4
USES= cmake:outsource
-USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_XZ= yes
+USE_QT4= corelib declarative gui opengl script xml \
+ moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes