aboutsummaryrefslogtreecommitdiff
path: root/games/kodi-addon-game.libretro.beetle-psx
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-02-28 18:46:10 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-02-28 18:46:10 +0000
commitf1627d76bb10d60702a7e281d579d736a62a4cb8 (patch)
treeb0cd953f16a1a97e57219f73901b61a805b21520 /games/kodi-addon-game.libretro.beetle-psx
parent0536c1a6d101370c0fa768839c24c06538ff3e69 (diff)
downloadports-f1627d76bb10d60702a7e281d579d736a62a4cb8.tar.gz
ports-f1627d76bb10d60702a7e281d579d736a62a4cb8.zip
Beetle PSX is a port/fork of Mednafen's PSX module to the libretro API.
It can be compiled in C++98 mode, excluding the Vulkan renderer, which is written in C++11 for the time being. Beetle PSX currently runs on Linux, OSX and Windows. WWW: https://github.com/libretro/beetle-psx-libretro PR: 245258 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=566789
Diffstat (limited to 'games/kodi-addon-game.libretro.beetle-psx')
-rw-r--r--games/kodi-addon-game.libretro.beetle-psx/Makefile41
-rw-r--r--games/kodi-addon-game.libretro.beetle-psx/distinfo5
-rw-r--r--games/kodi-addon-game.libretro.beetle-psx/pkg-descr6
-rw-r--r--games/kodi-addon-game.libretro.beetle-psx/pkg-message12
4 files changed, 64 insertions, 0 deletions
diff --git a/games/kodi-addon-game.libretro.beetle-psx/Makefile b/games/kodi-addon-game.libretro.beetle-psx/Makefile
new file mode 100644
index 000000000000..527f4c3fcb66
--- /dev/null
+++ b/games/kodi-addon-game.libretro.beetle-psx/Makefile
@@ -0,0 +1,41 @@
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
+# $FreeBSD$
+
+PORTNAME= game.libretro.beetle-psx
+PORTVERSION= 0.9.44.22
+DISTVERSIONSUFFIX= -Matrix
+CATEGORIES= games
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Kodi game addon for Sony - PlayStation (Beetle PSX)
+
+LICENSE= GPLv2+
+
+LIB_DEPENDS= libtinyxml.so:textproc/tinyxml
+RUN_DEPENDS= kodi-addon-game.libretro>=0:games/kodi-addon-game.libretro
+
+USES= cmake:noninja gmake kodi localbase
+USE_GITHUB= yes
+GH_ACCOUNT= kodi-game \
+ libretro:beetle_psx
+GH_PROJECT= beetle-psx-libretro:beetle_psx
+# Keep in sync with: depends/common/beetle-psx/beetle-psx.txt
+GH_TAGNAME= e1836bde1b250d41c6f91c2b6f06444d989f1138:beetle_psx
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS=1 \
+ -DADDONS_TO_BUILD=${PORTNAME} \
+ -DBEETLE-PSX_LIB=depends/common/beetle-psx/mednafen_psx_libretro.so
+
+post-extract:
+ @${MV} ${WRKSRC_beetle_psx}/* ${WRKSRC}/depends/common/beetle-psx/
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|find_library(BEETLE-PSX_LIB.*|add_subdirectory(depends/common/beetle-psx)|g' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|defined(BSD)|!defined(CLOCK_REALTIME)|g' \
+ ${WRKSRC}/depends/common/beetle-psx/libretro-common/rthreads/rthreads.c
+
+post-install:
+ ${RM} -rf ${STAGEDIR}${PREFIX}/lib/libretro
+
+.include <bsd.port.mk>
diff --git a/games/kodi-addon-game.libretro.beetle-psx/distinfo b/games/kodi-addon-game.libretro.beetle-psx/distinfo
new file mode 100644
index 000000000000..7e3776c865c4
--- /dev/null
+++ b/games/kodi-addon-game.libretro.beetle-psx/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1611230274
+SHA256 (kodi-game-game.libretro.beetle-psx-0.9.44.22-Matrix_GH0.tar.gz) = 5f2c3f8e503f2d18b90d77ca9717b3522727e39750d2aedb7707d7786ad1ba2e
+SIZE (kodi-game-game.libretro.beetle-psx-0.9.44.22-Matrix_GH0.tar.gz) = 46846
+SHA256 (libretro-beetle-psx-libretro-e1836bde1b250d41c6f91c2b6f06444d989f1138_GH0.tar.gz) = 1495fc8f7fcaeb2b1f1ae9d8b5a0ffaad0fc0cd72634746964b42b67bc3a9732
+SIZE (libretro-beetle-psx-libretro-e1836bde1b250d41c6f91c2b6f06444d989f1138_GH0.tar.gz) = 2795575
diff --git a/games/kodi-addon-game.libretro.beetle-psx/pkg-descr b/games/kodi-addon-game.libretro.beetle-psx/pkg-descr
new file mode 100644
index 000000000000..307e84871280
--- /dev/null
+++ b/games/kodi-addon-game.libretro.beetle-psx/pkg-descr
@@ -0,0 +1,6 @@
+Beetle PSX is a port/fork of Mednafen's PSX module to the libretro API.
+It can be compiled in C++98 mode, excluding the Vulkan renderer, which
+is written in C++11 for the time being. Beetle PSX currently runs on
+Linux, OSX and Windows.
+
+WWW: https://github.com/libretro/beetle-psx-libretro
diff --git a/games/kodi-addon-game.libretro.beetle-psx/pkg-message b/games/kodi-addon-game.libretro.beetle-psx/pkg-message
new file mode 100644
index 000000000000..1cc3cde44818
--- /dev/null
+++ b/games/kodi-addon-game.libretro.beetle-psx/pkg-message
@@ -0,0 +1,12 @@
+[
+{ type: install
+ message: <<EOM
+
+BIOS files required, download and save to:
+~/.kodi/userdata/addon_data/game.libretro.beetle-psx/resources/system/
+
+WWW: https://kodi.wiki/view/Game_add-ons#BIOS_requirements
+
+EOM
+}
+]