aboutsummaryrefslogtreecommitdiff
path: root/games/kodi-addon-game.libretro.pcsx-rearmed
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-02-28 18:52:47 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-02-28 18:52:47 +0000
commit9ab8a77e90a3007ab8871e5d355ee4e2d324b55d (patch)
tree73929e83f03b3ac5fb563c673ceea6e2b74da108 /games/kodi-addon-game.libretro.pcsx-rearmed
parentdcf31cc0f1f6bfcbdd9501aeae23b423708bbdac (diff)
downloadports-9ab8a77e90a3007ab8871e5d355ee4e2d324b55d.tar.gz
ports-9ab8a77e90a3007ab8871e5d355ee4e2d324b55d.zip
PCSX ReARMed is yet another PCSX fork based on the PCSX-Reloaded
project, which itself contains code from PCSX, PCSX-df and PCSX-Revolution. This version is ARM architecture oriented and features MIPS->ARM recompiler by Ari64, NEON GTE code and more performance improvements. It was created for Pandora handheld, but should be usable on other devices after some code adjustments (N900, GPH Wiz/Caanoo, PlayBook versions are also available). PCSX ReARMed features ARM NEON GPU by Exophase, that in many cases produces pixel perfect graphics at very high performance. There is also Una-i's GPU plugin from PCSX4ALL project, and traditional P.E.Op.S. one. WWW: https://github.com/libretro/pcsx_rearmed PR: 245262 Submitted by: rozhuk.im@gmail.com
Notes
Notes: svn path=/head/; revision=566791
Diffstat (limited to 'games/kodi-addon-game.libretro.pcsx-rearmed')
-rw-r--r--games/kodi-addon-game.libretro.pcsx-rearmed/Makefile40
-rw-r--r--games/kodi-addon-game.libretro.pcsx-rearmed/distinfo5
-rw-r--r--games/kodi-addon-game.libretro.pcsx-rearmed/pkg-descr14
-rw-r--r--games/kodi-addon-game.libretro.pcsx-rearmed/pkg-message12
4 files changed, 71 insertions, 0 deletions
diff --git a/games/kodi-addon-game.libretro.pcsx-rearmed/Makefile b/games/kodi-addon-game.libretro.pcsx-rearmed/Makefile
new file mode 100644
index 000000000000..0ad14f2e9086
--- /dev/null
+++ b/games/kodi-addon-game.libretro.pcsx-rearmed/Makefile
@@ -0,0 +1,40 @@
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
+# $FreeBSD$
+
+PORTNAME= game.libretro.pcsx-rearmed
+PORTVERSION= 22.0.0.19
+DISTVERSIONSUFFIX= -Matrix
+CATEGORIES= games
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Kodi game addon for Sony - PlayStation (PCSX ReARMed)
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/depends/common/pcsx-rearmed/COPYING
+
+LIB_DEPENDS= libtinyxml.so:textproc/tinyxml
+RUN_DEPENDS= kodi-addon-game.libretro>=0:games/kodi-addon-game.libretro
+
+USES= cmake:noninja gmake kodi
+USE_GITHUB= yes
+GH_ACCOUNT= kodi-game \
+ libretro:pcsx_rearmed
+GH_PROJECT= pcsx_rearmed:pcsx_rearmed
+# Keep in sync with: depends/common/pcsx-rearmed/pcsx-rearmed.txt
+GH_TAGNAME= 54686ee7ccbba7220aaf69892ad3d77515478776:pcsx_rearmed
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS=1 \
+ -DADDONS_TO_BUILD=${PORTNAME} \
+ -DPCSX-REARMED_LIB=depends/common/pcsx-rearmed/pcsx_rearmed_libretro.so
+
+post-extract:
+ @${MV} ${WRKSRC_pcsx_rearmed}/* ${WRKSRC}/depends/common/pcsx-rearmed/
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|find_library(PCSX-REARMED_LIB.*|add_subdirectory(depends/common/pcsx-rearmed)|g' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ ${RM} -rf ${STAGEDIR}${PREFIX}/lib/libretro
+
+.include <bsd.port.mk>
diff --git a/games/kodi-addon-game.libretro.pcsx-rearmed/distinfo b/games/kodi-addon-game.libretro.pcsx-rearmed/distinfo
new file mode 100644
index 000000000000..460e25093560
--- /dev/null
+++ b/games/kodi-addon-game.libretro.pcsx-rearmed/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1611230780
+SHA256 (kodi-game-game.libretro.pcsx-rearmed-22.0.0.19-Matrix_GH0.tar.gz) = 56ebea334e7b61372f05ee2cba2576176eb2c42982ec839e158c7397cd5188ab
+SIZE (kodi-game-game.libretro.pcsx-rearmed-22.0.0.19-Matrix_GH0.tar.gz) = 72793
+SHA256 (libretro-pcsx_rearmed-54686ee7ccbba7220aaf69892ad3d77515478776_GH0.tar.gz) = aeb8941cb9a262d4e9f94d6491c2cfaa823df759f40b30dd624c27a36f369fa1
+SIZE (libretro-pcsx_rearmed-54686ee7ccbba7220aaf69892ad3d77515478776_GH0.tar.gz) = 2289399
diff --git a/games/kodi-addon-game.libretro.pcsx-rearmed/pkg-descr b/games/kodi-addon-game.libretro.pcsx-rearmed/pkg-descr
new file mode 100644
index 000000000000..313ec475e487
--- /dev/null
+++ b/games/kodi-addon-game.libretro.pcsx-rearmed/pkg-descr
@@ -0,0 +1,14 @@
+PCSX ReARMed is yet another PCSX fork based on the PCSX-Reloaded
+project, which itself contains code from PCSX, PCSX-df and
+PCSX-Revolution.
+This version is ARM architecture oriented and features MIPS->ARM
+recompiler by Ari64, NEON GTE code and more performance improvements.
+It was created for Pandora handheld, but should be usable on other
+devices after some code adjustments (N900, GPH Wiz/Caanoo, PlayBook
+versions are also available).
+
+PCSX ReARMed features ARM NEON GPU by Exophase, that in many cases
+produces pixel perfect graphics at very high performance. There is also
+Una-i's GPU plugin from PCSX4ALL project, and traditional P.E.Op.S. one.
+
+WWW: https://github.com/libretro/pcsx_rearmed
diff --git a/games/kodi-addon-game.libretro.pcsx-rearmed/pkg-message b/games/kodi-addon-game.libretro.pcsx-rearmed/pkg-message
new file mode 100644
index 000000000000..ca574b700aa2
--- /dev/null
+++ b/games/kodi-addon-game.libretro.pcsx-rearmed/pkg-message
@@ -0,0 +1,12 @@
+[
+{ type: install
+ message: <<EOM
+
+BIOS files required, download and save to:
+~/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system/
+
+WWW: https://kodi.wiki/view/Game_add-ons#BIOS_requirements
+
+EOM
+}
+]