aboutsummaryrefslogtreecommitdiff
path: root/games/ladder
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-08-11 07:19:59 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-08-11 07:19:59 +0000
commitc90d3c5b7e42ea9e594ee0746f572427ec178e5b (patch)
treebc6c5ae5a9f3a2894d4f667ce3d0163e95dd1236 /games/ladder
parent81e805e9363e4879d34bff5585f38f4108932f80 (diff)
downloadports-c90d3c5b7e42ea9e594ee0746f572427ec178e5b.tar.gz
ports-c90d3c5b7e42ea9e594ee0746f572427ec178e5b.zip
Install this setgid games, not setuid games. Respect CC and CFLAGS.
Split the patches into one file per patch, per the porters handbook. Bump PORTREVISION to not setuid->setgid change.
Notes
Notes: svn path=/head/; revision=46066
Diffstat (limited to 'games/ladder')
-rw-r--r--games/ladder/Makefile1
-rw-r--r--games/ladder/files/patch-aa8
-rw-r--r--games/ladder/files/patch-ab107
-rw-r--r--games/ladder/files/patch-ac11
-rw-r--r--games/ladder/files/patch-ad29
-rw-r--r--games/ladder/files/patch-ae40
-rw-r--r--games/ladder/files/patch-af10
-rw-r--r--games/ladder/files/patch-ag8
8 files changed, 109 insertions, 105 deletions
diff --git a/games/ladder/Makefile b/games/ladder/Makefile
index ec7093630458..f945045ccdb9 100644
--- a/games/ladder/Makefile
+++ b/games/ladder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ladder
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.srv.net/~kth/ \
ftp://ftp.42.org/pub/unix/games/
diff --git a/games/ladder/files/patch-aa b/games/ladder/files/patch-aa
index f6ee39682ddd..2b082bb7b9e6 100644
--- a/games/ladder/files/patch-aa
+++ b/games/ladder/files/patch-aa
@@ -9,11 +9,3 @@
mvaddstr(r,RM0,"Jump = Space Stop = Other");
r++;
mvprintw(r,LM,"Play Speed: %d",speed + 1);
---- ladder.h.org Wed Feb 18 19:19:51 1998
-+++ ladder.h Wed Feb 18 19:26:29 1998
-@@ -1,4 +1,4 @@
--#include <ncurses/curses.h>
-+#include <ncurses.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <signal.h>
diff --git a/games/ladder/files/patch-ab b/games/ladder/files/patch-ab
index c2d28576ecf7..3c21d7d47020 100644
--- a/games/ladder/files/patch-ab
+++ b/games/ladder/files/patch-ab
@@ -1,11 +1,14 @@
---- Makefile.org Mon Oct 27 00:15:08 1997
-+++ Makefile Wed Feb 18 22:34:28 1998
-@@ -3,11 +3,11 @@
+--- Makefile.orig Sun Oct 26 15:15:08 1997
++++ Makefile Sat Aug 11 00:15:35 2001
+@@ -2,12 +2,13 @@
+ SRCS = ladder.c lplay.c ltime.c lscore.c lscreens.c
OBJS = ladder.o lplay.o ltime.o lscore.o lscreens.o
- CC = gcc
+-CC = gcc
-CFLAGS = -O -pedantic -I/usr/include/ncurses
-+CFLAGS = -O2 -pedantic -Wall
++CC ?= gcc
++CFLAGS ?= -O
++CFLAGS += -pedantic -Wall
LDFLAGS = -s
M4 = m4
LIBS = -lncurses
@@ -14,7 +17,7 @@
.SUFFIXES: .o .c .m4
-@@ -21,6 +21,14 @@
+@@ -21,6 +22,14 @@
$(CC) -o $(TARGET) $(LDFLAGS) $(OBJS) $(LIBS)
$(OBJS): ladder.h
@@ -25,97 +28,7 @@
+all: $(TARGET)
+
+install:
-+ install -c -s -o games -g bin -m 4555 ladder ${PREFIX}/bin
++ install -c -s -o root -g games -m 2555 ladder ${PREFIX}/bin
# ladder.c: ladder.m4
---- ladder.c.org Mon Oct 27 00:07:23 1997
-+++ ladder.c Wed Feb 18 22:33:55 1998
-@@ -14,7 +14,7 @@
- char *d = t;
- int i;
-
-- for( ; *s; *s++ )
-+ for( ; *s; s++ )
- if( *s & 0200 )
- for( i = 210 - (unsigned char)*s; i; i-- )
- *d++ = ' ';
---- lplay.c.org Tue Nov 11 20:01:51 1997
-+++ lplay.c Wed Feb 18 22:33:56 1998
-@@ -54,7 +54,7 @@
- mvaddstr(row,0,t);
-
- /* find points of release */
-- for( s = t; s = strchr(s,CRELEAS); s++ )
-+ for( s = t; (s = strchr(s,CRELEAS)); s++ )
- {
- rel->row = row;
- rel->col = s - t;
-@@ -67,7 +67,7 @@
-
- /* find lad */
- for( row = 0; row < DIMROW; row++ )
-- for( s = t = bg[row]; s = strchr(s,CLAD); s++ )
-+ for( s = t = bg[row]; (s = strchr(s,CLAD)); s++ )
- {
- /* nasty, check for CLAD's surrounded by CFREEs */
- if( s[-1] != CFREE || s[1] != CFREE )
-@@ -433,6 +433,8 @@
- else
- dir = STOP;
- break;
-+ default:
-+ break;
- }
- }
-
---- lscore.c.org Mon Oct 27 00:07:24 1997
-+++ lscore.c Wed Feb 18 22:33:56 1998
-@@ -21,7 +21,7 @@
- FILE *lfp;
-
- for( i = 3; i; i-- )
-- if( lfp = fopen(lf,"r") )
-+ if( (lfp = fopen(lf,"r")) )
- {
- fclose(lfp);
- sleep(2);
-@@ -47,7 +47,7 @@
-
- lock_score();
- memset(scores,0,sizeof(scores));
-- if( sfp = fopen(sf,"r") )
-+ if( (sfp = fopen(sf,"r")) )
- {
- for( scp = scores; scp < &scores[MAXSCORE]; scp++ )
- if( fscanf(sfp,"%d%d%d%d",
-@@ -67,8 +67,8 @@
- SCORE *scp;
- for( scp = &scores[MAXSCORE]; scp > scores; scp-- )
- if( scp[0].score > scp[-1].score ||
-- scp[0].score == scp[-1].score &&
-- scp[0].level >= scp[-1].level )
-+ (scp[0].score == scp[-1].score &&
-+ scp[0].level >= scp[-1].level ))
- {
- SCORE tmp = scp[0];
- scp[0] = scp[-1];
-@@ -113,7 +113,7 @@
- if( scores[i].score )
- {
- printw("%5d00 %2d ",scores[i].score,scores[i].level + 1);
-- if( pw = getpwuid(scores[i].uid) )
-+ if( (pw = getpwuid(scores[i].uid)) )
- addstr(pw->pw_name);
- else
- printw("UID %d",scores[i].uid);
---- ltime.c.org Mon Oct 27 00:07:24 1997
-+++ ltime.c Wed Feb 18 22:33:56 1998
-@@ -2,6 +2,7 @@
- #include <sys/types.h>
- #include <sys/times.h>
- #include <sys/time.h>
-+#include <unistd.h>
-
- static void waittcs(unsigned int tcs)
- {
diff --git a/games/ladder/files/patch-ac b/games/ladder/files/patch-ac
new file mode 100644
index 000000000000..3dfe7265028e
--- /dev/null
+++ b/games/ladder/files/patch-ac
@@ -0,0 +1,11 @@
+--- ladder.c.org Mon Oct 27 00:07:23 1997
++++ ladder.c Wed Feb 18 22:33:55 1998
+@@ -14,7 +14,7 @@
+ char *d = t;
+ int i;
+
+- for( ; *s; *s++ )
++ for( ; *s; s++ )
+ if( *s & 0200 )
+ for( i = 210 - (unsigned char)*s; i; i-- )
+ *d++ = ' ';
diff --git a/games/ladder/files/patch-ad b/games/ladder/files/patch-ad
new file mode 100644
index 000000000000..eef6d35ba017
--- /dev/null
+++ b/games/ladder/files/patch-ad
@@ -0,0 +1,29 @@
+--- lplay.c.org Tue Nov 11 20:01:51 1997
++++ lplay.c Wed Feb 18 22:33:56 1998
+@@ -54,7 +54,7 @@
+ mvaddstr(row,0,t);
+
+ /* find points of release */
+- for( s = t; s = strchr(s,CRELEAS); s++ )
++ for( s = t; (s = strchr(s,CRELEAS)); s++ )
+ {
+ rel->row = row;
+ rel->col = s - t;
+@@ -67,7 +67,7 @@
+
+ /* find lad */
+ for( row = 0; row < DIMROW; row++ )
+- for( s = t = bg[row]; s = strchr(s,CLAD); s++ )
++ for( s = t = bg[row]; (s = strchr(s,CLAD)); s++ )
+ {
+ /* nasty, check for CLAD's surrounded by CFREEs */
+ if( s[-1] != CFREE || s[1] != CFREE )
+@@ -433,6 +433,8 @@
+ else
+ dir = STOP;
+ break;
++ default:
++ break;
+ }
+ }
+
diff --git a/games/ladder/files/patch-ae b/games/ladder/files/patch-ae
new file mode 100644
index 000000000000..f7545c84d287
--- /dev/null
+++ b/games/ladder/files/patch-ae
@@ -0,0 +1,40 @@
+--- lscore.c.org Mon Oct 27 00:07:24 1997
++++ lscore.c Wed Feb 18 22:33:56 1998
+@@ -21,7 +21,7 @@
+ FILE *lfp;
+
+ for( i = 3; i; i-- )
+- if( lfp = fopen(lf,"r") )
++ if( (lfp = fopen(lf,"r")) )
+ {
+ fclose(lfp);
+ sleep(2);
+@@ -47,7 +47,7 @@
+
+ lock_score();
+ memset(scores,0,sizeof(scores));
+- if( sfp = fopen(sf,"r") )
++ if( (sfp = fopen(sf,"r")) )
+ {
+ for( scp = scores; scp < &scores[MAXSCORE]; scp++ )
+ if( fscanf(sfp,"%d%d%d%d",
+@@ -67,8 +67,8 @@
+ SCORE *scp;
+ for( scp = &scores[MAXSCORE]; scp > scores; scp-- )
+ if( scp[0].score > scp[-1].score ||
+- scp[0].score == scp[-1].score &&
+- scp[0].level >= scp[-1].level )
++ (scp[0].score == scp[-1].score &&
++ scp[0].level >= scp[-1].level ))
+ {
+ SCORE tmp = scp[0];
+ scp[0] = scp[-1];
+@@ -113,7 +113,7 @@
+ if( scores[i].score )
+ {
+ printw("%5d00 %2d ",scores[i].score,scores[i].level + 1);
+- if( pw = getpwuid(scores[i].uid) )
++ if( (pw = getpwuid(scores[i].uid)) )
+ addstr(pw->pw_name);
+ else
+ printw("UID %d",scores[i].uid);
diff --git a/games/ladder/files/patch-af b/games/ladder/files/patch-af
new file mode 100644
index 000000000000..c1f515e0ce0e
--- /dev/null
+++ b/games/ladder/files/patch-af
@@ -0,0 +1,10 @@
+--- ltime.c.org Mon Oct 27 00:07:24 1997
++++ ltime.c Wed Feb 18 22:33:56 1998
+@@ -2,6 +2,7 @@
+ #include <sys/types.h>
+ #include <sys/times.h>
+ #include <sys/time.h>
++#include <unistd.h>
+
+ static void waittcs(unsigned int tcs)
+ {
diff --git a/games/ladder/files/patch-ag b/games/ladder/files/patch-ag
new file mode 100644
index 000000000000..ff629e032dfc
--- /dev/null
+++ b/games/ladder/files/patch-ag
@@ -0,0 +1,8 @@
+--- ladder.h.org Wed Feb 18 19:19:51 1998
++++ ladder.h Wed Feb 18 19:26:29 1998
+@@ -1,4 +1,4 @@
+-#include <ncurses/curses.h>
++#include <ncurses.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <signal.h>