aboutsummaryrefslogtreecommitdiff
path: root/games/lbreakout/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-25 02:55:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-25 02:55:56 +0000
commit32a70a32ed5ee67ddf138f983ffde437b65bd26e (patch)
tree68fbc9f9aa4a5dde53411314f74b344786cbf817 /games/lbreakout/Makefile
parent5f9ab5f5f35c7954d1f1e659cfe81dec15fb985f (diff)
downloadports-32a70a32ed5ee67ddf138f983ffde437b65bd26e.tar.gz
ports-32a70a32ed5ee67ddf138f983ffde437b65bd26e.zip
Notes
Diffstat (limited to 'games/lbreakout/Makefile')
-rw-r--r--games/lbreakout/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index d41f18a9649a..478fc906560a 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -3,25 +3,29 @@
PORTNAME= lbreakout
PORTVERSION= 010315
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= SF/lgames/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice clone of classical Breakout game
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_SDL= sdl
USES= gmake
GNU_CONFIGURE= yes
LIBS+= -lcompat
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
- 's|"SDL/SDL|"SDL|g ; \
- s|<SDL/SDL|<SDL|g'
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
pre-install:
${MKDIR} ${STAGEDIR}/var/games/${PORTNAME}
+post-install:
+ ${MV} ${STAGEDIR}/var/games/${PORTNAME}/lbreakout.hscr \
+ ${STAGEDIR}/var/games/${PORTNAME}/lbreakout.hscr.sample
+
.include <bsd.port.mk>