aboutsummaryrefslogtreecommitdiff
path: root/games/leela-zero
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-12 22:23:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-12 22:23:17 +0000
commitb16627b31a26aa80166b00b4ff85fc2c11181c44 (patch)
treef37764c01e80f2e56cd96cdf997607d9bbf54683 /games/leela-zero
parent9fc882a25d1717ef448d8159346e8e7103f6d771 (diff)
downloadports-b16627b31a26aa80166b00b4ff85fc2c11181c44.tar.gz
ports-b16627b31a26aa80166b00b4ff85fc2c11181c44.zip
games/leela-zero: Add the patch preventing rejection of CPU-only OpenCL providers
Notes
Notes: svn path=/head/; revision=504045
Diffstat (limited to 'games/leela-zero')
-rw-r--r--games/leela-zero/Makefile1
-rw-r--r--games/leela-zero/files/patch-src_OpenCL.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/leela-zero/Makefile b/games/leela-zero/Makefile
index 6585b57ec84d..bf38667618fd 100644
--- a/games/leela-zero/Makefile
+++ b/games/leela-zero/Makefile
@@ -3,6 +3,7 @@
PORTNAME= leela-zero
DISTVERSIONPREFIX= v
DISTVERSION= 0.17
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= yuri@FreeBSD.org
diff --git a/games/leela-zero/files/patch-src_OpenCL.cpp b/games/leela-zero/files/patch-src_OpenCL.cpp
new file mode 100644
index 000000000000..7dcd9e6ee924
--- /dev/null
+++ b/games/leela-zero/files/patch-src_OpenCL.cpp
@@ -0,0 +1,11 @@
+--- src/OpenCL.cpp.orig 2019-06-12 22:15:19 UTC
++++ src/OpenCL.cpp
+@@ -785,7 +785,7 @@ OpenCL<net_t>::OpenCL(int gpu, bool silent) {
+ bool preferred = (gpu == id);
+
+ if (((this_score > best_score)
+- && (d.getInfo<CL_DEVICE_TYPE>() != CL_DEVICE_TYPE_CPU))
++ /*&& (d.getInfo<CL_DEVICE_TYPE>() != CL_DEVICE_TYPE_CPU)*/) // Do not reject CPU-only OpenCL providers because some users only have that (ex. pocl)
+ || preferred) {
+ best_version = opencl_version;
+ best_platform = p;