aboutsummaryrefslogtreecommitdiff
path: root/games/legesmotus
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-18 08:47:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-18 08:47:31 +0000
commit03cf2e0916b5eadaaa5d50ad8034f0f648102053 (patch)
tree2e7efe898622c1415ef112d3cb11991db31f4790 /games/legesmotus
parent0d005beba9e28875a2ea08dc3dd55d446547630a (diff)
downloadports-03cf2e0916b5eadaaa5d50ad8034f0f648102053.tar.gz
ports-03cf2e0916b5eadaaa5d50ad8034f0f648102053.zip
Conditionalize the addition of -Wno-c++11-narrowing to fix clang6 errors
in CFLAGS to affect clang-based archs. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=479998
Diffstat (limited to 'games/legesmotus')
-rw-r--r--games/legesmotus/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/legesmotus/Makefile b/games/legesmotus/Makefile
index cabac7223fa4..1be946671e95 100644
--- a/games/legesmotus/Makefile
+++ b/games/legesmotus/Makefile
@@ -18,10 +18,11 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" \
--mandir="${PREFIX}/man" \
--datadir="${DATADIR}"
-USES= gmake
+USES= compiler gmake
MAKE_ENV= XDIR=${LOCALBASE}
-CXXFLAGS+= -Wno-c++11-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
PORTDATA= *